Question about 1999 Buick Century

1 Answer

Transmission sensor/switch I have a 1999 Buick Century that has a "chug" to it and the check engine light come on for a day or so then goes out. I had it put on the computer today and it came up with the code the transmission sensor/switch is bad. I was just wondering if this sound like the right symtom for that switch to be bad? Do I have to go back to Buick for this part? or its it something that is after market?

Posted by on

  • Msashley0183 Feb 03, 2009

    i have the same problem, also,i have a 2004 Dodge Neon and when i start it up its stalls then **** and pull off.Even when i stop sometimes its does it.Then my engine light came on.I went to go get it in the computer and they said it was a transmission switch..So i wondering If thats all it could be?LET ME KNOW!!!!Thanks

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

Doe it stall? Or just drive like it didn't downshift? possibly the TCC solenoid in the transmission if it stalls when coming to a stop.

Posted on Dec 30, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1999 buick century stalls and chuggs at random


Try first to replace the fuel filter. Then if that don't work, have the sensors checked by an auto technician with a diagnostic tool that interfaces with the cars computer. Most places will do this for free.

Sep 28, 2012 | 1999 Buick Century

1 Answer

I have a 1999 buick century with a 3.1 engine stop running while driving,ran codes came back with crank sensor,multiply cylinder misfire changed crank sensor,cleared codes,will start,but idles very rough...


Did you replace the crank sensor that is in the engine block between the engine and transmission? it has two and the one by the pulley hardly ever goes bad.

Dec 12, 2010 | 1999 Buick Century

1 Answer

Cold Start and TRanny issues.


A neutral park switch keeps you from activating the starter in drive or reverse. It also turns the reverse lights on. Its on top of the transmission at the end of the shift cable . If it does not turn over in park try it in neutral, Clean battery cables. Check fuel pressure. Is check engine light on?

Jul 01, 2009 | 1989 Buick Century

1 Answer

1995 Buick century struggles to go into 2nd gear


have u checked fuel filter ,if thats ok get a back pressure test done on catalytic converter.

Jun 04, 2009 | 1995 Buick Century

1 Answer

My car is jerking while accelerating and reaching certain RPM


clean mass air flow sensor check for mil light

Jun 01, 2009 | 2002 Buick Century

1 Answer

Buick 1999 century replaced the sensor light and still comes on.


your buick century has a low coolant level sensor located in the passenger side of the radiator , sometiomes the sensor get covered with coolant sludge and will show that the cooling system is not filled , sometime the radiator is just still low on coolant . check the radiator when the engine is cold ( IF HOT WAIT !!! 30 mins ) and make sure the level is above the sensor.

Feb 06, 2009 | 1999 Buick Century

3 Answers

1999 Buck Regal Stalls While Driving


Possible solution to stalling '99 Buick. My '99 Buick Century would die for no apparant reason with no error codes. After 4 days at a Buick dealership and many frustrated mechanics, the problem was corrosion from under the battery location. The wiring harness had small amounts of corrosion internally. Check the wiring under the battery for any corrosion. This has been the problem on more than 1 vehicle that we are aware of. No service bulletin has been issued by Buick.

Nov 23, 2008 | 1999 Buick Century

2 Answers

1995 buick century transmission trouble


Most likely causes is the OD shift solenoid or less likely the VSS

Oct 25, 2008 | 1995 Buick Century

1 Answer

1999 Buick Century V-6


What is the code? I suspect the MAF (mass air flow sensor) but until I know for sure I am only guessing

Sep 01, 2008 | 1999 Buick Century

3 Answers

I have a 2002 buick century and just had three lights come on....trac off...check engine...and anti-lock. any ideas


One of the things you will want to check is your speed sensors, some times they will also cause your ABS light to come on, and they relate to your Transmission electronics that is why the Check Engine light comes on.

Aug 22, 2008 | 2001 Buick Century

Not finding what you are looking for?
1999 Buick Century Logo

295 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

70365 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6878 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...