Question about 2001 Oldsmobile Bravada

1 Answer

Check engine light comes on with repeated fixes

Have had several problems replaced o2 sensors abs sensors hub bearing assemblies and evap canister purge solenoid and keeps reading a code of small leak detected in emissons . Any ideas??? code p402 404 also the heater motor always is running maybe a short??

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have seen the rubber o ring on the gas cap leak or have dirt under it. Newer chevy pickups are know for this. causes code 402 normally. check your blower motor resistor on the heater box this can cause the fan to run all the time.

Posted on Feb 16, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

I have a 2003 pontiac aztek i replaced spark plugs a few days ago and itbtook me 3 days to change them 2 of them was fused in there cuz someone had put them in hot. I had to retap them to put them in. I...


according to your codes your O2 sensor closes to the motor by cylinder 1 is malfunctioningp0135. youalso have a bad wheel sensor right front.this is causing the trans to shift wrong c0035 whick gives you the p1811 code (long shift) if you replace that o2 sensor ( there are usually like 4 on a V6) and replace the front passenger side wheel sensor and reader plate then you problems should correct and the lights should go off after you run the car for a bit. hope it helps.

Feb 02, 2015 | Pontiac Cars & Trucks

2 Answers

Can bad hub bearings make the abs and tc light to come on in a 2003 gmc yukon


Absolutely YES! The bearing and hub assembly contains the wheel speed sensor which is used by the Antilock Brake System (ABS) and the Traction Control (TC) system to see when a wheel is trying to lock up and cause skidding. The ABS will release the hydraulic pressure to the brake on that wheel and the traction control will reduce engine speed to prevent the wheel from locking up or causing you to spin out.
Many GM vehicles also commonly have problems with the wiring harnesses to the wheel speed sensors that can cause this same problem. The computer does not know WHY it cannot read the speed sensor signal. It only knows that it is not getting the signal and this is why the light is turned on. Before paying the BIG BUCKS for a wheel bearing and hub assembly, it would be wise to make absolutely certain that the problem is not being caused by a fault in the wiring harness. I have seen many mechanics automatically replace the wheel bearing only to find out that the problem still exists because they did not take the time to DIAGNOSE the problem. The fault code description says "Wheel Speed Sensor CIRCUIT fault." They see "speed sensor and automatically replace the sensor without actually checking the circuit. Not a problem unless you are the customer having to PAY for this type of guess-work!!!

There are wiring harness repair kits available for MOST GM vehicles just for this purpose.

I have included pictures of the bearing and hub assembly and the wiring harness kit to help you understand what we are talking about here.

Note the electrical connector sticking out of the hub assembly. This is the wires to the speed sensor. In the other picture, the connector at the end of the wiring harness is what plugs into the connector in the hub assembly. The other end of it gets spliced into the main vehicle harness in the engine compartment, after cutting the original harness out.

WHEEL BEARING AND HUB ASSEMBLY



dttech_40.jpg WIRING HARNESS REPAIR KIT

dttech_41.jpg

Aug 20, 2011 | 2003 GMC Yukon

2 Answers

My services traction light comes on on my 05 chevy impala and my abs light doesnt go off neither does my trac light. What could be the problem? and how much would u think i looking at in cost to fix it?


Very common problem. The MOST LIKELY cause is that you have a front wheel speed sensor that is not working properly. This could be due to a bad front wheel bearing assembly or it could be a wiring problem. GM has had a LOT of problems with the wiring harnesses. A company named "DORMAN" makes a harness repair kit. (See picture below) The Dorman part number is: Part Number: 970-041 The wheel speed sensor itself and the wheel bearing come as a complete "HUB" assembly. The wheel bearing should be checked for looseness and the speed sensor should be tested at the speed sensor connector for AC voltage output when the wheel is spinning. If the bearing or the sensor is bad, then you must replace the hub assembly. If this is the case, I recommend using the "Timken" hub assemblies. They are more expensive, but are much better quality. I have had many problems using the cheaper brands. (See picture below) If the wheel bearing and sensor is OK, then the harness should be replaced. You will have to scan your Antilock Brake System (ABS) module to find out which one is causing the light to come on. As far as cost...it depends on exacltly WHAT it needs and WHO is doing the job. There also may be more than one speed sensor giving you problems. Your best bet is to get it diagnosed and get an estimate of repairs. If they try to sell you a hub assembly, ASK them if they actually TESTED the speed sensor. MOST mechanics out there will just throw a speed sensor (hub assembly) at the problem if they have a speed sensor code, only to find out later that the problem is in the harness. Of course, the customer is the one who ends up paying for their incompetence when this happens. dttech_36.jpg
SPEED SENSOR WIRING HARNESS REPAIR KIT


dttech_37.jpg WHEEL BEARING, SPEED SENSOR AND HUB ASSEMBLY

Aug 06, 2011 | 2005 Chevrolet Impala

2 Answers

Abs light on wheels shaking


If your ABS light is light it could mean several things. First check to make sure that your parking break is all the way down. Secondly, it could be cause by you not having enough fluid for your breaks.

Jul 28, 2011 | 2003 Mercury Mountaineer

2 Answers

P1443 code problem. How do I fix this?


P1446 - EVAP Canister Vent Control Valve Close
EVAP canister vent control valve remains closed under specified driving conditions.

This solenoid valve responds to signals from the ECM. When the ECM sends an ON signal, the coil in the solenoid valve is energized. A plunger will then move to seal the canister vent. The ability to seal the vent is necessary for the on board diagnosis of other evaporative emission control system components.

This solenoid valve is used only for diagnosis, and usually remains opened. When the vent is closed, under normal purge conditions, the evaporative emission control system is depressurized and allows EVAP Control System (Small Leak) diagnosis.

The EVAP canister vent control valve is located on the EVAP canister and is used to seal the canister vent.

Symptoms:
- Engine Light ON (or Service Engine Soon Warning Light)

About the possible causes that your must solved:
- EVAP control system pressure sensor and the circuit
- Blocked rubber tube to EVAP canister vent control valve
- EVAP canister vent control valve
- Water separator
- EVAP canister is saturated with water


Hope this helps.

Apr 27, 2011 | Mercury Cougar Cars & Trucks

4 Answers

ABS light is on repair shop says wheel bearing is bad


Hello apetersen08,

Yes, a bad wheel bearing can set the ABS light. There are ABS sensors in the hub assemblies.

Regards,
netvan

Mar 08, 2011 | 2004 Buick Rainier

1 Answer

P1443 code How do I fix this code problem on my 97 Ford ranger?


P1443 is the Evaporative Emission Control System Control Valve. Any time you get this code always check your gas cap. If it is not installed all the way, or leaks, it can cause the evap emission code to come up. If the cap is okay...

The problem is probably caused by the Canister Purge Assembly. This assembly connects the intake manifold to the charcoal canister and the assembly is made up of hoses, a valve and a sensor. On the 1997 Ranger, it is located near the front of the engine compartment on the driver's side (the canister is right behind the driver's side headlight). Apparently, if there are any cracks in the hoses, or if the valve or the sensor wears out, this will cause the check engine light to come on, and return the P1443 code.

Part numbers for the canister purge solenoid/flow sensor assemblies:

F57Z-9C987-AB Canister Purge Solenoid/Flow Sensor
Assembly - 2.3L F57Z-9C987-CA Canister Purge Solenoid/Flow Sensor
Assembly - 3.0L F57Z-9C87-BA Canister Purge Solenoid/Flow Sensor
Assembly - 4.0L

Part cost = $65 to $100 depending on engine size - good luck :O)

Feb 17, 2011 | Ford Ranger Cars & Trucks

1 Answer

Abs light on and traction control light and service engine soon light on


One of your wheel speed sensors is not functioning and this is why you are having the abs and trac control light. These are on the back side of your wheel bearing hub assembly and you may have a broken wire or a damaged sensor. Check all four of these visually and with a continuity tester to find the bad one. The check engine light is usually emissions related and I would suggest replacing your O2 sensor.

Jun 21, 2009 | 2000 Cadillac DeVille

3 Answers

Buick rendevousz headaches


I own the 2002 Buick Rendezvous CX and I've encountered the same problems listed here. The ABS / Traction Control Lamp stays on and was throwing a code for the left wheel speed sensor as well as an anti-lock brake code (both in the wheel bearing hub assembly). I replaced the left and right front wheel hub assembly yet this did not eliminate the abs codes. 
Ultimately, I traced this problem to a break in the wire that leads to the left hub assembly. Although the sensor was properly connected, the wire (which is encased in a plastic housing) was broken. This is the wiring which leads from the abs wiring harness under the hood down to the left wheel abs sensor. 
I would suggest that you simply remove the left wheel and inspect the wire that leads to the abs sensor (there is only one wire on each wheel). Mine literally fell apart when I removed the plastic housing around the wire. I spliced the wire together and put it back in the plastic housing. After this, my abs codes disappeared and my anti-lock brakes began working again!
This is a simple fix that many people spend $1000 + on by replacing the hub assembly which does not fix the problem.

Aug 20, 2008 | 2002 Buick Rendezvous

Not finding what you are looking for?
2001 Oldsmobile Bravada Logo

195 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...