Question about 1997 Chevrolet Monte Carlo

1 Answer

'97 Monte Carlo

I have a Monte Carlo that has a bad smell in the engine, I'm having a hard time starting it sometimes, and the car is worse on gas than usual. I went through a full tank of gas in a week not driving much at all.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 160 Answers

Sulphur smell either bad o2 sensors or a bad cat

Posted on Nov 12, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

97 Monte Carlo LS getting hot while driving then cools off when letting off gas


have a coolant pressure test done. Have the radiator cores checked for blockage. Sometimes when an engine has sat for a period of time, rust and scale form in the water jackets of the engine. ON running ,this breaks away and blocks the cores of the radiator Other times the old motor tolerates a partially blocked radiator when a relative new motor needs all the cores free to maintain the temperature.

Jun 14, 2013 | 1997 Chevrolet Monte Carlo

1 Answer

Hard start and engine hesitation at highway speed


The PO441 has to do with your HO2S 2 (Oxygen sensor). You need to check to make sure the wire is not off of the sensor and check the grounds to the Oxygen sensor. Could be a bad Oxygen Sensor. The other code has to do with your Evap system Purge solenoid circuit. Has to do with detecting an improper voltage level. Could be a shorted Purge solenoid.

Sep 11, 2009 | 1997 Chevrolet Monte Carlo

2 Answers

Out of blue 97 3.1 monte carlo engine start running bad


Check firing order 1,3,5 in the back next to firewall 2,4,6 in front check coil packs. If o.k you could have burnt valves. As for the knocking If its a heavy kock and it happens all the time even at idle it could be the main bearings on the crankshaft.

Mar 22, 2009 | 1997 Chevrolet Monte Carlo

1 Answer

My 2001 monte carlo misses out, no engine lite is on.


The rev limiter won't allow it to rev above 4000 in park. Will it go above 4000 on the road. Does it miss at ldle or under a load.

Mar 10, 2009 | 1992 Buick LeSabre

1 Answer

Monte carlo


you might check the crank and cam sensors

Jan 29, 2009 | 2004 Chevrolet Monte Carlo

3 Answers

97 monte carlo will not start


if you remove the battery and charge it than reinstall (make shore all lighting and non essentals are off) and if the car runs for awhile then the problem most likely is with the alternator

Oct 12, 2008 | 1997 Chevrolet Monte Carlo

1 Answer

Car won't start - Monte Carlo SS 2004


there is a coil pack for spark plug wires that could be arking to the engine(which you can see at night very well) or one of the sensors have gone bad , test the night visual of the coil pack after testing for spark at the spark plugs. so first you need to know if you have spark ,if you do then it may be one of the timming sensors

Oct 08, 2008 | 2004 Chevrolet Monte Carlo

1 Answer

2000 monte carlo starting problems


Most likely, this is your starter bendix going bad. Time for a new starter. Hope this helps. Good luck.

Aug 25, 2008 | 2000 Chevrolet Monte Carlo

Not finding what you are looking for?
1997 Chevrolet Monte Carlo Logo

Related Topics:

277 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...