Question about 1993 Chrysler Imperial

1 Answer

Sometimes will not start and digital dashboard stops working.

Sometimes my Chrysler Imperial will not start, it may run for a second but then shuts off. Also at the bottom of the speedometer it looks like a small snow flake is flashing. Sometimes while starting the car on the information center (located at the top center of the windsheld) I will get a module self test showing E2 - 0 and E3 - 0 and than self test complete message.
One other thing sometimes when it does start the digital dashboard / speedometer and the information center will shutoff/ It will show a speed of zero while moving and the small snow flake is flashing. Also while this is happening the sometimes alarm set light will come on but not always

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Just had this problem on one of my homies cars. We thought it was the fuel pump, but it wound up being the anti theft. Locking all the doors and unlocking it from the drivers side (As recommended in the owners manual. ) with the key didn't work. But it did work locking all the doors and unlocking it with the key from the passengers side. Started right up!

Posted on Dec 16, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Pretty major problem here. My '92 Chrysler Imperial entered the "safe mode" for it's transaxle, then proceeded to stall on the next stop. It now will not start again. I need to fix this ASAP.


it is in limp mode because of a problem in the transmission
you will have to run the fault codes to determine the area of failure
areas to check for will be TCM , turbine speed sensor, servos, pump pressure sensors
take it to an accredited auto transmission specialist shop
it appears that the transmission control module doesn't know what ratio to select so at this point I would be wary of "new box" comments until the reason can be properly explained

Oct 12, 2016 | 1992 Chrysler Imperial

1 Answer

Stoped runing andwill not start


If it stopped in a second, the cause is electrical problem. If it stopped more gradually, over several seconds, it is usually fuel related. If you put the key in the ignition and turn it to run, not start, are there lights on the dashboard panel? If you turn the key to the start position, does the engine rotate? Sometimes I have to turn the key to start position several times before it works and the engine rotates.

Jan 31, 2013 | 2009 Chrysler PT Cruiser

1 Answer

Tail lights on my 1991 Imperial stopped working


check the light switch and harness that plugs into it. my friend has one and we replaced the switch and it fixed it.BE VERY CAREFUL WITH THE HARNESS, THEY HAVE A TENDENCY TO MELT CINCINNATI-ED

May 25, 2010 | 1991 Chrysler Imperial

2 Answers

Our 1983 chrysler imperial has had some issues within the past few months. My husband rebuilt the intake thinking this would help. The car has been idleing high in park and very low when in reverse to the...


hi There
I have read your report. Yes your dad is right. Check the alternator. Because if it goes bad your car will loose power and it would be hard for your car if had lights radio a/c on. The relay in alternator dose go bad and sometimes you get a bad one also. Try this tip when you start your car take the positive cable off the battery and if it dies. Then it's your alternator. just remember that little trick. Hope this info helps. and thank you for writing to fix ya.
Best Regards Richard

Dec 04, 2009 | 1983 Chrysler Imperial

2 Answers

My dash lights are not working the gauges fuse is


good be dimmer switch, but only if all dash lights are out,like radio heater control, cig light,if those still work then i would say its bulbs.

Oct 03, 2009 | 1990 Chrysler Imperial

2 Answers

Car will start for a few seconds then dies.


Still sounds fuel related to me. Getting minimal fuel enough to start & or rev, but not maintaining proper pressure required. Try this. Get a can of WD-40 ready, remove air intake hose at throttle body. Start car & when it starts to begin to die, spray some WD-40 into front of throttle body & see if engine continues to run, as long as you keep giving it squirts of 1-2 seconds. If it does, change fuel filter first, but be prepared to do pump too. If you can get a fuel pressure test done on it, that would be even better. Let me know what happens.

Jul 24, 2009 | 1991 Chrysler Imperial

1 Answer

Car wont stay running after initial start up?


Will it stay running if you keep the pedal depressed. If so you have a Idle Air Control valve issue. If it wont run at all it may be a bad fuel pump

Jul 14, 2009 | 1991 Chrysler Imperial

Not finding what you are looking for?
1993 Chrysler Imperial Logo

253 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

chargerhp
chargerhp

Level 3 Expert

813 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...