Question about 1998 Ford Explorer

1 Answer

Lacks power I had my alternator replaced 2 weeks ago, and now my explorer is spitting and sputtering at me, as if it were cold out. Check engine light flashes at me whe nI try to "kick it down" a little bit, but this light has been on since I bought it 2 yrs ago. Never any problems til the alt. was replaced. I had plugs/wires replaced in feb of 08 along with new fuel pump and filter also

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 962 Answers

Every time the battery is removed or current is cut. the ECU (computer unit) deprograms. Try disconnecting the battery at the negative side. leave it for a while. Then reconnect the battery and the computer is supposed to reprogram. if it does not do it right away. Try it several times.

Posted on Nov 02, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Lights make 1987 chevy s-10 pickup bog down and spit and sputter when turned on while driveing


I suspect that something has caused a short of one of the diodes in your alternator and the alternator is only putting out 1/3 of the current it should. Maybe even 2 diodes are out. Have the alternator checked.

Apr 12, 2014 | 1987 Chevrolet S-10 Pickup

1 Answer

Spitting and sputtering like not getting fuel


It may have fouled your plugs, but you can tke them out and clean them. Use a small blade and scrape the carbon off.
You could also take the egr valve off and try to clean it. Use a wire brush. also clean as best you can the passages under the valve, they can get plugged with carbon. Use a new gasket when you bolt the egr valve back down. Keep trying to get the fuel filter off, but the egr cleaning should help.

Nov 27, 2012 | 1997 Honda Accord

1 Answer

My 1994 grand marquis spits & sputter when the engine is cold. Also sometimes loses power after it's left ideling too long sometime I don't have enough power to get up hills we replace the


If the check engine light is not on, I doubt there is much you can do.
It sounds like one of the engine temp sensors or one of the other sensors. The engine temp sensor and the intake air temp sensor tell the computer what the outside air temp is and the coolant temp which allows the computer to regulate the amount of fuel going thru the injectors. Generally if one of the sensors has failed the check engine light should be on.
It could be low fuel pressure too.
You may have to have a shop check the sensors with a scanner and the fuel pressure with a gauge.

Sep 03, 2012 | 1994 Mercury Grand Marquis

1 Answer

When u push on the gas it spits and sputters, it ran out of gas like 2 weeks ago and yes sometimes i do let it run low on gas. It spits and sputters when i turn a corner or go up a hill


Could be a clogged fuel filter, and or dirty fuel injectors. Try running some strong injector cleaner through it. It may take 2 or 3 times before it cleans the injectors out fully.

Feb 02, 2011 | 1992 Oldsmobile Cutlass Ciera

1 Answer

Check engine light is on and now the truck is spitting and sput


i would take it back. they should cover it. sounds like mass air flow sensor. if it was barelly detailed it water might of seeped into the intake thus sucking small amount of water which then causes sputtering and a little lack of power.

Nov 06, 2009 | 2001 Nissan Frontier Crew Cab

2 Answers

92 ranger - piece of **** rebuilt starter ?


run scanner for trouble codes, some auto parts store will do this for free, check starter solenoid, check voltage at battery , 12+volts not started ,  14+ amps when running 

Oct 04, 2009 | 1992 Ford Ranger

1 Answer

Sputters and lack of power when cold


check transmission fluid.smell burnt change it and filter.stop up transmission cause power lost when engine cold.change fuel filter. check plugs and wires and coils.also do a compression test.to make sure your valves and rings are good.

May 30, 2009 | 1996 Chevrolet Blazer

2 Answers

2000 explorer 4.0 missing and skipping.


you may have gotten water in your gas it happens alot

Jan 12, 2009 | 2000 Ford Explorer

1 Answer

Lack of power


You need to check a service manual on this but it sounds a bunch like a cold-start valve isn't closing once the engine is warm and this would cause an overly rich fuel-air mix that would gag a warm engine. I don't know if your car is equipped with  one or not. 

Jan 06, 2009 | 1996 Oldsmobile Cutlass Supreme Coupe

Not finding what you are looking for?
1998 Ford Explorer Logo

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...