Question about 2001 Pontiac Aztek

3 Answers

Service Vehicle Soon Light for 2001 Pontiac Aztek

I was driving down the highway and my service vehice soon light came on-I have had a leak with the anti-freeze but I would add frequently-and I looked down and the gage that states the engine temperature stated cold. When I went out to check my car at work the anti-freeze that was put in this morning was already gone.

Posted by on

  • 3 more comments 
  • sadysudetosn Nov 18, 2008

    I have an intermittent problem where the temp gauge goes below cold and the service soon light comes on. Also, it seems that the bright headlight indicator light comes on at the same time. Has anyone had this problem?

  • Anonymous Nov 20, 2008

    I have the same problem with my aztek 2001

  • angienew Nov 22, 2008

    I was driving down the highway a couple nights ago and my '01 aztec dinged & the service engine soon light came on and my temperature gage went to below Cold... I noticed last night that one of my turn signals is out but that wouldn't cause my temperature gage to constantly read below cold... would it? please help! thanks!!!

  • evrim_baykal Nov 26, 2008

    got the same probs. service engine light comes on. engine runs below cold. constantly out of antifreeze/coolant. what gives?

  • jkporcupine Apr 08, 2009

    Same thing with me.
    Light went on (Both service engine soon lights) and temp is below cold.

    The electronics on these things are so screwed up

×

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

What light is flashing with this Service Vehicle Soon message? (Mine had the high beam light flashing and it turned out to be a head light.)

Posted on Nov 14, 2008

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Add coolant, and the problem is solved

Posted on Nov 24, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had the same problem went to auto zone they scanned my aztek 2001 they said the temperature sensor so i replaced and service vehicle light went out went for a drive to test it and 1 hour later light came back replace the sensor again this time it didnt work . any body can tell me whats going on?? thanks dieselreal@hotmail.com mail me with suggest please

Posted on Oct 29, 2009

  • 1 more comment 
  • dieselreal Oct 30, 2009

    ok now i had the stupid problem with the gauge and the service vehicle soon light ok, i solve the problem by flushing my radiator and putting a brand new antifreeze because the one i had was looking like **** also put a new sintetic oil change on it i dont think the oil was the problem but anyway i did that too but i do believe it was because of the antifreeze light went out and didnt come back! for all those people that didnt say how they fix this problem its because they went to to dealer and they fu..them really good and at the end they didnt know that they did to it. i know there are other problems with bcm my that is not my case so if you having the service vehicle soon light and your temperature gauge goes below 0 try this that maybe the cause of it! also sorry about my spelling but i speak spanish too im sure you understand what im saying and i hope this method work for you too

  • babydoll1175 Mar 01, 2011

    I have a 2001 Pontiac Aztek issue. My service soon light came on (its the car picture with wrench). Thought it was related to the oil as it was due to be changed. The mechanic hooked it up to a computer and the code came back as the temperature sensor. A few weeks prior I noticed that the temperature guage was reading correctly (stuck on cold), even when I drove it around town all day. Two days later I was travelling out of town (got an hour away) and without warning it stalled. It had almost a full tank of gas (3/4), conditions were cold with snowy road conditions. It wouldn't start, but would turn over. A gentleman stopped to help and said that it seems to not be getting any gas. He added a gas line antifreeze to fuel and it started within 5 minutes. I let it run for about another 5 minutes before proceeding on my way and 5 minutes later my engine light came on. I didn't want to take any chances so I turned around and headed back home. I'm not sure what's going on but could this be related to the temperature sensor being bad? Or even a thermostat issue or could this be fuel related like the pump (fuel filter replaced July 2010 with 6 injectors). Could anyone help with this issue? I know that the fan runs after the engine has been turned off for awhile too.

  • jmwatfla Apr 14, 2011

    estaba leyendo abajo de frio? y le hizo el flushing y esto lo arreglo?

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why did security and service engine soon lights come on?


Power windows may not work due to faulty body control ...

repairpal.com > Problems > Pontiac > Aztek
Pontiac Aztek Power windows may not work due to faulty body control module. ...2001 Pontiac Aztek140,000Visitor ... air conditioner pump not engaging no power to relay . fix remove fuse # 28 bcm pump engaged air worked also a short term ...

Aug 30, 2015 | 2001 Pontiac Aztek

1 Answer

Service engine soon light is on after leaving gass cap off and driving?


You set a evaporative code by leaving the gas cap off..Put the cap back on ,as long as your fuel level is between a 1/4 to 3/4 the vehicle will eventually do another test and the light will go out

Sep 05, 2011 | 2002 Pontiac Aztek

1 Answer

How do I turn off the service vehicle soon light. and what does it mean. It turned on after I got an oil change.


If you are refering to the maintenance reset proceedure for the oil service light, it is generally reset by turning the key on and depressing the accelerator pedal to the floor either 3 times slowly within 5 seconds. If the light flashes and then stops then it is reset, if it does not repeat the proceedure. If the Check Engine light is on, it requires a scan tool to reset the light.

Jan 19, 2011 | 2001 Pontiac Aztek

1 Answer

The service vehicle soon light is on and the temp gauge is below cold, but it sounds like the fan is still running after the engine is shut off also. What could cause this?


the fan is the temperature sender is or could be faulty ,as for the service light this vehicle isnt listed in a europeon alldata book

Dec 25, 2010 | 2001 Pontiac Aztek

1 Answer

Resetting a service engine soon light on pontiac aztek 2003


take the negitive battery cable off for about five minutes or so and plug it back in and that should fix ur problem

Jul 02, 2010 | 2003 Pontiac Aztek

3 Answers

How do i reset service light on 2001 pontiac aztek?


Before you re-set it, take the car to AutoZone or other similar store to read the code. That way, you know why the service light came on.
Then AutoZone can re-set it for you (all free)!

== or ==

Disconnect the negative cable from the battery for 10 minutes, or more.
When you re-connect the battery cable, the service light will have benn reset. But it will turn back on eventually.

Hope this helps!

Sep 10, 2009 | 2001 Pontiac Aztek

1 Answer

Service vehicle soon


all these lights are probably associated with the abs.. have the abs scanned at an autozone or another shop and probably will determine a front hub assembly (abs sensor ) is bad.

Jul 05, 2009 | 2003 Pontiac Aztek

2 Answers

Abs light, trac light, service engine soon light 2001 Pontiac Grand Am


Sounds like you have a bad wheel speed sensor. You need to have it scanned. Since it's been sitting, it might just be a bad connection to one of the speed sensors.

Jun 01, 2009 | 2000 Pontiac Grand Am GT

2 Answers

Service vehicle soon light


Unplug the battery... i have to do this several times... as every time the gas cap does not get on correctly it comes on...

Oct 30, 2008 | 2001 Pontiac Aztek

1 Answer

My car is a aztec pontiac 2001 and the service engine soon light is on. the code is PO420 but i don't know where to start. what i can do? please help me.


Hi, I look for Aztek information and I've just seen your problem on fixya.com

I give you an adress that will probably helful.
Have a nice day

http://www.obd-codes.com/p0420

Jul 29, 2008 | 2001 Pontiac Aztek

Not finding what you are looking for?
2001 Pontiac Aztek Logo

2,102 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

64052 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...