Question about Alfa Romeo 156

1 Answer

Hi..alfa turns over fine but will not start at all flattened battery trying..problem happened overnite..fuel pump primes ok but plugs dont get wet or no spark..all dash warning lights go out as norm on ign..cheers,kev

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 231 Answers

Check all of your fuses, check to see if you are getting power to your coil. And each point after that. Also check your fuel filter. Good luck and remember to rate all replies that you get, thanx.

Posted on Oct 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My 2004 Dodge Stratus Coupe SXT went out. It was running fine now it tries to start. It' about to start but it won't kick over. Fuel pump was replaced but nothing still.


does it have spark? you may want to check for this and make sure its getting to the plugs. check a plug to see if is wet with gas. if you dont think its getting gas, check and see if you have fuel pressure. if its ok you need a noid light to make sure you are getting a pulse to the fuel injector. if you have fuel and spark, the only other thing is air. if the timing belt is good and the catalytic converter isnt clogged, it should be sucking air (vacum). if the plugs are wet, it may be flooded

Dec 24, 2014 | 2004 Dodge Stratus

1 Answer

Vp commodore won't start


starter,coils ,tune up,fuel filter,

Mar 07, 2013 | Cars & Trucks

1 Answer

I have 1986 Alfa Spider that won't start. Car has been sitting for a year. I replaced battery, fuel tank, fuel sender unit, both fuel pumps. I seems that the in tank pumps is not getting any po


Could be the main or fuel run relay located in the compartment under the luggage rack, passenger side, main relay also, fuse for the fuel relay 8amp. Electronic Control Unit is also located there.

Could be electrical, Hook up a timing light, three leads: Power, Ground, and one that goes around the wire to #1 cyl. Turn the engine over and see if there's firing. Note: u can check all 4 spark plugs this way.

Fuse lead goes to pin 30 of the fuel relay, u can jump 30 across to 57 and check for the pumps running, if not, change-I suggest both relays, main and fuel run relays. Both pumps get their 12v DC from the fuel run relay, both should be running when you switch ignition switch to on, then a tachymetric signal is fed from the coil to the relay to keep it running.

Jun 10, 2012 | 1986 Alfa Romeo Spider

1 Answer

My 1997 chevy tahoe is hard to start, I changed the fuel filter and spark plugs but it still takes a lot of cranking before it will start


the pressure regulator may be leaking. pull he vac line and see if its wet. wet is bad. Also these fuel pump connectors are known to overheat from poor connections. Do a search on gm fuel pump repeat failures and overheating connectors. Also the fuel pump could be leaking down so the line needs to be primed. Try cycling the key about 3 to 5 times before you start it. The pump will prime for 3 seconds each time before shutting off. If this helps the problem is the fuel pump.

Aug 14, 2010 | 1997 Chevrolet Tahoe

2 Answers

93 jeep cherokee sport turns over but does not start. Spark plugs are dry looking. Should they be wet if they are getting fuel?


No, if they are wet you would be getting too much fuel.There is a fuel pressure test port on the fuel rail.A pressure tester is available at any parts store for 8-12 dollars.They will be able to give you the specs for the pressure also.

Oct 29, 2009 | 1993 Jeep Cherokee Country

1 Answer

Old j reg mercedes 230te wont start


Check Injectors spraying Fuel when you start. Fuel pump prime because you hear the pump. IF pump is weak, then your Fuel distributor doesn't have correct pressure to spray fuel when injectors open. Do your sparks plug wet after trying several times. If they are dry then you don't have fuel. Replace injectors If they are wet then you don't have correct air:gas ratio of 14.6:1. Replace Fuel distributors

Aug 10, 2009 | 1993 Mercedes-Benz Mercedes Benz 300 Class

1 Answer

Fuel pump will not prime..


Are you even sure it was the fuel pump to begin with?
All electric fuel pumps shut off after the key is turned on in just a few seconds.It will only run as long as the car is running. So it makes me think that the fuel pump was ok to begin with. You probably need to change the ignition module. Its the flat thing that the wires plug into on the side of distributor. Let me know what happens

Feb 21, 2009 | 1994 Ford Escort

1 Answer

Hard Start Toyota Landcruiser HZJ75


two first things to check fuel and spark ...fuel make sure your fuel pump is working its messy but the easiest way is to pull the fuel line "only one connection" and turn key to on then press gas pedal and gas should pump out if not fuel pump is bad... if thats not it you want to check for spark easiest way is to pull one of the spark plug wires and stick a screwdriver in the end then hold the screwdriver to where the metal shank is approx. 1/4" away from any metal surface ... hold the screwdriver without touching the metal shank!!! have someone crank the engine you should see a spark intermittently between the screwdriver and the metal youre holding it close to.. if thats ok the only other thing i can suggest is get a battery with more cca "cold cranking amps"..hope this helps..OH YA ON A SAFER NOTE!!!...DONT LOOK FOR SPARK WITH THE ENGINE WET WITH FUEL..

Sep 19, 2008 | 2001 Toyota Land Cruiser

4 Answers

1998 Alfa Romeo 156 2.5 V6 86000 miles


reset ecu. turn ignition on. leave it for 90 seconds. turn it off and leave it for 90 seconds. start and run engine at idle for 15 minutes. dont touch the accelerator during processs

Aug 19, 2008 | 2000 Alfa Romeo 156

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

139 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alfa Romeo Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

yadayada
yadayada

Level 3 Expert

70374 Answers

ROBERT GARCIA
ROBERT GARCIA

Level 3 Expert

616 Answers

Are you an Alfa Romeo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...