Question about 1998 GMC Sonoma

1 Answer

Missing when first started. Stops when warms up.

For over a year whenever the truck is first started (engine cold) it runs rough if pushing on the gas. Slight bucking when driving and letting up on gas pedal. Most noticable at highway speeds. Starts fine. Not noticed if just idling. Clears up after driving for about 10-15 minutes. No check engine light on. Had to a dealer off an on for a month. They did a "major" tune-up. Problem still there. They say they checked everything fuel related. They gave up.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • GMC Master
  • 12,223 Answers

016 Engine Misfire Misfire Scan Data Find someone who knows what scan data is an knows how to use it .Intake manifold vacuum leak .
Rough Running When Cold GMC Yukon

Posted on Jun 19, 2017

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 375 Answers

SOURCE: Sierra 3500HD rough idle

do a good tune up it is not the tranny . you might think about a good diagnostic test to make sure it is not a senser it is hard to say for me onless i could look the truck over my self . good luck

Posted on May 18, 2008

ourhowse
  • 2007 Answers

SOURCE: Engine starts then dies

Probably MAF. Mass air flow sensor, or idle control system/ sensor.
I have actually heard of some people having this problem because of a faulty heat sending unit, which doesn't show up on scan, but i'm still betting on the MAF. Good luck, let me know what you find.

Posted on Jun 22, 2009

  • 5 Answers

SOURCE: Rough idle only when engine is cold

where is the egr valve located? i haven't seen one on mine...??

Posted on Nov 17, 2009

  • 59 Answers

SOURCE: low oil pressure after engine warms.....

A 1999 Yukon DOES NOT have a vacuum advance. It is computer controlled timing. Low oil pressure is the result of some or all of the following : worn oil pump, worn cam bearings, worn crank bearings. Oil pressure also normally drops as engine warms because the viscosity of the oil changes with temperature.

Posted on Feb 23, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

4.6l. After warm-up, why does it run rough with missing?


Could be spark or fuel.
Weak or worn spark plugs, weak coil, dirty injector, and so on.

Jan 05, 2016 | 2001 Ford Mustang GT

1 Answer

MY RX300 LEXUS MAKES TAPPET NOISE ON STARTING MY CAR WHEN EVER THE ENGINE IS COLD AND STOPS WHEN ENGINE IS WARM. WHAT COULD BE THE COUSE?


Well best bet is take it too the dealer so in case ther is warranty on it if not they wood know why this is doin it

Mar 13, 2015 | Lexus Cars & Trucks

4 Answers

2006 Chevy Trailblazer started to run rough in idle but only after it warms up. My mechanic got P0017 code on his scan tool and told me I needed to replace the Crankshaf and Camshaft sensors. Both sensors...


Bad coolant temp sensor or EGR valve stuck. You can remove and test temp sensor (the one for the ECM--has only one wire) using cold and then hot water and read resistance with ohm meter.

Jan 28, 2015 | 2006 Chevrolet Trailblazer Ext

1 Answer

On my 88 Lincon Mark 5 when it is cold it will start but it misses after it starts to warm up it shuts off and has difficulty starting back everytime we go to put it in gear it will die it wont even...


Sounds like you have a bad ign. module. When the engine is cold moisture causes the miss and when the engine warms the module shorts out all together.

Feb 16, 2013 | Cars & Trucks

1 Answer

Buick 97 lesabre, runs rough when warm


Buick 97 lesabre, runs rough when warm

Jan 25, 2012 | 1997 Buick LeSabre

1 Answer

Missing at cold start both codes po171 and po174 runs ok on the road and after warmup stops missing


year make and model would help a lot.

P0171 and P0174 are lean codes. Since it is running rough at start up and goes away when warm it is usually a sign that the plenum gaskets are leaking. If this is a pickup with a 5.3 liter than for sure the intake plenum gaskets that go in between the intake and the heads are leaking. Very common problem. Once the engine warms up everything expands and the leak seals itself up.

If you can post the year make model and engine size I can help you out a little more.

Nov 28, 2010 | Chevrolet Tahoe Cars & Trucks

1 Answer

I've been having problems with my Hyundai Sonata 1999 with a 2.4L 4 cyl. Running rough when started. Have to push gas pedal to start or stalls after running for a few seconds.. Sluggish/jerky starts when...


could be a few things the start up could be the idle air control sensor (my first thought), the coolant temp sensor for the computer might be a secondary thought for the engine being cold if the computer thinks its warm. that would be the first 2 places i would start without a check engine light or code to reference

Jul 31, 2010 | Hyundai Sonata Cars & Trucks

1 Answer

Will not run smoothly when engine warm unless MAF


I would guess you pretty well havew it figured out. Change the MAF sensor.

Dec 24, 2009 | Mitsubishi Montero Sport Cars & Trucks

1 Answer

1996 Dodge Avenger runs rough


Could be a defective engine coolant temperature sensor -- if it's sending erroneous signals/data to the engine control module, it can cause the symptom you describe (of course there are numerous other possible causes for the symptom you describe. Good Luck

Jun 30, 2009 | 1996 Dodge Avenger

Not finding what you are looking for?
1998 GMC Sonoma Logo

Related Topics:

61 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...