Question about 1999 Ford Escort

1 Answer

Car run good when cold. after it warm up.engine die out.wait awhile it run good

1999 ford escord z2

Posted by on

  • Anonymous Oct 28, 2008

    My car usually runs good through town and car reach speeds of 70-80 mph, however after constantly running for 60+ miles the car will lose power to engine. Lights and radio are not effected. I have to turn the car off for 3-5 min and on startup it will run well for approx. 15 miles then it will lose power again. When losing power it feels like the engine is "hiccuping". Fuel filters and fuel pump have been checked and replaced.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Have you tried getting the thermostat in the engine checked. I had a similar problem with my car and thats what it turned out to be...the thermo was broken.

Posted on Oct 28, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Starts right up but once it warms up it dies have messed with the air gas screws that's fine don't know what the problem is


My car runs good when it's cold but stalls once it warms up ...

www.badasscars.com/index.cfm/page/ptype...id.../prd289.htm
My car runs good when it's cold but stalls once it warms up? ... In this situation, you can usually re-start the engine once it has hada chance to cool back ... it'll fill-up and exits fuel right up and out the vent tube which dumps it down the middle of ...

Car starts and after warmed up.. it dies!! HELP! - Honda-Tech

honda-tech.com/...del.../car-starts-after-warmed-up-dies-help-2797652/
Jun 28, 2010 - Car starts and after warmed up.. it dies! ... but if i let it sits for awhile till the engine is cool down it starts right up but after its warmed up.. it dies.

Troubleshooting an Engine that Stalls at Idle When Warm ...

www.gearheaddiva.com/.../troubleshooting-an-engine-that-stalls-at-idle-...

Dec 21, 2015 | Cars & Trucks

1 Answer

Dies when I first start have to restart a few times and dies at stop light unless it gets a little gas


This is usually a problem caused by a bad water temperature sensor. There are usually 2 sensors with one working the temperature gauge and the second working engine controls.

The "cold start" sequence is similar to a choke in old cars. It needs the signal from the water sensor to trigger the cold start sequence. The cold start sequence enriches the fuel charge, adjusts timing, and increases idle speed until the engine gets a little warm.

Now if stalling when warm, you have other issues. Manifold runners are a problem on some engines.

Feb 12, 2014 | 1999 Ford Taurus

1 Answer

1993 ford taurus


sounds like it could be a coil issue after its been sitting for awhile it starts again correct? when its running the coil will warm up and if there is a small crack in it anywhere it will seperate and loose its contact therefore interupting the spark for the engine and it will die. or it could be a bad fuel pump or even cheeper yet check the fuel filter.

Mar 20, 2012 | 1993 Ford Taurus

2 Answers

It's 12 degrees outside, how long should i leave the engine of my 2007 ford focus running to warm up?


Wait for the temp gauge to lift off of the low end stop. The car is then warm enough to drive. Be very gentle on the trans for the first 20 miles or so, because the transmission relies on engine heat to warm up the trans fluid. Cold trans fluid is very dense and can cause the transmission to slip, causing gear damage.

Jan 04, 2010 | 2000 Ford Focus

1 Answer

99explorer when cold out idles rough and smell gas like its flooding until it warms up have to keep foot on accelarater or it will die after it warms up good it runs fine doesnt do it in warm weather 4.0...


These Engines use a plastic intake manifold with rubber gaskets sealing them to the cylinder heads. The workshop I worked for had this problem & went through heaps of different scenarios to work it out. Turned out the intake manifold gasket had gone hard & was leaking until the heat of the engine had re-created the seal, which was taking anything from 30 seconds to a minute. It took heaps of testing to arrive at this conclusion & once the gasket had been replaced it was as good as new.

Dec 07, 2009 | 1999 Ford Explorer

1 Answer

Cold starts ok warms up shakes and stalls


check engine coolant temperature when it gets warmer, or at operating temperature, and verify that the temperature gauge is showing warmed up to operating temperature. If the coolant temperature sensor tells the computer the engine is cold it will over fuel and miss and the engine will die. When cooled down it will run fine until it warms up. Also could be coil if it starts missing after warmed up.

Aug 18, 2009 | 1990 Ford Bronco II

1 Answer

Starts but dies when engine warms up


Ok, i have a 93 mitsubishi eclipse, so same motor as mine. I had a similar problem after replacing my battery. In removing the intake tube, it split for about 3 inches on the underside of the tube, allowing air to bypass the air intake sensor ( the place where the tube connects to the filter housing). Check this and let me know :)

Apr 30, 2009 | 1992 Eagle Talon

2 Answers

Runs fine then warms up and dies


Air filter blocked or drawing air through leaking or holed air pipe. Otherwise its the air flow meter

Jun 29, 2008 | 2000 Ford Focus

Not finding what you are looking for?
1999 Ford Escort Logo

Related Topics:

103 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...