Question about 1999 Chevrolet Blazer

1 Answer

Wont accelerate!!! 2 months ago I had to replace the fuel pump and filter. 3 days ago had to replace the Battery. My problem is over the past few days (before and after battery replacement) Im not able to get it over 1900 RPMs. Once its at that mark, it drops to 1300 - 1400 RPMs. If I hold the pedal in while driving, it goes up and drops repeatedly as if Im tapping the gas pedal. All fluids are topped off and in good shape (oil/Tran/brake/Coolant). Other symptoms are left turn signal flashes really fast (and bulbs are all working) and that horrid clicking noise coming from the glove box.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 231 Answers

Sounds like a wiring problem and the clicking could be a breaker kicking on and off. As for the surging in the R.P.M.'s I would be taking a look at your throttle positioning sensor. Good luck and remember to rateall the replies you get, thanx.

Posted on Oct 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Loss of power and shuttering when accelerating


You sure filter is facing flow correctly?:I'd check that first,some cars/trucks have in-line filters.

Feb 10, 2014 | 1996 Chevrolet Tahoe

1 Answer

My car wont start engine turns over but doesnt start like ist recieving no gas


Considering it ran fine after pump replacement for awhile then it is probably a fuel issue. Couple things it could be. 1. you could have a ton of sediment in gas tank and it keeps clogging up your pump. 2. you could have blocked fuel filter and or clogged injectors.

Oct 31, 2012 | Chevrolet Cars & Trucks

1 Answer

I have a 2001 Camaro V6 3.8L that stalled on the highway a few days ago. The car stalls almost instantly after starting, ive actually got it to run for about 20 secs a few times but still stalls. Plugs...


When you turn the ignition to on you should here the fuel pump run. If you aren't hearing it then it sure sounds like the pump. Assuming nothing has happened to the car to affect electrical connections. I don't think there is a fuse for the pump but worth checking also.

Mar 11, 2010 | 2001 Chevrolet Camaro

1 Answer

Excessive use of fuel


check fuel pump and check for waterin gas tank let set a day remove draine plug slowly

Nov 13, 2009 | 1984 Chevrolet C1500

Not finding what you are looking for?
1999 Chevrolet Blazer Logo

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...