Question about 2000 Nissan Xterra

1 Answer

P1320,po325 can it be a bad tps [high idle main problem ]

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Nissan Master
  • 76,691 Answers

Check for engine vacuum leaks, use a can of spray carb cleaner, if you hit on a vacuum leak the engine idle will change. Repair *** necessary.

Posted on Feb 20, 2012

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Check engine soon. giving codes p0120, p1705, p0325


TPS sensor (RPM) po120,knock sensor po325.

Mar 25, 2015 | 2001 Nissan Xterra

1 Answer

2001 ford focus se sedan revs to high after replacing icv and tps


It sounds like the TPS was installed improperly..It has to be set in place with no tension on the spring loaded mechanism...This will cause the throttle to rise...I don't know what problem you had before replacing these components but nothing should magically go bad while doing it unless it is a faulty new part...Try removing the TPS ..,INSPECT it to see the plastic lever operation is in correct timing with the lever it is mounted to ...Look close with a light to see what I am describing then carefully connect it....I've seen it happen before...If not the IAC..( idle air control sensor )..will cause it to have a high idle if it is bad....),,maybe it was accidently disconnected .....GOOD LUCK..

Dec 07, 2014 | 2001 Ford Focus

1 Answer

Tps prob!!


wont go to high idle
this is the IAC failing not TPS, the tps only signals to the ECU
that you are at idle.

Apr 17, 2014 | 1994 Geo Metro

1 Answer

2000 nissan frontier rough idle and has a po325,po300,po120,and po304


THROTTLE POSITION SENSOR, MISFIRE, #4 MISFIRE, KNOCK SENSOR, THESE ARE YOUR TROUBLE CODES, PO120,PO300, PO304, PO325, RESPECTIVELY, REPLACE THE TPS @ THROTTLE BODY, REPLACE KNOCK SENSOR , @ ENGINE BLOCK, REPLACE YOUR SPARK PLUGS & PLUG WIRES ! AND YOU MUST ALSO REPLACE BOTH YOUR AIR & FUEL FILTERS, DISTRIBUTOR CAP & ROTOR , INSPECT, MAY NEED TO REPLACE, I WOULD ANYWAY !!!!!!!! ADD SOME GOOD FUEL INJECTOR CLEANER TO TANK, NEXT FUEL UP !

Apr 02, 2013 | Nissan Frontier Cars & Trucks

1 Answer

The chek ingine ligth is on on my 2000 nissan maxima and the code is 1320 i whant to now what it is


What I found on the internet was that P1320 is a
transistor in the ignition coil, that turns on the primary
side of coil

Maybe a 1320 is similar to a Generic PO303
eg: coil #3 middle plug firewall side

You can put the P1320 into the computer & continue
on for the answer

Maybe a bad #3 cylinder coil, if the code actually
is accurate. On my Lincoln, even professional scan
tool software, isn't always of any use, sometimes,
because of coils not grounding properly & coming
back on the TPS Sensors

Sep 05, 2012 | Nissan Maxima Cars & Trucks

1 Answer

Codes are reading low tps voltage, mapps high voltage ignition on low voltage at idle. Idle surges sputers and stalls when driving. Replaceed mapp and tps with no improvment?


Have you consider to check the battery power. I believe the main problem you have is either the battery or the alternator. Due to these two things with low voltage the brain ( ECU ) does not have the enough power to work. Good Luck.

Aug 15, 2012 | 1992 Chevrolet S-10 Blazer

1 Answer

High idle after engine is warm. nothing is sticking with linkage.1992 chev k1500 5.7


Make sure the idle screw was not turnned causeing tps sensor to read over the spec limit, the next then is to make sure the idle air control valve is working , a bad valve will cause this problem and last is the stepper motor that controls the idle. some of these around this year used steeper idle control motors instead of idle air control valves and in turn the stepper motor is bad it will hold the throtle plate open to much causing the tps reading to be wrong triggering the engine light to come on. the steeper motor will be boltted to side of the throtlebody and theres a small arm to the throtle linkage. i will enclose a stepper motor picture and an idle air valve to show you, but this sounds like the tps is out of range due to this. the last thing is to make sure there are no vacuum leaks, spray crab cleaner around throtlebody base gasket and also the intake mounting gasket and see if the idle changes is so theres a vac leak in that area. good day. okay just did a little research and this truck does have a idle air control valve, the picture is encolsed and is screwed into throtlebody, check that and for vacuum leaks, make sure tps is good sometime it will test good when testing and go bad when it wants, you could have a bad tps and idle air control valve also.11_27_2011_9_27_54_pm.jpg

Nov 24, 2011 | 1992 Chevrolet K1500

1 Answer

Six cyl high idle. already replaced tps


the problem could also be caused by a bad mass airflow sensor. you may be able to get one cheap at a junk yard.

Apr 15, 2009 | Ford F-150 Cars & Trucks

1 Answer

Idle high all the time


Most likely the tps.I had the same problem with the same type car and the tps was the problem.

Sep 09, 2008 | 1997 Pontiac Grand Am

1 Answer

Transmission and idle


One of two things....He screwed up when replaceing the transmission and damaged the TPS sensor.... or the common problem is the TPS sensor got messed up when the rat ate the insulation off of the sensor and chewed through the wires.
Check with your local dealer about a warranty/recall on the TPS sensor.

May 20, 2008 | 2000 Honda Odyssey

Not finding what you are looking for?
2000 Nissan Xterra Logo

409 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...