Question about 1999 Cadillac Escalade

1 Answer

WIPERS,RADIO,WINDOWS ALL STOPED WORKING AT THE SAME TIME

CHECKED THE BATTERY CABLE AND CLEANED THEM. CHECKED THE FUSES THEY ARE OK. IT HAS BEEN RESETTING BUT HASN'T THIS TIME.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Body control module has a bad solder joint you have to remove the center console take out body control module look at circuit boord on back of relay resolder and reinstall ,it fixed my problem. four screws to remove console then slide it towards back seat & take it out PAPA QUEEN

Posted on Jul 22, 2012

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
dnewcombe1
  • 1564 Answers

SOURCE: 2000 escalade windows and radio stopped working at same time,,..

Look under the hood and try testing ALL fuses first, then try swapping out two of the relays(of the same size of course) and try your windows again. There are also a couple cercuit breakers, try swapping those. Now, If I'm thinking correctly, you have another power control unit under the drivers passenger seat. Do all the same poperations to that section. Good Luck.Dana

Posted on Aug 31, 2009

  • 362 Answers

SOURCE: After main battery replacement, the radio will not power up at al

Hi fasterboatma, Your computer stats are gone, the computer was reset when battery was disconnected, your radio is in theft mode, the radio is waiting on a code to be entered. The reason it does this is so if the radio was stolen it cant be used without the code. Look in your owners manual and see if the code is recorded there, if not call a local dealer and they can look it up, they will usually do it for free, if not you will have to take the front bezel off and see if you can see the code printed on the top of the radio. Let me know if I can assist further and please rate this solution. lone99star

Posted on Jan 11, 2009

SOURCE: 1] Security system seems

I would install a bypass kit and this will disable your anti theft system so that you don't lose battery power and will also upgrade the car with a remote starter. Click on the link below to view the kit:

http://www.autotoys.com/x/catalog/GM_PASSKEY_3_Bypass_Kit_TYPE_5_p_4566.html

Posted on Nov 16, 2010

  • 7 Answers

SOURCE: I changed the battery a

The radio on most american vehicles has two fuses powering its functions. Ie--CD player runes but is not amplified. Clock works but not radio. Check all the fuse headings again...ALL FUSE PANELS, there are usually more than one. sometimes 2 panels Inside and under the hood as well

Posted on Jan 13, 2011

  • 11800 Answers

SOURCE: No information system display. Have

All of this points to a bad connection in the wiring from the dash to the instrument panel - you will need to check it. While you are there also check the ignition key switch - the contact inside might have worn out and are causing this.

Posted on Aug 08, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i fix a 2007 ford explorer radio back light and rear wiper stoped


Have you checked your fuses? The fuse block should have each one labeled in the lid that covers it, and would tell you if rbl and rw are on the same fuse.

Feb 23, 2015 | Ford Explorer Cars & Trucks

2 Answers

Windows, wiper, radio, dash dimmer wont work i have tried the relays and fuses


Now try checking ALL the ground wires connected to the frame under the dashboard. If any one of them is broken off or loose that is a cause of multiple outages.

Jan 13, 2013 | Cars & Trucks

1 Answer

1999 CADILAC ESCLADE,WIPERS,RADIO AND POWER WINDOWS KEEP CUTTING OUT, NOW WON'T WORK AT ALL


Have you check the appropriate fuses? There is most likely more than one fuse box.

Feb 20, 2012 | 2001 Dodge Caravan

1 Answer

Started up this morning fine went and did not start at all later.


remove and, clean your battery cable clamps then retighten and, test.
If your battery is too discharged "jump" it using jumper cables and, another car.

Apr 25, 2010 | 1996 Chrysler Cirrus

1 Answer

Windshield wipers stoped working i think it is a fuse. edkk@verizon.net


COULD BE FUSE.IF FUSE GOOD.CHECK TO SEE IF POWER GOING TO WIPER MOTOR.IF YES.REMOVE WIPER MOTOR HOT WIRE IT USING JUMPER WIRES TO CAR BATTERY.IF WIPER DONT WORK IF HOT WIRED.WIPER MOTOR IS BAD.IF WIPER MOTOR WORKS HOT WIRED.YOUR WIPER LINKAGES BINDING. NEED LUBRICATING OR REPAIRED.

Apr 18, 2010 | 2005 Acura TL

1 Answer

Windows wipers and radio wont work


first things first did you check you fuses ?

shack

Apr 18, 2009 | Chevrolet Silverado Cars & Trucks

1 Answer

Toyota 4runner gate window, wiper, and keyless entry not working


make sure the back window is all the way up then try the wiper, if it still does not work then it is a sensor for the rear window (about $30.00) if you installed it yourself

Mar 31, 2009 | 2000 Toyota 4Runner

2 Answers

2003 Murano interior lights all stopped working at same time.


if the problem is that the interior light does not work, and have already checked the fucibles and appear well or not, housed the correct fuse. Just disconnect the battery cable and connect buelbelo .. and you will be surprised to see that your lights funcionana. I do not believe it but I worked it costs nothing to test.

Mar 21, 2009 | 2003 Nissan Murano

1 Answer

Windshield wipers stoped working, fuse is ok


hi it sounds like the motor or your switch has broke

Nov 24, 2008 | 2002 Buick LeSabre

1 Answer

2001 Windstar Van elecrical problems


Start with the battery and battery cables, fully charged and clean.
Next inspect wiring behind alternator.
Do a load test on the battery, if a-ok check charging system( should be 13.5 to 14.5 vlts) Check fuse box for these items, make sure the terminals are free of corrosion and are noy shorting out.If all ok at this point get wiring diagram of all circuits involved and see what they have in common and where it is . Then probe it to see whats up. repair as needed.

Nov 04, 2008 | 2001 Ford Windstar

Not finding what you are looking for?
1999 Cadillac Escalade Logo

426 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...