Question about Chevrolet TrailBlazer EXT

Open Question

2006 TRAILBLAZER 6 CYL AFTER SITTING IN COLD WEATHER INITIAL START UP IS ROUGH IDLE AFTER WARMUP IT RUNS FINE

After sitting awhile the motor idles rough at startup - once it's warmed up it runs ok

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Bappa170873
  • 505 Answers

SOURCE: Engine Runs Rough At Low Idle When Cold

There are 3 things that cause an engine to run hot;
1) Lack of coolant
A) Broken fan belt
B) Any obstruction to air flow, rags in the fan or vents
2) Ignition timing too far advanced
3) Too lean a fuel mixture.

Posted on Oct 13, 2008

  • 1 Answer

SOURCE: Running rough and stalls during wet weather otherwise runs fine.

Your ignition coil is cracked. Replace it with a new OEM unit.

Posted on Jan 12, 2009

chuck943
  • 783 Answers

SOURCE: Rough idle when engine is cold 1997 Explorer V 6

There are 2 common problems on this concern. 1st maybe a dirty MAF sensor. Remove the MAF sensor and clean it with a good electrical cleaner and air dry or light shop air,then reinstall and do a couple of wide open throttle burst to reset it.
2nd problem and we see alot of this is the orings between the upper and lower intake manifold leaks.You would have to remove the upper intake manifold and replace them.

Posted on Jan 29, 2009

chuck943
  • 783 Answers

SOURCE: 2000 Ford Explorerer rough idle When cold

what codes are present? If it is lean codes P0171/P0174 problem is most likely the orings leaking between upper and lower intake manifold if this is a 4.0L

Posted on Feb 11, 2009

  • 4 Answers

SOURCE: 2002 chevy trailblazer has rough idle

it could be an o2 sensor. it could also just need a tune up

Posted on Mar 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I've a 1981 Vette that idles very rough with a cold engine start.


You need to have the choke adjusted so it runs on a fast idle so the engine can warm up or you may need the carb to be rebuild and adjusted properly.

Jan 31, 2014 | 1981 Chevrolet Corvette

2 Answers

Rough Idle when starting when motor is warmed up


My brother has a Ford F150 that does this the problem turned out to be a bad mass air sensor (little black box with plug in on it located next to the air box on the air intake pipe

Jan 29, 2014 | Ford Bronco Cars & Trucks

1 Answer

Rough idle at startup but after 3min warmup runs fine


The cold start heater coil is getting stuck. It is like a spring...lubricate it!

Jan 22, 2013 | 1993 Oldsmobile Eighty Eight

1 Answer

94 trailblazer runs really rough for awhile after sitting ,after running awhile its starts to run fine (worse on cold days) help please!!!


Have a pressure bleed down test run on the fuel pump, that is the most common problem that causes this condition.

Aug 23, 2012 | Cars & Trucks

1 Answer

Eng. will idle &run rough.Restart and it runs fine./19872.8/V-6


if it has MAF & TPS sensors then clean with right cleaners and check air filter your computer is resetting itself

Apr 21, 2012 | 1987 GMC S-15 Pickup

1 Answer

Started in cold weather yesterday. Ran real rough, almost like a motor mount bad. Fan turns by itself when turned with your hand.


If it only happens in cold weather, check your intake manifold bolts for tightness. #5 & #6 by the firewall are easiest to check. Some people will find these not even hand tight = rough running car.

However, if (when cold) your car is vibrating at idle IN GEAR and stopped, this would be a motor mount on Envoys and Trailblazer, very common.


Fan shouldn't turn by itself, you may have a bad fan clutch.

Mar 13, 2011 | 2006 GMC Envoy

1 Answer

Car wont start in cold idles funny for a moment, then is fine .The heat dont act right gets hot going down the road cools off when sitting at idle.


i hate to be the bearer of bad news but it sounds like a head gasket failure.usually occurs in cyl 2 ond or 3 in these engines (1.8L).car sits and engine cools coolant leaks into cylinder and when started runs with amiss until coolant burns out of cylinder and conversely air gets in cooling system,system gets low and you have poor heat esp at idle.have your mechanic confirm but these engines are becoming notorious for this.

Feb 02, 2011 | 2002 Nissan Sentra

1 Answer

2003 Monte Carlo SS Hesitates and Dies after running for awhile


The ck engine light should not be ignored, what sensor was shown to be bad ? Have it scanned again and replace the sensor that is bad if it still runs rough you might want to consider a tune up. Plugs, wires, fuel and air filter's and clean the throttle body with some gumout. It could also be the IAC motor Idle Air Control. Good Luck

May 10, 2009 | 2003 Chevrolet Monte Carlo

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

108 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...