Question about 2000 Hyundai Elantra

1 Answer

Engine high rev at stop and slowly goes to idle speed.

When I start my car it revs at about 2k-3k rpm. It also does it when I come to a stop. When I come to a stop it will stay at a higher rpm than that of idle speed.

Posted by on

  • 1 more comment 
  • mustcharger Nov 09, 2008

    I have a 2001 Elantra, I revs up to 3k rpm when I started and slowly goes down. Also, the rpm does not drop between shifts (it's a 5 speed) I thought it may be the tps or air control valve, but thess do not seem be the problem, any ideas?

  • ROYSTERONE Dec 08, 2008

    I HAVE A 1990 CIVIC SI WHEN I TURN THE VECHILE ON FOR THE FIRST TIME IN THE DAY IT REVS UP TO 4K RPMS ONCES ITS WARM IT DROPS DOWN SLOWLY TO 2K RPMS. I CHANGED IDLE CONTROLLED VALVE AND IT CONTINUED TO DO THE SAME THING. PEOPLE R TELLING ME IT COULD BE THE TIMMING THAT THEY MIGHT HAD SKIP A TEETH WHEN THEY WERE PUTTING IT ON...... WHAT SUGGESTIONS DO YOU HAVE

  • yadayada
    yadayada May 11, 2010

    You have not provided any useful info for figuring this out, like how cold is it outside when this happens (idle speed is controlled by the computer, how fast on cold start? as high as 3000 RPM)), does the engine idle fast when it is hot?does it reach normal operating temp of about 195 F? Have you check for computer trouble codes?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I've got Hyundai Lantra 1.6 year 2000. It's take time to start when it's hot. When I start my car it revs at about 2k-3k rpm. It also does it when I come to a stop. When I come to a stop it will stay at a higher rpm than that of idle speed. It drives ok when on freeway but uses more petrol. I have changed the water & petrol pump but no luck

Posted on Feb 12, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2008 mercury mountaineer. heat will blow and then it will blow cold. Coolant is full and no leaks. It's overheated twice in the past week. Now high rpms at low speed, when heat is turned on or off.


Mercury Mountaineer Start Stall Idle Problems - Car Forums at ...

forums.edmunds.com > Mercury > Mercury Mountaineer

Dec 12, 2010 - 14 posts - ‎14 authors
Learn more about Mercury Mountaineer at the Edmunds.com Car Forums! ... Light came back on but no more stalling at speed. ... I have the same stalling at low idleproblem (under 500 RPM) with my 2003 Mountaineer 4.6L V8 AWD. ... My computer is telling the engine to rev at a high RPM on startup, then ...

Engine Rev's high, slow to accelerate - Ford Truck Enthusiasts Forums

www.ford-trucks.com > ... > Expedition & Navigator
Aug 22, 2003 - Engine Rev's high, slow to accelerate Expedition & Navigator. ... If you give it more gas I do pick up speed faster, but the noise gets louder. ... 99 Expedition 5.4/3.55 LS (plan to replace with SD-PSD) & 95 Mercury Mystique 2.5L/v6 .... What transmission, mrpositraction, 2004 - 2008 F150, 15, 04-08-2008 ... 2008 F-150 - Rough Idle and Hissing Noise at 1800 RPM
May 22, 2014
2001 mercury moutaineer 5.0 high idle 1000-1200 rpm's at idle ...
Aug 2, 2011
Head gasket leaks; Overheats at high speed/RPM.
Jan 11, 2011
Strange "whoop" sound?
Jun 19, 2007
More results from www.ford-trucks.com

Loud..the RPMs increase like I am stuck in 1st gear..torque


Dec 07, 2015 | Mercury Cars & Trucks

1 Answer

I have an 03 Jeep Grand Cherokee v6 2x2 with 170k... I'm having a couple of issues... 1. Occasionally will have trouble with cycling through gears when getting on Hwy causing decreased, sluggish...


I would consider changing the vehicle speed sensor. When they go bad, they can really throw out a lot of bad data to the computer, resulting in unexpected behavior like you're experiencing. They're only around $20-$25. I hope this helps! :)

May 02, 2014 | Cars & Trucks

1 Answer

Oil lamp lights at 750rpms


750 rpm?

your revs are too low.

The engine speed drives the oil pump via the timing belt.

too low revs = poor pump speed = low pressure.

I'll bet when you rev the idle speed faster, the warning goes off?

Apr 30, 2010 | 2004 Chrysler Sebring

1 Answer

Carburation & emission control?


check for broken or disconnected vacuum hose/line
also check for the fast idle sped control valve for defect

Mar 18, 2010 | 1983 Honda Accord

1 Answer

98 galant 2.4 engine speed uncontrollable after 1600 rpm


check automatic idle speed motor if equipped.

Jul 07, 2009 | 1998 Mitsubishi Galant

1 Answer

Idle irratic


Here are some of the causes of surges, stalls at stops, slow idle speed, erratic idle speed, rough idle and engine hesitation (and other problems), it is in most cases the idle speed control air-bypass valve and or throttle valve and upper intake, these area's get full of gunk and combustion residue over the miles and cause idle issues (stalls, low idle) like yours, Get a can of intake cleaner from any local parts store, not carb spray, intake cleaner, it is made by a company called CRC, remove the air intake hose to the engine, hold the idle high so the engine won't stall, then spray the can of cleaner into the intake while keeping the engine running, use at least 1/2 the can, shut down the engine and disconnect the battery for 5 minutes, then restart and complete a number of mixed driving cycles, town, freeway, stop and go etc., after a few days the problem will go away as the system will relearn to the clean intake

Apr 11, 2009 | 2001 Chrysler PT Cruiser

1 Answer

Not reving high on cold start


Here is the most common cause of surges and stalls and low idle, it is the idle speed control air-bypass valve and throttle valve (IAC for short), they get full of gunk over the miles and cause idle issues (stalls, low idle) like yours, Get a can of intake cleaner from any local parts store, not carb spray, intake cleaner, it is made by a company called CRC, remove the air intake hose to the engine, hold the idle high so the engine won't stall, then spray the can of cleaner into the intake while keeping the engine running, use at least 1/2 the can, shut down the engine and disconnect the battery for 5 minutes, then restart and complete a number of mixed driving cycles, town, freeway, stop and go etc., after a few days the problem will go away as the system will relearn to the clean intake

Feb 06, 2009 | 1998 Volkswagen Jetta

Not finding what you are looking for?
2000 Hyundai Elantra Logo

2,556 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hyundai Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Hyundai Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...