Question about 1993 Chevrolet K1500

Open Question

1993 chevy truck shuts off

Truck starts runs 10 min. shuts off.have replaced ecm, distributor,and sensor.

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
fastboyz
  • 674 Answers

SOURCE: distributor cap firing order on a 1993 chevy cheyenne truck v6

b9fdd9f.gifhere

Posted on Nov 28, 2008

Ad
  • 2 Answers

SOURCE: distributor cap firing order 1993 chevy cheyenne truck v6

Firing order is 1-6-5-4-3-2 cyls. # 1-3-5 on drivers side front to back and cyls. # 2-4-6 passenger side front to back.

Posted on Nov 30, 2008

Mike258
  • 1498 Answers

SOURCE: how to troubleshoot 1993 chevy Z71 pcm

Hi Nsilguero,

I apologize for the delay in responding.

From your description, I'm leaning toward a timing chain problem, first stretching, then skipping and finally breaking.

If you're getting voltage to the coil and still getting no spark, there is a test I'd like you to try.

Take off the distributor cap and have someone turn the engine over while you eyeball the rotor. Is it spinning?

This going to take some back and forth interaction. Comment me back with the results. We will proceed from there.

Mike

Posted on Jan 17, 2009

savindude
  • 175 Answers

SOURCE: I have a 1991 chevy truck, I am getting no spark.

Possibly ignition switch, Power (12 volts) going to distributor goes through ignition switch.If you read voltage on the primary side of the coil, with the ignition key on, can you read 12 volts, maybe a little higher? If not, that's pointing to a problem. Good luck.

Posted on Jun 29, 2009

  • 4088 Answers

SOURCE: 1987 chevy s10 2.5l tbi will not start. changed

That eliminates the crankshaft and camshaft position sensors. Have you checked the fuel injector itself for an open winding or stuck valve plunger? There should not be a steady 12 volts to the injector--if good injector, it would be spraying fuel steadily into the throttle body. But at least the engine should try to run if poorly. Take the injector out, dry it off with air, and intermittently apply 12 volts to one terminal while grounding the other. You should hear a click from inside every time you touch 12 volts. If not, replace it. If it does, it may be plugged with debris. Try blowing through it in reverse with compressed air.

Posted on Jul 17, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Runs good, after 30 mins stalls no injector pulse and hard to start.after 10-15 mins starts again, spark OK. changed fuel pump,distributor. Same


run the fault codes and check for problem ECM
There is an electronic component failure in the injector circuit that when over heats , shuts that injector circuit down
try replacing the ECM with a known good unit

Dec 09, 2015 | 1988 Ford Tempo

1 Answer

1994 f150 6 cyl engine shuts down every 10 min restart after 5 min


Sounds like the module inside the distributor. Have to be replaced.

Sep 29, 2012 | Cars & Trucks

2 Answers

1993 S-10 Blazer- replaces distributor and plugs and wire timing is set, getting fuel but still will not start????


take out the ecm and have it tested at autozone. if this is it ,your looking at around a hundred for it.

Apr 28, 2010 | 1993 Chevrolet S-10 Blazer

3 Answers

I have a 1996 c1500 5.0, Runs rough when hot.


has any one checked to see if the intake is leaking& Chevy does have a problem with the intakes leaking. This a thought hope it helps.

Apr 18, 2010 | 1996 Chevrolet C1500

1 Answer

1993 chevy 2500 pick-up sat for 1 year starts runs for 5 min. shuts down. had a bad pump. change pump. did a good job on it I am a good mech. It started run for 5 min. and shut down. I have no spark. I...


broken ground to the frame,cracked magnet assembly in the distributor next to the rivets,the distributor hall ic has rust near it,or the vortec 50psi pump is overfuelling.there are 2 different fuel pumps.pressure is 13 psi.disconnect pump and put it on a fuel machine at 13 psi and see how it runs.the fuel pressure regulator can only compensate so much. ground the ecm case directly to the chassis with a jump cable.start with those

Jun 14, 2009 | 1993 Chevrolet K1500

2 Answers

My 1987 Lincoln Town Car runs fine for about 30 min and shuts off


replace fuel filter and (clean or replace) air filter. then pressure test fuel system.

May 14, 2009 | 1987 Lincoln Town Car

2 Answers

93 chevy g20 van


More than likely it's the distributor. They have a tendency to build up corrosion and rust and have personally went through the same situation three weeks ago on a suburban. Check to see if you are getting spark from the distributor first. Have the ecm in the distributor checked at Oriellys for free. It's under the rotor and has two 8mm head bolts with wires plugged in at each end.

Jun 22, 2008 | 1993 Chevrolet S-10 Blazer

Not finding what you are looking for?
1993 Chevrolet K1500 Logo

Related Topics:

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

77202 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...