Question about 2005 Volvo V50

Open Question

Power system service urgent

Just purchased vehicle, power system service urgent came on as well as the battery light. car seems fine, no weird noises, car doesn't shut down and everything that is to have power is working just fine. the message only stays on for about a minute then goes away. it may or may not come back on for the remainder of the drive. any ideas?

Posted by on

  • Kyley Kendall Feb 24, 2012

    UPDATE:
    took the car into the shop, needed the alternator, battery harness and belts replaced. a $1500 fix. I was lucky that my car did not break down on me, but if you ever have this issue, TAKE IT TO A SHOP IMMEDIATELY! it's not worth the risk.
    if you're care is smart enough to tell you what's wrong, chances are it's right.

×

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 76 Answers

SOURCE: ETS light comes on and off

Just to add to it. Volvo Darin is right, but the extended warranty period was for 10 years or 200,000 miles. It depends on your warranty start date. Being a 1999 it could or could not be covered.
Don't wait any longer, because there is NO help or extension of this warranty after 10 years.

Monday, Monday, Monday...

Posted on Feb 28, 2009

roy7777
  • 109 Answers

SOURCE: I can not reset RSR air bag service urgent message on XC70

if your car has NOT been in a accident the easy fix would is to find a used AIR-BAG SENSOR on a car that HAS-NOT been crased what happened when you did that is sent a code to sensor without dissconnecting battery and light came on I did same ting changing the seat get another air-bag sensor and before installing it dissconnect neg battery terminal tape irt up with duct tape and replce sensor and problem should be solved

Posted on Apr 11, 2009

  • 19 Answers

SOURCE: "SRS - AIRBAG SERVICE URGENT"...message

If you have SRS and "brake failure" it should be taken to a dealer. a shadetree mechanic will screw more up than he will fix in this case. trust me on this! you will pay a price, but will save you more $ and less headache in the longrun.

Posted on May 09, 2009

roy7777
  • 109 Answers

SOURCE: message system reads "engine system maintenance required"

WHAT HAPPENED IS WHEN YOU SHUT DOWN AND RESTARTED YOU (RESET THE ENGINE MANAGEMENT COMPUTER) AND THE SERVICE LIGHT SHOULD GO OUT AFTER 10 MINUTES OF DRIVING

Posted on May 12, 2009

wracefans24
  • 1985 Answers

SOURCE: My 2000 volvo S80 2.9 seem to go into a safe mode

your car is going in "limp" mode,
the computer is seeing a problem with a sensor on the transmission,so it won't up shift because it doesn't know how fast your going.
check the speed sensor,the input sensor,and the output sensor.one of these is not working correctly,
it will help when you have the car checked for codes,look for history codes section.
cycling the key resets the soft code but it will always return until repaired.

Posted on Jan 08, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1997 mercury mystique. Battery fully charged, turn the key, absolutely nothing. In fact no power to anything, no interior lights, nothing. Battery is brand new


Its seems voltage regulator issue.Get the vehicles charging system inspected.

To troubleshoot these issue i suggest you few helpful links with solutions:---Click the link below:----

How to inspect Vehicles Alternator?

http://repairhelpcenter.blogspot.com/2011/11/how-to-inspect-vehicles-alternator.html

---------


How to Test Vehicles Alternator?

http://repairhelpcenter.blogspot.com/2011/11/how-to-test-vehicles-alternator.html

-------------


How to Service Vehicles Alternator?

http://repairhelpcenter.blogspot.com/2011/11/how-to-service-vehicles-alternator.html

------------

How to Replace Alternator?

http://repairhelpcenter.blogspot.com/2011/11/how-to-replace-alternator.html

---------------


How to monitor Vehicles charging system?

http://repairhelpcenter.blogspot.com/2011/11/how-to-monitor-vehicles-charging-system.html

-------------

Car Alternator making noise?

http://repairhelpcenter.blogspot.com/2011/11/car-alternator-making-noise.html


--------------

Car Alternator Working Intermittently?

http://repairhelpcenter.blogspot.com/2011/12/car-alternator-working-intermittently.html

-----------




Car not starting or turning over indicates towards multiple possibilities. It can be issue with battery or weak battery. But if battery checks out ok, then it can be starter issue or faulty alternator or problem with low fuel pressure or no spark at spark plugs due to dirty spark plugs or faulty ignition coil or injectors getting cracked or dirty and needs to be cleaned.


To confirm the problem, the basic troubleshooting is required.



From start to end troubleshooting these problems I suggest you to check the help link below and follow its procedure: -----


Mostly all types of car no start problems are discussed here with solutions:---

CAR NO START: ENGINE NOT TURNING OVER:

http://alltypesofpartsreplacing.blogspot.com/2012/11/car-no-start-engine-not-turning-over.html

---------

These will help.

Thanks.

Dec 10, 2012 | 1997 Mercury Mystique

3 Answers

Alternator/Electrical??


check the connection on your battery terminal ends. if they are loose or corroded that could explain the intermittent no spark. also could be a short somewhere but id check the terminals first. I had that problem once and the car did all sorts of weird things. airbag light, check engine light, randomly wouldnt start until i would mess with the battery.

Nov 06, 2012 | 2000 Ford Explorer

1 Answer

2001 Mustang GT. Motor shut down on quick acceleration. Won't restart. Traction control light lights up "Off" Making clicking noise. Doesn't reset when ignition switched off or battery...


Hello and welcome to FixYa!

You may just have system failure. As a first course of action, I strongly suggest that you remove the positive battery connector and let it sit for at least 5mins. before reconnecting it. This will reset the system and can get your vehicle back to it's normal operation.

This thing really happens and reconnecting the positive battery connector serves like a jumpstart to the vehicle's PCM (powertrain control module).

Hope this helps and thank you for using FixYa! Have a good one!

Sep 18, 2011 | 2001 Ford Mustang

1 Answer

I have a 2001 L100 seires Saturn and My service light and the security light both are on and the car wont start. the battery seems to be fine all the lights work i left it alone for a while and it started...


No, the fuel gauge not working wouldn't have anything to do with your not starting problem , probably the gauge is bad . With the SECURITY light lit , anti-theft system problem ! Service light ????? Service engine soon ? Or service vehicle ? With the light's on code's DTC'S - diagnostic trouble codes are stored . Have it checked , don't guess as to what the problem is. This would prevent the buying of un needed parts .

Jun 11, 2017 | 2001 Saturn L-Series

2 Answers

The radiator and cap just replaced, tune up and oil change current. 1999 jeep cherokee 2.5L 4 cyc engine losses power after this last servicing. i use o'reilly octane booster and so far this seems to...


You don't really have a mechanic that has much knowledge

Without the vehicle to test drive & do some testing on it,
there is no way to just guess & I suspect you wouldn't
understand any of our suggestion anyway.

Find the best established shop,one that has been in the same
family for 20 or 30 years

You have to go on a road test with these people before you
leave a vehicle. Be part of the solution,go to the shop on a
supprise visit & as a lot of questions,walk into the service bay

If that isn't some they want you doing take your vehicle &
go elsewhere.
So what test tools they have,study obd2 on internet & have some
trick questions ready to fire off.

Jul 12, 2011 | Jeep Cherokee Cars & Trucks

1 Answer

My 2000 ford focus will not start. It does not make any noise but the lights go on. It doesn't even turn over. My mechanic disconnected the remote car starter and that seemed to help but now I'm...


If it's not a dead battery, it could have bad connections. Check battery connections for tightness

Check the battery cable connection on the start solenoid, usually very near the battery. Check all wires on the sloenoid.

Check solenoid cable to starter for tightness at both ends.
If starter & battere are good it has to be one of above'

Good Luck

Jun 30, 2011 | 2004 Ford Focus

1 Answer

My dad says the ignition switch maybe what's causing my 1994 Grand Prix not to start. The battery still has juice, and he says the starter is good, but maybe the starter relay isn't. What do you...


Look on the dash for a light that says "security" when it doesn't start. It's very common on GM vehicles for the security system to shut down the starter if there is a mis communication in the security system. Look at this link for info and solutions that you can do yourself http://vatspasslockpasskeysecurityhelp.yolasite.com/

May 29, 2011 | Pontiac Grand Prix Cars & Trucks

1 Answer

2006 ford explorer wont start and lights wont work on outside or inside. I hear a clicking sound on the inside under dash. The battery is fine checked it what else could it be?


Since your battery is fine and you hear a clicking sound there is a problem getting the power to the rest of the systems on the vehicle. That clicking noise is your starter that doesn't have enough juice to get it going. This may be something as simple as dirty or rusty terminals, a bad connection between the terminals and the cable or even bad battery cables. The ifrst thing you should do is take off your battery terminals and clean them clean them and also while you're at it take a look at those cables to make sure they aren't obviously damaged. Reconnect the terminals to the cables and battey and see what happens. If it doesn't work, you'll need to have a professional look at it.

May 13, 2011 | 2006 Ford Explorer

Not finding what you are looking for?
2005 Volvo V50 Logo

Related Topics:

367 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volvo Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Volvo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...