Question about Cars & Trucks

1 Answer

Complete loss of power on a hot day in heavy trafic, after about one hour power is back

When driving in heavy traffic, stop start on a hot day,my car starts by sluggish acceleration then after a while it looses all power and I have to wait maybe an hour before I can drive off again. and then it will start the same again. the following day it is fine.

Posted by on

  • Hennie Drinkwater Feb 17, 2012

    Good day Dennis, the temp gauge stays on normal although the engine might be a degree or what above normal.when it happens the car loose all power it starts running rough on idling and eventually dies.it must have something to do with heat.I just thought of something else. the fan got two broken blades and is maybe not as efficient as it should be?then when driving in slow traffic the the engine does reach a higher temperature than normal although the heat gauge does not register it?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 75,822 Answers

Did the engine overheat and go into limp home mode? That would be my guess.

Posted on Feb 16, 2012

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 23 Answers

SOURCE: car cuts out in traffic

Hi guys,obviously this could be any number of problems,but the most common ones to cause this is a dirty throttle intake housing,usually a good clean up rectifys this,also check the small vacum hoses for any splits or perishing as this also can cause this problem,hope this helps you's out,Bill.

Posted on Feb 27, 2009

  • 147 Answers

SOURCE: car cuts out in traffic

check your fuel pump or its sensor in his way.

Posted on Apr 06, 2009

SOURCE: When I switch on air conditioning or heating the

Most likely the idle air control valve is faulty. But that's just a guess. Does it do the same thing when you turn the steering wheel at a stop. The IAC is suppose to open a little when a load is placed on the engine in order to add more fuel so the air/ fuel ratio stays efficient

Posted on Jul 17, 2009

michigan man
  • 3533 Answers

SOURCE: heavy white smoke when accelerating sluggish and

if its a bittersweet smell its a crack cylinder head or a leaky head gasket give these websites a try www.alldatadiy.com and www.autozone.com if all fails stop by your local library and get your hands on a Haynes auto repair manual for your SUV wish you the best of luck Michigan Man.

Posted on Mar 27, 2010

jgwhomeequip
  • 1902 Answers

SOURCE: Vehicle is sluggish and not

First error code
P1650 - Power Steering Pressure (PSP) Switch Malfunction In Key On,
Engine Off Self-Test, this DTC indicates the PSP input to the PCM is
high. In Key On, Engine Running Self-Test, this DTC indicates that the
PSP input did not change state. Steering wheel must be turned during Key
On, Engine Running Self-Test
PSP switch/shorting bar damaged
SIG RTN circuit open
PSP circuit open or shorted to SIGRTN
PCM damaged."

P1703 - Brake Switch Out Of Self Test RangeP1780 - Transmission Control Switch Out of Self-Test Range

Posted on Jun 15, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Renault trafic wont start...engine warning light flashing


The light and the word stop should be sending you a clear message . The engine hard starting and sluggish is also sending a message and if you do not heed the message and have the fault codes read and the problem fixed then the next message may be replace the engine or gear box . The light is there --not to be an annoyance ---but to inform you that something drastic is going wrong and it needs urgent attention.

Mar 09, 2014 | Renault Cars & Trucks

1 Answer

Power loss and shuddering on Daewoo Lanos 2000 in hot weather


sounds like you have a over heating issue most cars no a days will kill power and shake like this.the computer is like a back up safety tokeep you from destroying the engine.because when you let it set for about 30 minutes or so you can resume driving normal till the temp gets in the red I assume then it will start shaking and big loss of power.have you cooling system checked out to make sure.hope this helps you out.

Jan 08, 2014 | Daewoo Lanos Cars & Trucks

1 Answer

I have a 2005 Chevy Equinox. During the day after it's been sitting, when you first crank it the a/c blows hot. But once you get rolling at a good speed it cools down. BUT, when you stop at a red...


This sounds like your cooling fan is not running. If you were to stop too long with with the engine idling it would overheat the engine. I hate to be the bearer of bad news but this is a very serious issue. I can have a number of causes, like bad cooling motor, bad wiring or conectors, bad relay, open fuse, etc. Please have it diagnosed and repared before it overheats the engine and possibly damages the engine. If you are stopped in trafic you can place the transmission in neutral and shut off the engine. When trafic restarts you can restart the engine and place the transmission in drive again and continue. I hope this helps.

Aug 10, 2011 | 2005 Chevrolet Equinox

1 Answer

I AM THE PROUD OWNER OF A SSANGYONG REXTON, FITTED WITH A MERCEDES E320 ENGINE. LAST WEEK ON THE HIGHWAY, THE ENGINE STARTED TO RUN UNEVENLY WHEN I STOPPED AT THE OFRAMP AT THE ROBOT, WITH NO POWER. AFTER...


I had the same problem of loss of power with my Rexton E320, especially at low speed , I changed the plugs but the problem could not go away, until I changed the fuel filter and that problem is gone. I have made a lot of kms now without any such problem, try that, it might work.

Nov 03, 2010 | Mercedes-Benz E320 Cars & Trucks

1 Answer

Vehicle momentarily loses power while driving then resumes


Sounds like an electrical issue maybe the plug from firewall to cab is loose or on computer is loose, sometimes those coonections or pins get loose,i had a new car with 200 miles on it and it went dead in heavy traffic,had to get towed to dealer they found loose connection!!!!With audible noise when happens tells me its wiring,check all connections and wires to connections make sure there not loose!!!Best of Luck to you!!!!!

Aug 12, 2009 | 2003 Ford Expedition

1 Answer

RENAULT TRAFFIC 04


hi had same problem on a 04 reanult trafic 100dci changed the EGR valve but no success then changed the fuel filter and new seals and its been fine ever since hope this helps

May 10, 2009 | 2006 Renault 181

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

113 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...