Question about 1990 Toyota Land Cruiser

1 Answer

Leakage on injector pump

Hi ma prado leaks on the injector pump an also the smoke is too much when climbing uphill

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Toyota Master
  • 76,070 Answers

The only choice here is to remove the pump and have it rebuilt.

Posted on Feb 16, 2012

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: Toyota prado 2LTE EFI loosing speed uphill auto trans

what i did to overcome the same problem to my 2lte efi is 1.upgrade my turbo fan to larger size
2.adjust position of my fuelpump
3.make sure the green turbo led on dash working when boost pump in(should check the air tube to sensor for leak)

Posted on Oct 05, 2009

  • 2 Answers

SOURCE: Thick smoke and different smell coming out of

Thick smoke out of the tail pipe usually indicates a blown head gasket or seal. does smoke have a blue tint?

Posted on Apr 16, 2011

smhb1
  • 146 Answers

SOURCE: just replaced injector pump on

tray to open one of cylinder little

Posted on Jun 18, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is there smoke in my 1999 2.5tdi nissan kingcab pickup d22 changed filters oil heavy on diesel low on power more smoke on acceleration I think it might be a bad injector any ideas would be great


injectors
faulty turbo or internal crack
low cylinder compression
valve leakage
egr valve blocked or blanked off


also check ..
fuel pump pressure fuel filter
if hard starting cold ..glow plugs

26227996-baaqz4pc4guywvkqfm2wgc1t-4-0.jpg

Jun 29, 2016 | Nissan Cars & Trucks

2 Answers

Isuzu kb300 4jh1 not accelerating and producing white smoke


White smoke can also indicate you have a head gasket leak of coolant into a combustion chamber.

Dec 18, 2014 | Isuzu Cars & Trucks

1 Answer

My 2003 diesel prado gives off a heavy puff of white smoke smelling of diesel when I start it cold, the engine also have a uneven idle for the first few seconds.


sounds like injector is leaking letting fuel leak into a cyclinder the smoke is raw unburned fuel then it takes a minute or so to clear the cyclinder

Dec 17, 2014 | Cars & Trucks

2 Answers

How do i rebuild a mitsubishi l300 fuel pump


Don't sound like a fuel pump,replace fuel filter and see if it fixes.

Jan 05, 2013 | Cars & Trucks

1 Answer

94 Cadillac Eldorado overheating uphill


This actually sounds like your motor is not the problem it sounds as
thougth your transmission is in need of work. if you have flushed your
system also may look at your oil pump system as the change in pitch of the road to climb hills may infact be pulling sludge against the sump
tube screen and plugging the oil pump. these are the only two reasons I can see for this to happen if system only dose this when climbing a hill
.

Dec 07, 2012 | 1994 Cadillac Eldorado

1 Answer

Have a 1987 Dodge Ram 50 2.6 ltr.


it sounds as though you could have a dirty fuel filter, or a compression leak. is there any smoke(blue or black?) are all of your plugs tight?

Jan 02, 2009 | 1987 Dodge Ram 50

1 Answer

Engine light and cuts out at freeways speed when climbing up hil


Hi, williamtkr.

Have you changed your fuel filter lately? I had a vehicle once whose fuel tank that had a rusty seam. Every 10,000 miles or so, the rust flakes would clog the fuel filter, and the engine would sputter and stall when the vehicle was climbing uphill. If you idled for a bit, you could drive on for a ways, until the same thing happened.

A nearly dead fuel pump could cause the same problem, I suppose.

Good luck.
Ken

Dec 22, 2008 | 2001 Oldsmobile Alero

Not finding what you are looking for?
1990 Toyota Land Cruiser Logo

Related Topics:

102 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8266 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...