Question about Cars & Trucks

1 Answer

I have an 02 neon and the low beam went out on the drivers side but came back on when i wiggled it,then both lights went out altogether the next day. does this sound like a relay issue. i havent checked it out yet but i also had a mouse under the hood and was thinking the little ****** got at a wire

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 18 Answers

Wire is very possible, also may be element in bulb, or ground.

Posted on Feb 14, 2012

  • marcel cyr Feb 14, 2012

    hey victor sorry i forgot to mention that i replaced bulb on drivers side and it was ok but the next day it was no longer working on either side,i havent checked the ground cause i figured i would see some flickering when it was working,high beams are working fine,car has approx 250000 kms on it so i'm thinking relay. sound right to you?

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2000 Dodge Neon - the passenger side low beam will not come on. I've replaced the bulb but it still won't work. Both high beams and the driver side low beam are fine.


Check the wire right at the plug. This were they break the most. You have ground, because the high beam on that side works.

Feb 06, 2015 | 2000 Dodge Neon

1 Answer

Why did my 1995 dodge neon drivers side high and low beams stop working


have you checked the fusebox drivers side lower adsh as there is probably a fuse for each side of vehicle lights ets list of fuse location should be on the lid/cover.just a thought you have turned the light switch to 'parking light' position , there is also a fuse box in engine compartment worth checking keep me posted if you wish

May 12, 2014 | 1995 Dodge Neon

1 Answer

Fuse diagram


Have you checked to see if you have power at the headlight bulbs ? And have you tried replacing one of the bulbs ?

Jul 07, 2013 | 2001 Ford Focus

1 Answer

2007 chevy trail blazer low beam lights wont work.


maybe a fuse the fuse box is under the drivers side passenger seat . sometimes ive seem them get something spilled on them and i had to wiggle the fuses to clear the corrosion

Mar 16, 2010 | 2007 Chevrolet TrailBlazer SS

1 Answer

2001 Ford Focus - High beam / low beam problem with headlights


just replace the dimmer switch under the column its wore out on the low beam side

Jan 17, 2010 | 2005 Ford Focus

2 Answers

Volvo S80 - Low beam out - Changed bulb & fuses


you need to check and see if there is power to the light that is out , because they work on the same circut , look for a bad wire ?

May 09, 2009 | 2000 Volvo S80

1 Answer

Headlight out but new bulb doesn't work


See if moisture is in the lens assy.. If so.. you can drill small holes in the bottom of the light to allow moisture to leak/burn out.. Lemmie know

Mar 15, 2009 | 2007 Chevrolet HHR Special Edition

1 Answer

Low beams don't work


i would check that tail light and make sure there are no wires touching each other. sounds like a deffinant short some where.

Dec 01, 2008 | Buick Century Cars & Trucks

2 Answers

Right headlamp


Check the fuse for the passenger side.It is under the hood. it may not be making good contact. wiggle it a little bit and see if it makes any difference. if not, check where the the ground wires are connected to the chasis. See if thats not the problem.

Oct 31, 2008 | 2001 Buick LeSabre

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

62 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...