Question about 2002 Chevrolet Silverado 1500

1 Answer

Replaced a 5.3 motor! cant get new one to fire

Everything seems hooked up right. ran a diagnostic test. it read crank sensor failed. replaced it but to no avail . cleared computer with diagnostic tester. have checked all fuses. do i have a ground problem, is ecm not recognizing engine, any ideas?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 430 Answers

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Volvo s40 not start


first thing first, stop cranking it over and over again. U r loosing ur battery reserve.
Get your fuel pump checked.


Thanks.

Jan 10, 2014 | Cars & Trucks

1 Answer

Motor is miss firing p3o3 changer ecu after few mins mis fires is my crank position sensor not reading the third cylinder for some reason i did a motor swap ran new motor 3 or 4 hours had miss shift...


your crank position sensor does not read individual cylinders, only the position of the crank shaft. make sure the plugs and wires are good, check the spark coming from the coil, make sure there are no vacuum leaks at intake manifold, check timing, then do a leak down test to make sure you don't have a bent or damaged valve in the cylinder head.

Mar 31, 2011 | Honda Civic Cars & Trucks

2 Answers

Will turn over wont start getting plenty of gas new built 302 motor ran fine for last 6 months yesterday it died at a stop sign still wont crank had to tow it to the house


If I am reading this correctly, the engine cranks but does not start. It was running, died and will not start. I would be inclined to think it is a pickup coil in the disturbutor or the ingition control module. These are very common parts to fail in older ford products.

Feb 28, 2011 | Ford F-100 Cars & Trucks

1 Answer

Location and difficulty of replacing crank sensor on 92 park avenue? auto stalls out, farts, back fires? replaced water pump hose connecter that screws into block from top of water pump outlet? took out...


This could be one of many issues (or more than one!). When you say runs for 5 minutes, does it just stall? overheats? Probably not the crank sensor since when they go they go and engine will not run. If you can get it to Autozone or borow a diagnostic tool may be able to find an avenue to persue. My first thought is fuel from what you describe, fuel filter, fuel pump, injectors.

Jul 16, 2010 | 1992 Buick Park Avenue

2 Answers

Miss firing.


alot things can cause misfires
bad spark plugs
bad wires
wrong timing
bad injectors
think that distributor motor if is bad cap or rotor
if coil pack motor bad coil pack

Jun 28, 2010 | 2001 Chevrolet Astro

1 Answer

I have changed the engine and there is no fire. Tried changed the distributor and the crank engine sensor but still no fire The starter is turning the engine over but when i take a look at the spark plugs...


I have heard of these horror stories about cutting the wires on the ecu and splicing them back together to get the new engine running. We just did a motor and thought we were going to have to do that but the thing fired right up and ran perfect. We couldn't believe it. Anyway, I would try the ignitor, check the fuses, check the oil? Check the immobilizer? How about the ?? There has to be something you are overlooking. Did you get a new ecu with the new motor? Is everything hooked back up? No wires left disconnected? Hope this helps.

Apr 14, 2010 | 2001 Nissan Altima

1 Answer

1994 Jeep Grand cherokee 5.2 no start


Check the crank angle sensor sensor near the transmission inspection plate.

CAS can intermittent and fail with no warning.

I turn down a job because the "other guy": used a tire iron pry open the inspect the flywheel!!!

After all said and done.......it was the crank angle sensor.



Jul 14, 2009 | 1994 Jeep Grand Cherokee

1 Answer

Xg300 failing ran diagnostics and ...


I'm a Platinum Certified Hyundai Technician. Low RPM and Limp Home are always accompanied by each other. Throttle body cleaning FIRST - see what that does. ETS motor not probable, crank position sensor (maybe, because engine stops).. if crank position sensor, there's usually a diagnistic trouble code which identifies it. Clean the throttle body first... then see what happens.

May 23, 2009 | 2001 Hyundai XG300

1 Answer

1996 Camaro won't start


My 94 z28 Camaro misfires whne shes hot, I got her on a diagnostic and they told me that the distributor {optispark unit} was reading faulty and that I needed to replace this before they could go further $1100 quoted, ye right, I bought one for new at $169, they quoted me $400 just for the unit, anyway, I havent installed it yet, Found out that backfiring could also be a module, well I have the dizzy now so I may as well get the module as well. Will let you know. I went to start my car today, it started briefly then died, I thought the dizzy had completely died. Checked fuses and connectors, It cranked over but wouldn't fire. Decided to surf for info on the net. 1 hour later I went back out and tried again, It fired up and ran, Must have had a gremlin, all seems to be back where it was now, Summary, go make some lunch and come back to it, nothing to lose except some time. {If still fails, check Air flow sensor, may be clogged}

Mar 25, 2009 | 1996 Chevrolet Camaro

Not finding what you are looking for?
Cars & Trucks Logo

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...