Question about 1995 Isuzu Rodeo

1 Answer

I have a rodeo/isuzu 4ze1-a recently replaced the MAF sensor and ended up with no spark.. Power to coil and out but no power to distributer.. Replaced distributer and still no luck... All relays and fuses ok Fuel pressue is good No check engine light Engine cranks but won't fire....

Posted by on

  • Andrew Gibson
    Andrew Gibson Feb 12, 2012

    you said your not getting spark..... double check that all of your plug wires are firmly attached ... you could possibly have a bad coil pack

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 20 Answers

You said your not getting spark..... double check that all of your plug wires are firmly attached ... you could possibly have a bad coil pack .

Posted on Feb 12, 2012

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 177 Answers

SOURCE: 2003 Isuzu Rodeo 4 clr. manual experiencing

Did you replace the fuel filter? It sounds like that may be the issue.

Posted on Aug 04, 2009

brandyspoile
  • 61 Answers

SOURCE: Crank Sensor in 94 Isuzu Rodeo

it's on the bottom of the motor, towards the back on the passenger side. It has a small clip of wires and one screw holding it on. You may want to pull it up on ramps- if it'll run- otherwise, get under the Rodeo, it's up a little higher than the oil pan, and to the passenger side. (it's right on top of the two lines that run to the bottom of the radiator.) You will need a 10mm socket to remove it. I have added a few pics showing the location (i just completed this task myself)
bfcf016.jpg61ae995.jpgdeffbd6.jpgdd2e415.jpg

Posted on Jul 24, 2009

  • 1 Answer

SOURCE: Isuzu Rodeo Photo Cover fuse

my fuse for the rear tail lights keeps blowing after 20 sec,

Posted on May 12, 2009

honeymokey
  • 3113 Answers

SOURCE: not getting any fire in 94 isuzu rodeo

SWITCH ASM; POWER,IGN COIL 8-94474-294-2 Go to myisuzuparts.com and find this part number. This part is under the intake manifold. No crank sensor as is has a distributor. 8-94474-294-2 1 05-1990 to 08-1994




Posted on Mar 06, 2010

  • 880 Answers

SOURCE: 1997 Isuzu Rodeo 3.2 L - misfire on cylinder

I would check for a bad plug wire next and then a compresson test on #5 cylinder.

Posted on Jul 16, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is the Crankshaft position sensor for a 97 isuzu rodeo 2.6L? Pictures please!!


if the scan tool dont show it bad, its not. but... no symptoms posted
lost all spark, and engine dont start but cranks ok.
alldata shows this. alldata.com,
$250+ part too.. try a real scan tool? yet?
3 wire sensor, HALL type.


the correct name for this engines is 2.6 L 4ZE1 I4

if you google that , you can learn 1000 things, and where the parts are.
The 2.6L 4ZE1 SOHC eight valve engine features 120 hp (89 kW) and was available as an option to replace the 4ZD1 on four-wheel-drive models.

like all CKPs it can only be in 3 places.
front crank end.
rear end (lots of ways, here, on fly, behind fly, on crank)
mid crank (rare)

but also depends on what country sold, , in the USA they
had to move it, for misfire detection !
so where are you, or better to what country was the car sold to, new.
called market.

on the early cars there were no CKP, on the CAS in the DIzzy base.
on our cars it will throw a P0340 to 355 error if bad or even drops 1 in 10 pulses.like clock work that fact
outside USA, code 41"s"

im googling 4ze1 for your.
and the 3rd hit i find


"1995-1997 Pickup, Trooper II, Amigo, Rodeo 2559cc, 2.6L, Engine Model 4ZE1. Crankshaft has a bolt-on sensor ring at the rear main journal."

now you know why its $250,


ever heard of rockauto.
http://www.rockauto.com/catalog/raframecatalog.php?carcode=1398900&parttype=5292


same story.


Aug 11, 2014 | 1997 Isuzu Rodeo

1 Answer

4ze1 rodeo amricana


si el sensor de levas o el sensor del siguenal estan danadosno le van a mandar el neutro o la face depende del carro cuando trates de encender checa esos sensores alguno esta fallando

Jan 29, 2014 | Isuzu Amigo Cars & Trucks

1 Answer

Where is MAF sensor on 1994 isuzu rodeo Runs rough


The sensor should be right there where the intake air duct meets the air filter housing.
That oil down in the spark plug tube is most likely from a leaking valve gover gasket. Oil in there can and will cause misfires.

Oct 07, 2010 | 1994 Isuzu Rodeo

2 Answers

1990 Isuzu 2.6 L 5 spd. No start.. Fuel pressure is ok, not getting spark. Checked coil, ignition module, distributor, computer and coil wire. No power coming from the coil. Small voltage going into...


assuming you the coil, plugs, cap, rotor and wires are good. check the cam sensor, If you have 12 volts to the coil using a 12v light tester. The cam sensor responsible for sending info to the computer telling it that the cam is turning, then the computer tell the coil to dispurse the charge/sparks to the distributor as distributor distribute the sparks to each plugs from the rotor of the distributor. Replace the cam sensor, it tend to go bad over period of time.

Dec 23, 2009 | 1990 Isuzu Spacecab

1 Answer

I replaced the o2 sensor and 2 catalytic converter on my Isuzu1995 Rodeo but it is still accelerating slowly any ideas?


I would replace the fuel filter, or filters if you have more than one. If that doesn't work, have pressure on your fuel line tested to see if it is up where it should be. If it is not, you will most likely end up replacing the fuel pump. Your lack of power could also be attributed to bad spark plugs, bad plug wires, or even a bad coil. If your vehicle has a distributor, you might consider replacing the distributor cap as well as the rotary button.

Jun 10, 2009 | 1995 Isuzu Rodeo

1 Answer

Isuzu Rodeo Photo Cover fuse


my fuse for the rear tail lights keeps blowing after 20 sec,

Nov 30, 2008 | 1992 Isuzu Rodeo

Not finding what you are looking for?
1995 Isuzu Rodeo Logo

Related Topics:

794 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14380 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...