Question about 1993 Buick Skylark

Open Question

No start,3.3 no spark or injector pulse

I have no rpm input on scan tool. cranks oka, tried diff module and when you jump a and b pins at the crank sensor plug and grd the a pin with a test light i get no spark or pulse at the injectors from the ign module. Is there any inputs from the ecu that could stop the rpm signal?

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

CMV9
  • 594 Answers

SOURCE: 1996 Buick Regal Custom w/3.1 liter-No Spark

disconnect you battery. take something and fray back the plastic on the main hot wire on the coil. take another wire and wrapp it to the main wire you just frayed. now take that wire and run it to you ignition fuse. re connect you battery and see if your vehicle will start. if so than you have either a break or a short in you hot wire for your coil.

Posted on Aug 01, 2008

  • 4 Answers

SOURCE: no start,91 regal 3.8 w motor

sounds like an ignition module

Posted on Aug 02, 2008

  • 4 Answers

SOURCE: no start

if it runs on starting fluid its a fuel problem.. check fuel pressure even if its a couple of pounds off, the vehicle will not run. but using starting fluid may give you the extra poundage you need to make it run . also check vacuum hose at pressure regulator on fuel rail

Posted on Aug 02, 2008

erietrack
  • 37 Answers

SOURCE: 1991 Buick Regal will not start

Chech to see if you're gettin a signal from the crankshaft position sensor located behind the crank pulley. If no signal, you have either a bad sensor or a bad crank pulley. There is a reluctor ring on the pulley that separates and goes bad. If you have a good square wave signal from the the crank sensor it's probably going to be the computer. I've replaced a lot of them. They do really wierd things when they start to go. Check all of your grounds first. Also, while the car is running, shake and pull on the wiring harnesses for the computer. I've seen on a few cars where a wire or 2 will go bad and cause and occational short.

Posted on Nov 07, 2008

johnny5846
  • 379 Answers

SOURCE: no injection pulse

looking at the schematics, well the PCM controls the pulse width to the injectors , BUT , there is a injector coil fuse , its #2 in your kick panel fuse box , a 20 amp , check it , sure hope that fix ya . that would be sweet .

J5

Posted on Jan 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i check for RPM signal on the dash with out using a scan tool?


the tachometer works from the pulse generated for the spark in the ECM or in the ignition control module
the meter is extremely unreliable at cranking speed so at best the needle may flicker at anything under 150 rpms cranking speed
no spark can be from
cam/crank position sensor problems
broken timing belt / chain
ignition control module
ECM
immobilizer
run the fault codes to get an idea of the area of failure

Dec 15, 2016 | Cars & Trucks

1 Answer

My 2001 Malibu has 3100 engine..turns over but not firing but getting gas..replaced crankshaft censor,camshaft censor,ignition control module,coil packs and theft light is not on.


Did you check for battery positive voltage at the pink wire at the ignition module , you have three connectors ,one with 4 an two with two wires , the one with pink an black ,that's power an ground . is there power an ground ? Which crankshaft position sensor did you replace , yours has two ! crank sensor A an crank sensor B . A is an input to the PCM - engine computer , B is an input to the ignition module .Does your check engine light come on when you turn on the key ? an go off when you crank the engine ? You tested for spark at the coil ? Pull two pull wires on same coil an crank over the engine , is there spark jumping from one terminal to the other ?
Engine Cranks But Does Not Run
Inspect for the following conditions:
?€¢
Mass air flow (MAF) is compared to a calculated mass air flow based upon the manifold absolute pressure (MAP), throttle position (TP), and engine RPM readings. A skewed or unresponsive MAP sensor at KEY ON will cause the predicted air flow value to be inaccurate. Compare MAP and TP sensor value to that of a known good vehicle.


?€¢
A faulty engine coolant temperature (ECT) sensor. Compare the ECT with intake air temperature (IAT) on a completely cool engine with a scan tool. The ECT should be within 3?°C (5?°F) of the IAT. If not, refer to DTC P0128 .


You need a scan tool to check this stuff !
1
Did you perform the Diagnostic System Check-Engine Controls?
--
Go to Step 2
Go to Diagnostic System Check - Engine Controls

2

  1. Turn ON the ignition, with the engine OFF.
  2. Observe the DTC information with a scan tool.
Does the scan tool display DTC P0101, P0123, P0230, P0601, P0602, P1626, P1630, or P1631?
--
Go to Diagnostic Trouble Code (DTC) List
Go to Step 3

3

  1. Turn ON the ignition, with the engine OFF.
  2. Inspect the following fuses for an open:
?€¢
F/P INJR


?€¢
ELEK IGN


?€¢
F/PMP

Did you find an open fuse?
--
Go to Step 10
Go to Step 4

4

  1. Attempt to start the engine.
  2. Monitor the engine RPM parameter while the engine is cranking with a scan tool.
Does the engine RPM parameter display cranking RPM?
--
Go to Step 5
Go to Electronic Ignition (EI) System Diagnosis
  1. Monitor the Cylinder 1-6 Injector Circuit Status parameter with a scan tool.
  2. Crank the engine.
Do all of the Cylinder Injector Circuit Status parameters display OK?
--
Go to Step 6
Go to Fuel Injector Circuit Diagnosis

6

Command the fuel pump ON with a scan tool.
Does the fuel pump turn ON?

Aug 20, 2015 | Cars & Trucks

1 Answer

1991 chevy lumina will crank but wont start I checked the fuel pressure it squirts out good and the fuel pump sounds strong I checked spark on the coil its sparking good! I charged the battery its fully...


If you have spark at all the plugs, the crank sensor should be ok. You should use a gage to check fuel pressure? I don't know engine size? For the 3.1L engine, my info says 40--46 psi.
It is possible to have spark at the plugs, but, the computer doesn't see rpm signal. If that is the case, no fuel injector pulse. The purple wire with white tracer carries rpm signal from ignition module to pcm, that wire has dc pulse, engine cranking. If nothing there, have to check ignition module.
How long since a tune-up? Any applicable trouble codes?

Jul 29, 2017 | Chevrolet Lumina Cars & Trucks

1 Answer

Suzuki Aerio 2004, will crank over floods out tho. Changed Plugs and Boots. New baterry too. Can smell gas @ Tail pipe. Wants to fire-but just won't catch. Where do I start looking for the answers.?


what engine? 2.3 or 2.5L?
all cylinders flooding??? spark tips on ALL dripping in gas?
check spark at all spark plugs ( ALL not just ONE)
if spark is good.
this engine is chain cam, so it makes huge noise before death.
did it?, nah
ok, so connect any $9 scan tool, and scan it. (barrow /rent.?)

you crank it for 5 seconds, not less.
and as you crank the scan tool RPM shows 250 to300 rpm and fails to start, the RPM on the tool shows you that the crank sensor is working
now release the key and do not turn off
look for DTC errors. got P0340,355? or any other DTC
that decodes to bad CMP or CKP/
yes, BINGO, the scan tool told you why spark is dead, or way off
timing,

the PCM will report Cmp or CKP errors even 1 in 6 pulses.
the PCM runs monitors against these 2 full time. and will see it fail.
and report, it, let it tell why spark is bad.
say spark is good. and still floods.
1: engine compresssion over 150psi? W.O.T?
2: flooding , i pull the fuel pump relay and crank now.
starts and runs for 3 -5 seconds, yes, that is the flood clearing
so i then try test fuel, runs perfect now (no fuel pump) ???
runs for 3 second, each test fuel usage. well good motor, good spark.
what more do you want? sure to run
so you have either insane high fuel pressure. or injectors leaking
can and does happen.
the tests are all in the FSM under injector and pump testing.
i check fuel pressure first. as its a mandatory thing.....
to factory spec. for unsaid engine.
then i do a injector leak down and balance check.
ask if you get this far.....????


Jan 24, 2014 | 2004 Suzuki Aerio

1 Answer

I have a 2003 Oldsmobile Alero 3.4L that wont start. I have done fuel pressure test 50-55 psi and plugs have good spark. However when done light test on injectors there is no response so there is no pulse....


Is the security light staying on ?
Usually the engine will not crank and you have no power to the fuel pump if the security system is disabling the car.
No injector pulse but spark would point to the computer since both use input from the crank and cam sensors.

Dec 22, 2012 | Cars & Trucks

1 Answer

No power to the injectors



No injector pulse at injectors:
a) check fuses
b) use scan tool to read RPM at PCM while cranking. Ask question specifying RPM PID data.
c) crank sensor/cam sensor/ign. module/wiring fault
d) stuff not plugged in properly
4) check fuses
5) dead PCM note PCM pulses injector ground based on sensor input, power is constant from ignition
how are you testing injectors theres something called a noid light auto parts store let you use them free you have to test it on the injector itself what did you car do before it died does it turn over but not start

Dec 03, 2010 | 2002 Pontiac Grand Am

1 Answer

1990 gmc 6500 topkick with no spark or injector pulse. all 4 wires on the ignition coil have battery voltage with key on. is coil shorted or is the ignition module bad?


You are jumping to conclusions. Slow down.
No spark AND no injector pulse indicates none of the desired outputs were triggered. The ignition module makes spark when it receives a crankshaft position sensor signal, and then transfers control of that spark to the computer after it starts. The module takes its crank sensor signal and generates an RPM count that it forwards to the PCM(main computer) which is used for triggering the injectors and controlling timing. SO, if you had a bad crank sensor OR a bad ignition module, you could lose both spark AND fuel. a coil would not disable injector pulse. modules RARELY fail in a manner that disables RPM reference to the computer causing it to not fire the injectors...At this point, I would TEST the crank sensor as the next step. If its easier, 1 of the wires on the module goes directly there so you can test the crank sensor at the module.

Sep 18, 2009 | 1990 GMC K3500

Not finding what you are looking for?
1993 Buick Skylark Logo

Related Topics:

72 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8172 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...