Question about 1995 Chevrolet Blazer

1 Answer

95 Blazer W engine V6, Runs real good until fully warmed-up. Stops and won't start again for over a 1/2 hour. Has good fuel pressure and no spark at spark plug. Have switched PCM,module,coil, cap

Have checked wiring and all OBD II connections and sensors. No engine codes shown.

Posted by on

  • Gunnar Lund Mar 06, 2012

    I changed the crankshaft sensor and this corrected the problem, Chevy repair manual states the crankshaft sensor if bad will show one or two OBDII PO codes. No SES codes were listed, go figure!

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 5,370 Answers

Car not starting or turning over indicates towards multiple possibilities. It can be issue with battery or weak battery. But if battery checks out ok, then it can be starter issue or faulty alternator or problem with low fuel pressure or no spark at spark plugs due to dirty spark plugs or faulty ignition coil or injectors getting cracked or dirty and needs to be cleaned.


To confirm the problem, the basic troubleshooting is required.


Click this link below and follow the troubleshooting:------

http://technoanswers.blogspot.in/2012/02/car-starting-issues.html

---------

This will help.

Thanks.

Posted on Mar 05, 2012

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 611 Answers

SOURCE: i have a 95 s10 blazer with a 4.3 v6 vortex in it

most likely fuel pressure regulator or the lines but the early style injectors cause these problems

Posted on Jul 10, 2011

  • 2039 Answers

SOURCE: codes P0440 and P0300

the evap can simply be the gaz cap the 300 check for a good spark you may need wire and plug be carefull for those coil they offent defect good luck pierre

Posted on Jun 23, 2008

  • 2 Answers

SOURCE: computer and obd II not communicating with each

Check your fuses i had one 2 days ago that would not communicate and it had a blown fuse to cigarette lighter

Posted on Jan 23, 2010

  • 1 Answer

SOURCE: codes P0440 and P0300

I have a 2005 chevy suburban and it's getting a p0300 code. I replaced the plugs and wires and still have the same problem . It runs rough at idle in gear. What should I check?

Posted on Mar 15, 2010

  • 1 Answer

SOURCE: firing order for v6 chevy distributor

my truck has a small backfire while running. I`ve changed fuel injecter,egr,and the whole eghaust system with a tune-up.

Posted on Mar 24, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

2002 chevy 3.6 vortec runs rough misses until warm


check fuel filter and air filter if its clean check your fuel pressure regulator

Apr 17, 2014 | 2003 Chevrolet Blazer

1 Answer

MY 89 4X4 BLAZER BACKFIRES IN THE ENGINE HOW DO I FIX THIS


The backfire could be a problem with the distributor cap or plug wires, or lack of fuel. The cap or wires could get damp and short out until the engine gets hot.
The fuel pressure could be low or not steady until the engine warms up.

Dec 17, 2012 | 1989 Chevrolet S-10 Blazer

1 Answer

T10 blazer hard to start when cold,easy to start when hot


4.3L V6 CPI - center port fuel injection . you need 62 psi .When cold give it a shot of carb.cleaner or starting fluid ! does it start then ?

415-455 kPa (60-66 psi

Mar 18, 2017 | Cars & Trucks

1 Answer

92 grand caravan starts poorly, then runs ok when warmed up, then poorly after 30 min. to 1 hr. of driving. Then stalls and won't start till 30 min. or so later.


Hello
The engine and automatic transmission in this vehicles drive train are fully electronically controlled by a computer called the PCM (Power Train Control Module). Whenever a problem like this occurs the computer stores a record of the problem (there are of course some exceptions to this, like the fuel pump, engine coolant temperature sensor and MAF sensor for instance) in the form of a fault code in its memory, to read these fault codes you must have the systems memory scanned with a special tool. Once the fault code(s) are read you then must perform the appropriate diagnostic testing to find and resolve the problem(s) DO NOT REPLACE ANY PARTS UNTIL A TRAINED TECHNICAIN HAS DIAGNOSED THE PROBLEM TO AVOID SPENDING YOUR HARD EARNED MONEY ON PARTS THAT MAY NOT CORRECT THE PROBLEM

Aug 26, 2012 | Dodge Grand Caravan Cars & Trucks

1 Answer

1985 toyota 4runner running too lean


Maybe it's not running lean. Maybe it's misfiring. Since you put in new fuel parts and that didn't help, maybe there is an ignition component that fails when it gets hot. A bad coil can do this, also the igniter-rarely, admittedly, but you could have it tested. When it stalls and won't start, if you check for spark and find none, it would confirm an ignition problem.
I hope you find it. Post back and let us know.

Jul 29, 2012 | Toyota Cars & Trucks

2 Answers

1991 camaro rs v6 runs good tell it gets hot


You'll need to figure out if it is fuel or ignition related.
Some common things to check are trouble codes in the computer, fuel pump pressure, and sensor readings.

Jul 14, 2012 | Chevrolet Camaro Cars & Trucks

1 Answer

Have a '94 S-10 Blazer Tahoe 4X4 and it starts


My suspicion is a starter going bad. Sometimes when starters get old and worn they will start good when the engine is cold but not when the engine is warmed up. Did you perhaps notice that lately is seemed to drag when you tried starting, especially warm or it seemed to crank a little slower? I'd replace the starter. Hope this helps.

Aug 14, 2011 | 1994 Chevrolet S-10 Blazer

2 Answers

Car runs 6 minutes then stops. Fuel pressure good.


well since you already swapped the ecu that should rule out the question I would say sensor problem.

Oct 21, 2009 | 2000 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

327 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...