Question about 1996 Honda Accord

1 Answer

Hazards work but turn indicators do not.

I put the hazards on the other night and now the turn indicators don't. It's not a fuse, and I'm pretty sure it has something to do with the 12v plug under the kick-panel. I can't seem to get a straight answer on whether there's a second one for the indicators and the hazards. Also, I can pull the first one (that says hazards on it) but not the one in the back - which feels different than the one I just pulled. I'm hoping that it's not the actual switch itself since I'm a poor college kid trying to fix this problem myself. Can anyone help me?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 20 Answers

Dont mess with any plugs or any connectors, its probably a bad relay, find the turn signal relay, and replace it. and i to believe there is a different fuse for turn signals, and hazard flashers. But that was on a jeep, not a honda.
Best of luck, if all else fails, visit your local honda dealer and they will most assuradly inform you on how to fix it, or just visit a Kragen, Pep Boys, Auto Zone, or Advance, they can help as well, someone has dealt with a 96 accord, im sure of it.

Posted on Oct 22, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Its 51 plate. i had to replace the hazard warning switch which is also the relay for indicators because my indicators and hazards were only working now and again now i have perfect hazards and no...


is a new hazard switch you replaced it with and check to make sure the hazard swith is coming all the way out if it hangs just a little bit it will be in a neutral position and the turn signals wont work and if thats not it your multi-fuction switch feeds the turn signal lights it could be faulty

Apr 13, 2013 | 2001 Volkswagen Beetle

1 Answer

Turn signal indicator doesnt work accord 1998


i think its the indicator relay under the bonnet in with the fuse box

Feb 11, 2012 | 1998 Honda Accord

1 Answer

How to fix turn signal on 86 Chevy Astro Van


you don`t say but do the lights work either on the front/back on both sides.if not then it may be a fuse that needs replacing or need a bulb replacement.if the lights work but don`t flash then it sounds like a signal flasher problem.the flasher is located in the fuse panel under the dash on the drivers side.if the hazard flashers work then turn them on to find the hazard flasher by the fuse panel then you will know what the signal flasher looks like and change the signal flasher.make sure you change the one for the signals and not the hazard one.if the hazards work then i would say the signal switch is good as the hazards work through the same switch.

Apr 21, 2011 | Chevrolet Astro Cars & Trucks

2 Answers

VW Transporter,replaced the indicator stalk/switch but indicators


make sure the multi plug connection is in right ,if still no joy then unplug it and try the hazards ,if they work without the unit plugged in then check for a feed to the multiplug .if hazards do not work with multiplug disconnected then you have faulty switch or the wrong one

Dec 04, 2009 | 1998 Volkswagen Passat

1 Answer

Tail lights stopped working (keeps blowing fuse)


you could either have a front marker/signal lamp w/lamp grounded and causing this,remember...when tail lights are on so are your frt parking/marker lights on also..... other than that you could have a feed wire worn thru and grounding out to the frame

Sep 13, 2009 | 1994 Lincoln Town Car

1 Answer

98 Hyundai Elantra turn signal and hazards only work sometimes.


You need to replace the fuse - have a look at the manual and see which fuse it is buy a new one put it in and it should be fine - the on off thing is where the fuse wire touches and then moves again.

Dec 29, 2008 | Hyundai Motor 1993 Excel

Not finding what you are looking for?
1996 Honda Accord Logo

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top Honda Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6869 Answers

Are you a Honda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...