Question about 2005 Chevrolet Silverado 1500HD

1 Answer

Instrument cluster lighting

The 15 amp fuse for instrument cluster lights keeps blowing there fore i have no dash lights. The fuse is the TBC2 fuse...any idea as to what the problem could be?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have same problem did u get a solution

Posted on Sep 03, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

92 roadmaster instrument lights


Oh boy, I just went through this with my '92 Lesabre, took a long time to trace it all down, and wound up splicing in a new wire just to my instrument cluster lights. A short kept blowing fuses somewhere in that circuit.
Down where your feet go, up under the dash at the fuse panel, there is a 15 amp fuse for park/tail lights. When you hit the light switch (for heads or park lights), power is sent to that fuse, and then to the exterior park lights. There is another wire from that fuse (green wire on mine) that also goes up under the dash, and splices to several bulbs-on the radio, on the HVAC controller, on the ashtray light, also one to the under hood lamp, and then one to the dimmer/brighter switch on the dash, the rheostat that controls brightness of interior lights. One of the green splices goes into this switch, and then another wire goes from this switch to the instrument cluster for the gauge and dash illumination. I couldn't find the short, so ran a new wire from the park light fuse to the gray wire to the instrument cluster for the cluster bulbs. I bypassed the dimmer, and left off the HVAC bulbs and ashtray light. Too much trouble to wire them all up, and think my short may have been in the dimmer rheostat.
If you have a voltmeter, pull out the dimmer switch and check for power on those wires, the green from the fuse. The park light must be switched on, or the fuse has no power. There be 8 or 9 wires on that dimmer rheostat-I never did figure out where all of them went. Asked all over a Buick forum, but nobody had an answer.

Dec 02, 2016 | 1992 Buick Roadmaster

1 Answer

1989 chevy s10 ignition/gages fuse keeps blowing


If you think there is a problem with instrument cluster, unplug the instrument cluster, see if it still blows the fuse. Could be a wiring circuit problem, somewhere? Maybe fuse box issue?
Sometimes, I use a test light in place of the fuse, to keep from blowing all my fuses. If the test light comes on, the circuit is going to ground, somewhere. If the instrument cluster is unplugged, then hopefully, that is ruled out.

Oct 12, 2016 | Cars & Trucks

1 Answer

2005 Civic Temp Control & center dash lights not working -blower & all vent settings are functional ,I have checked all fuses under column & underhood with NO blown fuses


Your instrument cluster and console lights are protected by fuse #2 (15 Amp) in the underhood fuse and relay box. They actually get power from the tail lamp relay. If the tail lamps are working, the relay and the fuse is not your problem. The brightness of these lights are controlled by the Multiplex Control Unit and theCPU built into the instrument gauge cluster. The dimmer circuits are actually integral with the instrument cluster. If the tail lights are working and the lighting in the instrument cluster is working, then the problem is either a CPU failure in the instrument cluster or an open circuit between the instrument cluster and the center console lights. The console lights themselves should have power all the time that the tail lights are turned on. The CPU in the instrument cluster provides ground for them to function. The wiring is a little different depending on which model you have and how it is equipped (LX, DX, EX, LX with side curtain airbags, etc.) however, the function is the same.

I highly recommend scanning your computer network for fault codes before spending a lot of time trying to perform electrical diagnosis. There may be a fault code present that will lead directly to the cause.

Sep 15, 2011 | 2005 Honda Civic

1 Answer

No indicators working found fuse box which fuse?


When you are talking about "indicators" we could assuming that your are refer about signal lights. This work with "flashers" devices.

For 1996 Audi A4 2.8L SFI 6cyl the Flasher is located in front seating area, driver side, under dash, behind dash lower panel, mounted above driver side of steering column.

About generic fuses, open the driver side door. Remove panel on left side of dash. Fuse box is behind panel:

Fuse # / Description / Amps
1 / Heated washer jets / 5
2 / Turn signals flasher unit / 10
3 / Headlight washer, illumination of glove compartment, engine compartment, climate control, automatic transmission, instrument cluster / 5
4 / License plate light / 5
5 / Instrument cluster, seat heating, test connection for cruise control, bulb monitor for auto-check control, Automatic transmission display, switch lighting, mirror switches and actuators, airbag warning light, outside temperature indicator, Climate control / 10
6 / Central locking system / 5
7 / Anti-lock brake system / 10
8 / Vacant
9 / Mirror heating / 10
10 / Vacant
11 / Cruise control (automatic transmission) / 5
12 / On board diagnostic system / 10
13 / Brake lights / 10
14 / Interior lights, reading lights, anti-theft alarm system, vanity mirror / 10
15 / Instrument cluster, power windows, climate control, automatic transmission / 10
16 / Anti-lock brake system, Anti-Slip-Regulation / 5
17 / Heated door locks / 10
18 / High beam right / 10
19 / High beam left / 10
20 / Low beam right / 15
21 / Low beam left / 15
22 / Tail and side marker right / 5
23 / Tail and side marker left / 5
24 / Wiper and washer system / 25
25 / Blower for heating, climate control / 30
26 / Rear window defogger, mirror heating / 30
27 / Rear window wiper / 15
28 / Fuel pump / 15
29 / Engine timing / 20
30 / Sun roof / 20
31 / Tail lights, cruise control, automatic transmission / 15
32 / Engine timing / 20
33 / Cigarette lighter / 15
34 / Engine timing / 15
35 / Trailer receptacle / 30
36 / Fog lights / 15
37 / Radio / 20
38 / Luggage compartment light, central locking system / 15
39 / Emergency flasher / 15
40 / Horn / 25
41 / Anti-lock brake system / 25
42 / Vacant
43 / Vacant
44 / Seat heating / 30

Hope this helps (remember to rate and comme this free answeer).



Jun 16, 2011 | 1996 Audi A4

1 Answer

Insturmentation panel lights fuse blows when i start car


Try to remove the instrument panel and disconnect the harness to see if doing that gets rid of the blown fuse when starting the car. If it does, then the instrument panel should be replaced with another. If the fuse still blows when starting, then there is a wire shorted to ground somewhere.
---
Instruments and Switches Instrument Cluster Removal & Installation To Remove:
  1. Remove the instrument cluster trim plate.
  2. Remove the instrument cluster mounting screws.
  3. Rotate the instrument cluster rearward and lift up on the top of the cluster in order to disengage the locating pins.
  4. Disconnect the electrical connectors from the instrument cluster.
  5. Remove the instrument cluster.
To Install:
  1. Connect the electrical connectors to the instrument cluster.
  2. Position the locating pins to the holes in the instrument panel.
  3. Install the instrument cluster by rotating the top inward.
  4. Install the mounting screws.
  5. Install the trim plate.
prev.gif next.gif

Nov 09, 2010 | 2001 Pontiac Grand Am SE

1 Answer

Hello, Im a US Marine and dont know alot about automotive but Im not completly numb... My father in-laws 2003 4x4 dodge pick has been blowing fuse #18 which when blown or removed the dash lights go out......


That fuse also supplies illumination to the radio, hvac controller, cup holder and cigarette tray. I think the best thing to do is start unplugging each one of these until the fuse stops blowing. Then plug the last think in that you unplugged to make sure that makes the fuse blow. If you suspect the instrument cluster start with that first.

Sep 28, 2010 | 2001 Dodge Ram 1500 Truck 2WD

2 Answers

My 96 blazer keeps blowing gauge fuse which is a 10 amp but it has also blown 30 amp fuses,please help


unplug the instrument cluster. If it now does not blow, replace the instrument cluster. If it stll blows then you need to trace the wire in the loom looking for where it touches metal or have several wires melted together.

Mar 19, 2010 | 1996 Chevrolet Blazer

1 Answer

2000 ford focus dash lights not working


Check Fuse box Number 30 which is a 10Amp fuse
& number 15 which is a 7.5amp fuse.
you met have a blow fuse.
If good
Did you check the dimmer on the head light switch Pull out to see if you have power on cable color orange / blue. (Pin 9)
If this is good
Pull cluster out to see if you have power on plug pin 3 in instrument cluster this there..
If you have power
than replace the llumination bulb or cluster.
Very rare to find a ground poblem here.



Aug 29, 2009 | 2000 Ford Focus

4 Answers

Instrument panel went dead


Checked Every fuse in the fuse box (no small task).This includes #4 - Power point Instrument Panel, #14 - Day time running lamps (auto lamps doesn't work nor does auto lock), #27 - ignition switch run feed, #35 - Instrument Cluster, #41 - Instrument Cluster, #42 - Delayed Accessory, #45 - Ignition switch run/start feed, #102 - Door locks body security module, #103 - Ignition switch, #110 - Ignition switch, & #116 - Ignition switch. But I also check all other ones as well, they all register OK. AC panel & radio work. Turn signals work. Mileage does not work, trip computer does. So, basically, everything works except auto head-lights, auto locks, and the dash cluster (no MPH, RPM, mileage display, Fuel, Temp, Tran Temp, and Oil Pressure).

Aug 19, 2009 | 2003 Ford Excursion

1 Answer

No Dash Lights, Keep blowing #2 fuse


i would check the grounding wires. have you tried going to higher ampage on the fuse? There is definitely a short somewhere

Dec 07, 2008 | 1998 Jeep Cherokee

Not finding what you are looking for?
Cars & Trucks Logo

422 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6880 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...