Question about 2002 Mitsubishi Lancer

4 Answers

Its a 2000 lancer

Dashboard electrics are not working properly. speedometer/rev count/fuel gauge etc are dead, though indicators and door lights are still working.Ive replaced the fuse and theres still the same problem...really weird. any other ideas?

Posted by on

  • 4 more comments 
  • kurtmrussell Oct 22, 2008

    mitsubishi lancer ce 2000. instrument guages don't work all indercators and other instrument warning lamps work.. and all warning lamps share the same power supply and it is present at all pins.... maybe the dash has a voltage stabiliser hidden somewhere but all wiring diagrams don;t show it ... realy wierd....

  • Anonymous Dec 13, 2008

    The same problem here with my 2000 lancer. Speedometer, temperature, and revs sitting at the lowest position. Odometer does not show -- the lcd display is blank. The only one that works is the fuel gauge. 


  • spinfxtc Dec 22, 2008

    Yep same herewith my 2000 lancer. Just happened recently. My guages would work in the morning but then after sitting in the heat all day, the gauges stop working? What would cause this?

  • Anonymous Jan 08, 2009

    same with my mitsubishi lancer 1996

  • rickylatino Mar 09, 2009

    Dashboard electrics are not working properly. speedometer/rev
    count/fuel gauge etc are dead, though indicators and door lights are
    still working.Ive replaced the fuse and theres still the same
    problem...really weird.....I'm still looking for a solution since begining of last year. Anyone has a solution at this stange problem??

  • sebadb May 14, 2009

    TEngo el mismo problema en un Lancer, todo se ha quemado debido a la falla del regulador de voltaje. Intento reparar el velocímetro. quisiera saber acerca del integrado que maneja el mismo instrumento, de marca Yazaki. El principal(que comanda el display del odómetro) tiene 42 patas. La entrada del instrumento es: 12vdc alimentación, y 4,9 vac de señal de sensor, según un manual Mitsubishi similar. El segundo integrado es de 8 patas y podría ser un optocoplador. Alguien tiene mas datos al respecto....

×

4 Answers

  • Level 1:

    An expert who has achieved level 1.

    Governor:

    An expert whose answer got voted for 20 times.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

The problem will more than likely be the printed circuit board on the back of the instrument cluster. to remove this lower the steering wheel to its lowest position. there are 2 phillip head screw in the top of the surround remove these and pull surround out. there are 4 screw ,2 top and 2 bottom which hold the instrument cluster in place.remove and then pull the cluster toward you and out. I found the crack in mine to be on the long turn over section which turned out to be between the oil warning light and the hand brake warning light which in my case stopped working along with the tacho and speedo. I repaired the crack by scrapping off the lacquer coating and repairing the track with a circuitworks Conductive Pen - Micro Tip made by chemtronics and purchased from **** smiths ( fairly dear though aprox $40 ).

Posted on Feb 25, 2009

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I managed to fix my problem. I had a close look at the circuit board at the back of the gauge cluster and found a hair line fracture in one of the tracks. It was such a small fracture but it was there and was stopping my whole guages from getting power. I just scratched the blue coating off the track surrounding the fracture and soldered a small wire across the fratcure to join the track up again. It worked, was nothing major and didint take long at all. Saved me lots of money!!

Posted on Jan 03, 2009

  • Level 1:

    An expert who has achieved level 1.

    Governor:

    An expert whose answer got voted for 20 times.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 11 Answers

The printed circuit board on the instrument cluster always fail on these cars best bid go by a new one from the dealership because second hand ones are not trustworthy in life time

its a common problem for the circuit board to fail

Posted on Jan 02, 2009

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I just wanted to say thanks to "spinfxtc" and "mister g" for your solution to my instrument cluster problem... If it wasn't for you I'd still be driving with a dead instrument cluster. Big kudos to you both !!! :D

Posted on Apr 28, 2010

3 Suggested Answers

  • 82 Answers

SOURCE: speedometer not working fuses are fine

ok if its a cable driven speedo then the cable has snapped or the speedo drive that goes into the gearbox is gone ,,also if its electric speedo then id go with the electric speedo in the gearbox ,,,a ten mil nut holds it in and it goes straight down into the gearbox,,youl see it from under the bonnet ,,

Posted on Apr 24, 2009

  • 82 Answers

SOURCE: My dashboard lights don't work on my 2003 mitsubishi galant. Is there a fuse box?

Yes, There is a fuse box ... your owners manual will asssit you in locating it and the suspect fuse ... do your parking lamps work? Is your dimmer turned all the way down?

Posted on May 01, 2009

  • 7 Answers

SOURCE: 99 lancer,speedo tacho n gauge problem.

probably burnt or cracked circuit board on back of gauge cluster

Posted on Jun 21, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Every thing works no gauges working


None of my gauges will work, but my turn signal indicators ...

www.americanautowire.com/.../none-of-my-gauges-will-work-but-my-tu...
None of my gauges will work, but my turn signal indicators, high beam ... As we've discussed previously, anything electrical needs a 12 volt feed and ground to work. ... 09/28/2015 There are a number of new products coming in Nov/Dec this ...

my gauges quit working - CarGurus

www.cargurus.com > Questions > Ford > F-250 Super Duty

CarGurusSep 21, 2013 - my gauges quit working - My odometer, speedometer, fuel, tach, trip, and ... I tried fixing the wire and had the same problem....so I replaced the shift lever and everything is back to ... no gauges will work in dashboard 1 answer.

No dash gauges, but dash lights - Car Forums and Automotive Chat ...

www.automotiveforums.com > ... > Dodge > Caravan ' Voyager
Feb 6, 2010 - The dash lights work fine, so does everything else. The dash gaugesjust don't work. This is something that has been an intermittent problem ...

Dec 05, 2015 | Cars & Trucks

1 Answer

Why are my Bravo dashboard instruments not working?


When the battery is not working ( flat -dead or removed ) it affects the CPU program which affects various operation such as what you describe . Mostly it can be fixed by the removal of the earth wire but to do the job properly use a scanner to reprogram the CPU.

May 21, 2014 | 1995 Fiat Bravo 100

2 Answers

Dashboard is dead


hello Sylvia i think you have had your dash board taken out at some
stage previous to your owning it, there is a big electrical connector
that hooks up to the printed circuit board behind your dash. you will
need to get a techy to pull off the plastic masks around your dash
and unscrew the speedo console. we used to get alot of this fault
here in New Zealand when sellers of vehicles were clocking the
speedo's to show a lower mileage reading on the odometer, very
nasty.
cheers bucky

Dec 31, 2012 | 2004 Cadillac Escalade

2 Answers

The speedometer and the dashboard are not working


chech ur fuses or the flasher fuse block

Jul 24, 2012 | 1998 Nissan Maxima

1 Answer

DASHBOARD PROBLEM WITH GAUGES NOT WORKING. 2000 BUICK LASABRE


your gauges need to be replaced it sounds like you have a bad mother board on it.

Jan 30, 2010 | 2000 Buick LeSabre

2 Answers

Everthing on my dash (speedometer,odometer,fuel


Blown Fuse or fried Circuit board. Take to a local AutoZone, Advance, Murray's, O'reillys or a similar part house for them to check the wiring. I'm assuming the van does not use a mechanical Speedometer or Fuel Gauge.

On the plus side, with no speedometer, your indicated odometer mileage does not increase. Just keep your speed down and your tank full. Kidding, just kidding.

Jan 05, 2010 | 1992 Dodge Caravan

1 Answer

Dashboard Instrument cluster does not work.


there are 2 large terminal plugs with the wiring for all the instruments that are plugged into the back of that panel. make sure they are snug and in place. You reach in and under but it may easier to "simply" remove the cluster. 4 screws hold it in place accessible form underneath and with a long phillips screwdriver and lighting.

Aug 26, 2009 | 1994 Jaguar XJ6

1 Answer

Electrical fault dashboard warning lights come on, sametime speedo/rev counter/fuel/water gauges/radio stop working fault occurs sometimes when brake pedal applied also sometimes when indicators used other...


It could be lamba sensor in exhaust gone faulty you need to get it on a diagnosic com puter really to check as modern engines have lots of sensor to monitor air fuel temparatures etc most garages have them now as all cars have electronic control units to control the running of the engine

Jun 22, 2008 | 2008 Volvo S40

Not finding what you are looking for?
2002 Mitsubishi Lancer Logo

3,378 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...