Question about Fiat Strada

1 Answer

PROBLEM GETTING INTO FIRST GEAR, WILL GO IN OK SOMETIMES BUT WHEN I HAVE STOPPED THE CAR AT A ROUNDABOUT OR JUNCTION IT TAKES A FEW GOES FOR IT TO GO IN. IT IS A 04 FIAT STILO.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 136 Answers

It could be tranny fluid, or your tranny may be screwed
change the fluid and filter and see what that does.

thanks.

Posted on Oct 16, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why dose my my car make banging noises going around roundabout and bends and


sounds like a suspension problem as weight being transfered around the suspension so get the springs and shock absorbers checked , easy check for shock absorbers, bounce car on each corner ,if car stops smoothly then ok but if continues to bounce after you've stopped bouncing it then the shocker is worn , get the springs tested at a garage as will need specific equipment etc

May 01, 2014 | Mazda 626 Cars & Trucks

1 Answer

Was in heavy traffic uphill in our toyota corolla verso (automatic) and after a while kept getting a beeping noise coming from the dash every time i put my foot on the accelerator. Was it overheating in...


There are times, such as approaching a roundabout, turning into a junction or coming down a hill when I have slowed down and then want to accelerate away again. When I put my foot on the accelerator, the car acts as though it has gone into neutral or that the clutch is slipping. I have tried watching the display to see what gear it is in when it does this, but can't see a pattern.

I have tried driving in ES mode but it made it worse.

Also, when in automatic mode, I sometimes get a bleeping noise at low speed but the manual says this happens in manual mode!

Has anyone else had these problems and found a way round them or do you think I should take the car back? I have done 2500 miles.

Sep 11, 2012 | 2005 Toyota Corolla Verso

1 Answer

Speedometer goes to zero every now and then


Does this happen intermittently, im guessing so with the wording "Now And Then" also when your coming to a junction/roundabout and the Speedo has gone to Zero, do you feel a decrease in power around 10% and dipping the clutch and braking causes the Red Warning light to flash top right hand side in the dash and the car wants to stall and or Cuts out?

I have this same Problem and Believe it could be the Speed sensor on the gearbox ( Around £30 on ebay that i have found) 50+ from ford Dealer.

My Quick fix to get the speedo back from zero this is what i have found works to make it come back It does not Totally fix the problem, it just makes it come back if the speedo has dropped again whilst Moving.

This normally stops it happening again until the next time the car is turned off or stood for a while I have noticed it happens More often when the fuel gauge is Below 1/4 and its been raining for some reason? so im thinking it might have a loose connector on the sensor and its getting wet? but have to get under to have a check.

try this to see if it works, it does for me and i have a V Reg Focus LX 1.6

------------------------------------------------------------------------------------------------------------

What to do when you notice the Speedo has gone Off .

1) turn the lights on and off then,

2) change DOWN a gear to 3rd, then UP to 4th then to 3rd again

3) and tap the Gear stick on the palm part with the palm of your hand quite hard and wiggle the Gear Stick left and right with dipped clutch in Neutral .

4) turn the main dipped headlights on and off again ( i found also if i have the Heater running it makes this happen so turn it on and off a few times)

5) if it is safe to do so, pull over and turn the car OFF leaving the key in the ignition and then back ON Within 10 Seconds, repeat 1) , 2) 5) again and repeat untill the Speedo Returns (normally within 2-3 mins of this procedure)

if anyone else knows how to fix it please Post any info :)

uni.ianjones@gmail.com

Feb 20, 2011 | 2000 Ford Focus

1 Answer

Engine cuts out when approaching a roundabout or junction, when slowing and clutch is down. Changed the speed sensor a few months ago which we thought had worked, problem came back yesturday


hi...
this is may be due to the idealing problem.set the idealing in correct amount so that it doesnt stops.

considering the speed sensors check any signal comin to the sensing unit is getting intruppted.

i think only these are the problem wihch may be the reason

Jul 09, 2010 | Ford Focus Cars & Trucks

1 Answer

My 2002 Ford Escape has been acting strange. The


I have the same problem! I also have 2002 Ford Escape and the radio/CD player just stopped while I was driving. It comes on when I start the car but goes off as soon as I put it into gear. My cigarette lighter (where I plug in my phone) also appears to not be working. This just started yesterday, so I don't have a solution. We've had a lot of rain here and my car has been outside. I'm hoping that something may just need to dry out. I'll post if I find something out. Please post any information that you've found!

Apr 16, 2010 | 2007 Ford Expedition Eddie Bauer EL

1 Answer

S reg peugeot 306 1.9 gearbox??


It may be the clutch thrust bearing drying up.
Causing it to start seizeing.
The easiest solution is to change the whole clutch, or get it changed in a garage as you do need some specialist tools and knowledge.
Check the fan belt as the can make the same screech when worn or loose.

Aug 26, 2009 | 2006 Peugeot 604

1 Answer

Mercedes c class with tiptonic gearbox. It seems to have got stuck in a low gear when I slowed down for a roundabout. When I accelerated to 50/60 mph, the rev counter was way too high and no auto gear...


It seems oil level is low in your gearbox, and it most likely leaking from adapter bushing ( where cable is connected to gearbox).
You need to replace seals or complete bushing and correct oil level.
Better if you visit your mechanic.

Aug 04, 2009 | 2003 Mercedes-Benz C-Class

2 Answers

1998 Saab 9000 ---My wife was driving through a roundabout when she shifted from 1st to 2nd gear the clutch lost all resistance and would not go back into any gear. I'm thinking I lost the slave cylindar...


You may have a bad slave cylinder, but if you do the system would leak. Sometimes the hose fails, and that also causes a leak. if there are no leaks, I would suspect the master cylinder.

Mar 01, 2009 | 1998 Saab 9000

1 Answer

Transmission problem


its because your saturn motor is manual and your car is automatic i have the same problem thats whaat they told me

Nov 22, 2008 | 1993 Saturn SC2

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

158 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fiat Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

yadayada
yadayada

Level 3 Expert

60667 Answers

Randy Ohler

Level 3 Expert

14054 Answers

Are you a Fiat Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...