Question about 1994 Acura Legend

1 Answer

Follow up question on my 1994 Acura Legend Speed Sensor

Would a bad/wrong/not installed properly VVS make the odomiter show the 10 miles too fast? My mechanic doesnt think so. The odomiter has been fine for 215k miles. He thinks something else is causing it. IE too big tires. I know they are the right tires..

Any thoughts.

Thanks

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 350 Answers

Hi frank just sent you an e-mail explaining the problem you are having there are a few problems that would cause the problem low fliuld level clutchs slipping low pump prussure torque converters locking clutch failing solenoids faulty but if no conversions have been done on the final drive and it was not doing this before keep it simple check the vss on a ohm meter to see if its within tolerance or just replace it with one that you know is correct for your car make sure all the connections on the sensor are making a good contact check the engines ground as the slightest resistance is all it takes but as i said if it was ok before you can can bet 99 out of 100 it is something the mechanic has done them odds are in your favour best of luck paul

Posted on Oct 15, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why wont my 1994 acura legend car door open right after changing tire ?


possible jacked the car in the wrong place and the door sill has bent up into the door opening
take it to a panel repair shop for a proper diagnosis of the problem

Sep 18, 2016 | 1994 Acura Legend

2 Answers

1994 acura legendwhere is sensor located


The speed sensor is in front of the oil filter. There is one 10mm bolt holding onto the differential and one wiring harness that needs to be unclipped. You will have two hoses coming from your power steering pump and reservoir. You need to crimp these somehow. I used some crimps from harbor freight tools made specifically to crimp hoses. Take your time. Do not force the sensor out. Just wiggle it side to side and it will pull out. Don't let anything get into the differential or you're gonna have a bad day. Installation is in reverse order. Hope that helps.

Jun 19, 2014 | 1994 Acura Legend

1 Answer

D4 light flashing, speed off by 10 and check engine light is on....1994 acura legend


When my D4 light started blinking means VSS (Vehicle Speed Sensor) or Trans wrong: DIY Transmission Service (Filter + Drain)

Hope helps.

May 23, 2011 | 1994 Acura Legend

1 Answer

92 Acura Legend with 232000 miles has an odometer that works for a whilethen stops working for a while. All other gauges work fine. What could be causing the this problem.


The connector in the back of the gauge could have a bent pin or bad connection to operate the odometer, or the odometer signal is bad from the VSS (Vehicle Speed Sensor).

Jul 02, 2010 | 1992 Acura Legend

1 Answer

1994 Acura Legend odometer quit


Most likely your magnetic speed pick up failed. It is redundant, so the car will still drive. Should get it fixed though.

May 24, 2009 | 1994 Acura Legend

1 Answer

Follow up question on my 1994 Acura Legend Speed Sensor


No that is not likely, if the VSS was doing this the transmission would not shift correctly, I am sure the issue is with the speedometer head, they can be repaired, you don't have to buy a new one, get the phone number of an authorized repair station form your local dealer.

Oct 15, 2008 | 1994 Acura Legend

1 Answer

1994 Acura Legend Transmition/ speed sensor question


hi yes if its registaring 10 mile out it will be sending wrong information to the gearbox replace it with one that works yates210456

Oct 14, 2008 | 1994 Acura Legend

1 Answer

Flashes "D4" and speedometer shows 0 MPH while driving


this sounds like a Transmission Speed Sensor. ive done about 20 of them , common on hondas

Sep 30, 2008 | 1994 Acura Legend

1 Answer

Acura Legend Sedan 3.2 lts 1994


replace de ignition module first.. if still wont start good chances is the crank sensor is located behind the timing belt.. my 94 legend use to do the same thing until i replace the crank sensor.. and also if u can afford i will suggest u to replace the main fuel relay too... all this is after u are 100 pcnt sure that ur fuel pump is working....

Sep 26, 2008 | 1994 Acura Legend

Not finding what you are looking for?
1994 Acura Legend Logo

134 people viewed this question

Ask a Question

Usually answered in minutes!

Top Acura Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Acura Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...