Question about 1984 Toyota Pickup Deluxe

1 Answer

Car keeps cutting off have changed plugs and wires can it be the battery post gone bad

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Toyota Master
  • 60,867 Answers

Change the crankshaft position sensor, this is a known problem for your issue with stalling out. Also run a self test of computer for any trouble codes.

Posted on Oct 14, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi ,i have s type jaguar. my battery gone flat and i cannot openthe booth at the back ,manualy or by electric. how to open the booth please ..help?


You can use one of the plugs that go into the power point/cigarette lighter. Cut the end off add wire to reach a good 12 volt battery. Plug it in. This should give you power to open the boot with the switch.

Aug 07, 2016 | 2002 Jaguar S-Type

1 Answer

1993 Mercury Topaz red light came on that looks like a battery. Put another altanator in and battery but light still on ?


must be a bad wire if you put a new battery and alternator in it. Are you sure the battery and alternator are good. One way to test the alternator is to run the engine and disconnect the battery [one post] while the car is running. If the car keeps running, the alternator is good. If engine cuts out and shuts off, alternator is bad

Jul 27, 2014 | 1993 Mercury Topaz

2 Answers

My 2001 hunduy accent stops running after 5 minutes- new fuel pump,plugs and wire .filter ?


Are you letting the car idle? If the car is idling and dies, could be a bad voltage regulator...
When it dies, does it show a bad battery light? or does it just cut off? If it just cuts off, you'll need to check and see if the car thermostat is sticking/ sensor has gone bad.

It could be a faulty temp sensor causing the car's computer to shut itself off. Either way- I'd suggest going to a reputable mechanic and have them bang on it if you can't do the simple n easy checks.

Sep 23, 2012 | 2001 Hyundai Accent

1 Answer

My 2001 toyota echo is cutting out bad I just changed the cat and both o2 sencers and spark plugs and its still doing it help please


Try replacing the spark plug wires if you did not change them when you did the plugs. It is very important that you pull one and only one spark plug wire at a time to keep them in the correct order or your car will misfire. You should change your fuel filter every 30k miles and they are usually about $20. Try the wires first and see what happens.

May 13, 2010 | 2001 Toyota Echo

1 Answer

The dash lights keep coming on. The brake light,


This same thing keeps happening with my car. I've had the battery, alternator, alternator wore and plug changed, and the lights still keep coming on, and car keeps cutting off. I talked to someone today and they said it might be bad wiring or fuses so.... that may be it!

Feb 15, 2010 | 1989 Toyota Camry

1 Answer

Changed out batterie and now tran,will not go in


Check the fuse to your transmission and the Transmission Control Module (TCM) wire harness. There are two fuse box places to check, one is under the hood by the battery and the other is under the dash on the driver's side. The TCM is located on the passengers side fender, check to make sure the wire harness has not gone lose. Good luck and keep me posted, the other problem that will cause this is a bad Vehicle Velocity Sensor.

Nov 30, 2009 | 1997 Dodge Caravan

2 Answers

95 Ford Crown Victoria. Battery light came on. Bought a new battery. After driving for awhile battery light cuts on and off. Radio, heater, and lights keep cuting on and off. When I step on the gas after...


easiest check is to put a voltmeter on the battery posts. Should be 14 volts or over with engine running. If not alternator may have 1 or more bad diodes.

Also, clean all the battery connections, incluidng small wires on poitive post, if present.

Nov 05, 2009 | 1995 Ford Crown Victoria

2 Answers

Chevy 350 no spark I have changed the coil, cap, and rotor. Still no spark. I also changed the plugs and wires about 3 months ago


Check the distributor module (ICM), it may have gone bad and needs to be replaced. It's around $40.00 and it's under the rotor in the distributor assembly. Check the red lead wire to the HEI for voltage, there should be 12 volts. It common for the ICM to fail on the HEI system and if you go to Auto Zone, they can give you the step by step instructions to replace the ICM. Good luck and keep me posted, be glad to help.

Jun 11, 2009 | 1989 Chevrolet C1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

163 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...