Question about 1985 Toyota MR2

1 Answer

Car wont start or starts and runs for apr 10 secs then dies

I drove to my pals left car overnight , when i went co pick it up it started and died, when i tried again NOTHING if i left it for 5 mins it would do the same again. i checked all fuel system except injectors then changed air inlet valve but still nothing at times i could make it run by tweeking throttle but always wanted to die as if too much air. then it would not start at all So i checked the coil :i only had a red spark not blue so fitted a new coil it then started but would only run if i tweeked the throttle and always wanted to die again ! then suddenly it wouldnt start again ! i have also changed spark plugs and ht leads but to no avail PLEASE HELP ????

Posted by on

  • 2 more comments 
  • leeky120 Oct 15, 2008

    ok thanks very much , have changed the air control valve but no change will now check for loose conections etc HOW DO I CHECK FUEL INJECTORS ? i have another set but of a 1989 model and have different connectors so do i cut the ends off and swap as i have the loom as well or is there an easier way ?

  • leeky120 Oct 15, 2008

    aaaaaarggggg i have changed the distributer , cleaned all earths checked pipes as best as i can without removing injection system, but nothing !! the thing i find strange is it was running and dying unless you tweaked the throttle(did sound a bit like sucking too much air) then suddenly just nothing not eaven trying to start ! changed coil ! and it ran again (if you can call it running ) and dying then suddenly nothing again ! soo frustrated lol

  • Gray MR2 Oct 23, 2008

    1st gen MR2 cranks but will not start. I too drained & replaced the fuel, replaced wires, plugs and cleaned the ground connections. I have ample spark. When starting fluid is sprayed into the intake the car starts and runs briefly for four (4) to five (5) seconds then dies. It was suggested that our MR2 will need a fuel pump, could this suggestion be the correct remedy to my concern? How difficult is this to service? Is it easy as working on other japanese vehicles?



    Thanks In Advance!

  • Anonymous Mar 25, 2014

    left flasher on to start car now u can start car without engaging flasher weird

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Hmmm.....Thing's to check..
1) check for loose connection's @ the dizzy, the coil, and alternater
2) fuel injecter's
3)Check for vacuum leak's around the inlet manifold/ throttle body
4) check air control valve.


Join up on www.imoc.co.uk, we have a very knowledgable mk1 section who will be able to go thru all possible causes and get you back on the road. ;-)

Posted on Oct 15, 2008

  • 3 more comments 
  • Cassi
    Cassi Oct 15, 2008

    Right to test the injector's, you'll need ohmmeter.

    With the car running listen as closely as poss to the injector's each in turn, they should all have a uniforn clicking sound/ pulse. If listening's difficult (on my car it is) place a finger on each and try to fell the vibration.

    If you find one that seem's out of sync, disconnect it (turn the engine off) and with the ohmmeter check the resistance. it should be 1.5- 3.0 ohms, if not replace it.

    Give me two sec's and I'll find out if a and b injector's are interchangable, I have a feeling they're not.


  • Cassi
    Cassi Oct 15, 2008

    Just another thought...i remember mine doing this earlier in the year.

    Check the earth connection down on the gearbox, mine was all cruddy and rusty. We took it off and cleaned both the point's up. Never had a problem with it since :-)


  • Cassi
    Cassi Oct 15, 2008

    Just another thought...i remember mine doing this earlier in the year.

    Check the earth connection down on the gearbox, mine was all cruddy and rusty. We took it off and cleaned both the point's up. Never had a problem with it since :-)


  • Cassi
    Cassi Oct 15, 2008

    Reading it again, it does sound like a vacuum leak. Hmmm...have you checked your vacuum hoses including the hard pipe's (that run around the D/S of the inlet manifold) Check em for crack's and spit's,hardening from age etc...

    Check your cam belt hasn't jumped a cog ? Is the battery still ok ?

    Iv'e been told injector's dont go wrong very often and it would still run on 3 cylinder's.

    Hope this all help's ;-)


  • Cassi
    Cassi Oct 15, 2008

    Aww dude I really feel for you :-(

    Get hold of me here cassandra.hill@tiscali.co.uk.

    It will turn out to be something silly, mk1's are a real pain to diagnose...have you pulled a fault code from her ? Email me for direction's if you dont know how to do this.

    Maybe the only way of getting to the bottom of it.


×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Runs until warm and shuts off


hello ther I belive it is your ecu very common

Feb 05, 2014 | Ford Explorer Cars & Trucks

2 Answers

2006 BMW F650GS


i would look to see if it is like efi on a car there must be a way to pull codes from the computer on it

Jul 25, 2012 | Cars & Trucks

1 Answer

Battery died now wont start


the security system need to be reset, plug your charger back on the battery then turn the ignition switch on and leave it on untill the security warning light turns off (about 10 to 20 Min) then turn the key to off wait 5sec then turn the car on it should be good to go, this solves this kind of problem 9 out of 10. good luck

Apr 07, 2012 | 2006 Saturn ION 2

1 Answer

I have a 95 s10 and its been sitting alot here lately i drove it the other day and it was hard to start and when it did start it didnt wont to run it is missing and stumbling real bad made it up the road...


If the vehicle has been sitting for a while, you should start by draining the fuel tank, and changing the engine oil. Gasoline does go bad if it is just sitting for a period of time, and will cause the issue you describe. Most likely, your issue is simply bad gasoline.

Aug 24, 2010 | 1995 Chevrolet S-10 CA Edition

1 Answer

I have a 1999 buick regal ls dying.


Check the harmonic balancer

May 26, 2009 | 1999 Buick Regal

1 Answer

92 gmc c2500 turbo diesel. starts then dies after a few seconds.


Sounds like the Pump Mounted Injection Module.. Starts, dies, Starts dies... Not a fun fix.. but atleast it's just under the intake..

Mar 30, 2009 | 1994 GMC Sierra

1 Answer

Will run for 5 sec and then it will not run


Could be a number of things.

Fuel pump, pump relay, plugged fuel filter, bad spark plugs, plug wires, coilpack/or/distributor
Most reasons are car won't start or stay running is a bad sensor.

Jan 17, 2009 | 1995 Ford Windstar

Not finding what you are looking for?
Cars & Trucks Logo

350 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...