Question about 1994 Chevrolet S-10

3 Answers

94 chev S10

Feels like its not getting any fuel changed fuel filter but still runs then dies starts about hours later

Posted by on

  • masonchad20 Nov 07, 2008

    I am having the same problem with my s10 it runs good tll warmed up then statrs missing and wont start till it cools down

  • missmollybsu Feb 17, 2009

    I replaced the ignition module on my 94 and after a week it started doing it again. It reaches about 160 on the temp guage and then starts to sputter and dies and won't restart until it cools. I can drive about 20 minutes at a time before it dies again.

×

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Ignition module,fuel pump relay,ignition coil-i had similar prob and it was relay $10

Posted on Oct 19, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

S10forum.com

Posted on Oct 13, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 426 Answers

Sounds like ignition module

Posted on Oct 13, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Replaced fuel pump and fuel filter on my 94 olds cutlas supreme. Will start and run for 30 min's then will die and not start again for hours


Did it have this problem before you changed the fuel pump an filter ? When it dies an won't restart for hours ,is there spark at the coils ? What engine does yours have V-6 . Check for spark the way this guy does in this video. GM Ignition System diagnosis 1988 Olds Cutlass Same ignition system >

Oct 30, 2015 | Cars & Trucks

1 Answer

My 94 s10 blazer won't run it starts runs for about 15mins dies won't start back with out spraying starter fluid or if I let it sat for few hours


Have you tried a new fuel filter? not an inline filter but the main one, then check the pump, is it hot to touch when the vehicle cuts out? it may be ready to fail completely if its hot and wont give enough fuel feed for the engine when the auto choke switches off. Try that first before going any further.

Jul 29, 2014 | Cars & Trucks

1 Answer

Why is my truck acting like its running out of gas once it is at constant speed?


Maybe your fuel injecter is plugging up with dirt, or one of the injecters are going bad

May 28, 2014 | 1999 Chevrolet S-10

1 Answer

89 chevy s10 misfires and sputters when i give it gas, dies when i stop. Sometimes it runs fine, but recently it's just been bad. When i rev the engine it can stabilize the idle, but usually die


check fuel pump pressure- fuel filter --air filter --egr valve if carboned up clean or replace and cat converter feel the exhaust if feels restricted may be clogging up

Mar 30, 2013 | Chevrolet Blazer Cars & Trucks

1 Answer

94 CAPRICE WITH LT1 WONT STAY RUNNING


check fuel regulator, fuel pressure, could be bad sending unit in fuel tank, change out fuel filter

Apr 30, 2012 | Chevrolet Caprice Cars & Trucks

1 Answer

94 s10 with 4.3 w, misfires during driving.


Check fuel pressure,fuel pump maybe on the way out.

Apr 19, 2010 | 1994 Chevrolet S-10

Not finding what you are looking for?
1994 Chevrolet S-10 Logo

311 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...