Question about 1991 Cadillac Seville

1 Answer

Will not start

1990 seville 4.5L will not start has fule presser and good spark. Im not sure if I got injector pulse when i check the 2 wire injector plug with a test light with the key on I got power on 1 wire, then when I spin the engine over i still have power on the same wire and nothing on the other. The test light dims as I spin the engine over but never goes off completely that is why i think it has no injector pluse. Please Help!

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 26 Answers

HAVE YOU CLEANED YOUR SPARK PLUGS?? a bad wire can do this too. try changing the wire

Posted on Oct 13, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

HAD 2001 OLDS ALERO COMPUTOR CHECK SAID # 2 CYLINDER WAS MISSFIRING CHANGED #2COIL PACK STILL DIES WHEN SLOWING DOWN OR STOPING BUT STARTS RIGHT BACK UP DIES WHEN STOPPING OR SLOWING DOWN ALSO DIES AFTER...


Sounds like #2 is still missing. Misfires can be caused by an ignition problem, a fuel problem, or a mechanical problem where there is no compression in the cylinder.
Okay, you have changed the coil. Now try changing spark plugs and the spark plug wire-Swap #2 and #1 spark plugs and the plug wire too, and see if misfire follows now on #1. If it does, bad plug or bad plug wire. Of course you could just drop a new plug into #2 and see what happens. If no change, swap the plug wires and test again. If still misfiring, check the spark at end of plug wire-you need to see a blue snapping spark to know the ignition is working good on that #2.
If you have spark there, need to check if the injector is pulsing and spraying fuel into the cylinder. You might be able to feel the injector pulse if you hold a finger lightly on the injector while engine is running-should be a steady, rather rapid click feel to the injector. If not sure, have the injector circuit checked. You can buy an inexpensive "noid light" at auto parts stores, one that fits your injector circuit, plug it into #2 injector, and crank the car over or run the engine and watch the light-if working, the noid light will be blinking. This verifies the circuit is good. If the spark plug is wet with gas when pulled out, that would verify that injector is spraying fuel into the cylinder.
If still no help, have the compression checked in #2. Low compression from a valve problem or head gasket problem can cause misfires.
Good luck.

Sep 20, 2013 | 2001 Oldsmobile Alero

1 Answer

I am having a misfire on cylinder 2 but not sure how, I replaced the head, the plug, the wires and the coil pack....what am I missing. No pun intended.


Run tests to see why missing: spark test on no. 2, need a good blue spark to rule out ignition problem. Gas test: make sure injector for #2 is pulsing-is gas getting into the cylinder? Pull the plug after cranking a few seconds and see if wet with gas, or check for a pulsing signal on the injector. A "noid" light can be purchased cheap, it plugs into injector connector and blinks if wiring is working right.
If still no help, you need a compression test to check compression on #2. Low compression may indicate a head gasket failure or valves not sealing properly.

Jun 28, 2013 | Cars & Trucks

1 Answer

My 1990 Toyota's #3 cilynder makes no difference with spark plug wire disconnected.


Yes you can test the injector pulse signal with a tool called a "NOID LIGHT". You can buy this handy little tool at any auto parts store like NAPA or Carquest for about $5, it plugs into the injector connector and flashes each time the injector is commanded to open by the processor. I personally think you have a defective wiring harness on the engine.

Jul 12, 2012 | 1990 Toyota Pickup

1 Answer

Ok i had a p0302 and then i changed plug wires coil packs the icm injectors camshaft sensor and now i can a p0301 code.. and when i clear the code it will come back with the same code or else a p0300.. im...


1. Freeze Powertrain Control Module (PCM) and see if the problem can be duplicated.

2. Wiggle tug test wiring for #2 injector.

3. Scope the #2 injector for a glitch when the misfire happens. 1. Test for the Exhaust Gas Recirculation (EGR)/coolant adapter gasket leaking EGR gases past the gasket.

2. Connect a vacuum pump to the MAP sensor, block the vacuum source, reset fuel trims, start the engine and add typical vacuum to the MAP sensor and check operation.

3. Test the spark output with 2 High Energy Ignition (HEI) testers, at 25 KV air gap each, at the spark plug wires to ground at wires 2 and 3, then 1 and 4 at cranking speed and engine running.

4. Test the fuel injector pulse width at the injectors compared to the scanner data.

5. Disconnect the O2 sensor, reset the fuel trims, test the system operation in open loop, test injector pulse width. Compare to the closed loop operation injector pulse width and engine operation.

6. Test the Powertrain Control Module (PCM) powers and grounds during the problem.

Oct 13, 2009 | 1996 Chevrolet Cavalier

2 Answers

Had no spark. Replaced ignition mod, 2 coil packs, and computer. I now have fire; problem is engine will not run, the fuel injector sprays fuel (too much i think). When i unplug the injector the engine...


Check for any wiring pinch which might have occurred when the injector was replaced. The injector is driven directly by the computer, so it seems to point at the new computer as being faulty. (pulse signal is always 'on')

Oct 08, 2009 | 1990 Chevrolet Cavalier

1 Answer

My 1994 chevy s 10 blazer starts only in morning or after sitting for a long time(1 or 2 days) has new fule pump fule fliter fule presser is great have strong spark new plugs and wire relay is good motor...


I would definately check around the intake gaskets with any spray lubricant or cleaner.Do this while the engine is running. If it starts to stumble then concentrate the spray until you pinpoint the area of fault. This is all I have to offer without being there. Good luck,Dana

Aug 23, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

Trun over


2-12' mil bolts losen and pull an injector, check for fule. Next check for spark. make sure you have this to start with.

Jan 13, 2009 | 1990 Nissan 240SX

1 Answer

1987 cressida missing


Start with testing the injectors for pulse. Get a NOID light they sell the at almost any auto parts store remove in get plug from injector and plug the noid light into plug look for constant steady (pulse)lighting of noid light. Check all six injector on your strait 6. If all is good remove parke plug wire on at a time from cap and look for increased shaking and less when it replaced(Make sure to use wire puller with rubber insulation to avoid being zapped by spark from coil) Note cylinder with no difference or change when wire is removed. Those would be the problem cylinders. Then get a compression guage and check all cylinders for compression by removing spark plugs and attaching guage to each cylinders, make a not of each cylinder's reading. NOTE THEY SHOULD NOT BE MORE THAN 10 PSI difference in cylinders. Make note of low compression cylinders if any. If compression is good all around spark plugs are good, good ignition wires and you have good pulse pattern from you noid light. The only other problem is BAD INJECTORS and those would be the ones that didn't change when you took off the wires. I have work on these old cressida alot my self. Good Luck contact me if you need more help and if I solve your problem leave me a FIX-YA comment.

Dec 17, 2008 | 1987 Toyota Cressida

2 Answers

1990 montero no start. No power to open injectors, good fuel pump


Check the injector pulses with an osciliscope. If you arent getting a pulse check the ecu. I have cooked 2 of them. One killed my ignition but had good fuel. the second time it wouldnt open the injectors but had good spark. A quick check is to take the ecu out and take the cover off. then look for burnt electrical components.

Nov 20, 2008 | 1990 Mitsubishi Montero

Not finding what you are looking for?
1991 Cadillac Seville Logo

154 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...