Question about 1994 Chevrolet S-10 Blazer

2 Answers

1994 chevy blazer 4.3l feels like miss at idle only new cpi,egr,ignition.no vac leaks comp good tsb 4 crank sensor w/ spacer shim?

See above

Posted by on

  • ase willy Oct 12, 2008

    fuel pressure good 60 psi new filter new cpi unit w/ new poppets maf tps all good thinking crank sensor or computer  feels like dead hole at idle but runs great off idle & cruise. wish i still had access 2 Identafix network. awsum site. proven headache fixes. pinpoint step by step instructions to test confirm & fix stuff that tsbs & snapon troubleshooter dont even cover!!!!!!


  • ase willy Oct 12, 2008

    thanks 4 response. ps gotta larger clearer pic?   just kidding!?


×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 3 Answers

1st, we found a bad 02 sensor that wasnt lighting the ses, still had zero Gs acceleration , with a miss on acceleration , and idle -14 MPG all the time- seen all the blogs about air pressure assistd pro cleaning the injectors, so started dumping the bottles of kerosene in the tank - voila- finally cleaned the stuck injector(s), now smooth as silk, 2-3 years ive been chasing this problem, will have to add a bottle to this truck often-very finicky injector setup -1994 4.3 S10

Posted on Mar 16, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 352 Answers

Just some quick checks: I'll assume you haven't received any error codes.
fuel filter,bad gas(water in the gas), indication of failing fuel pump(the 4.3 is notorious for its pump problems),dirty spark plugs, clogged fuel injectors, failed fuel injectors, MAF malfuntion(mass airflow sensor), I could go on...

anaanymous

Posted on Oct 11, 2008

  • anaanymous Oct 12, 2008

    I'm sorry ase willy,



    I just re-read your question and what I said makes absolutely no sense, It was late and I was half dead, still I need to be more careful I the future, again I am truly sorry.



    anaanymous

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 94 chevy s10 with a misfire that's about to drive me crazy. I've changed plugs, wires, ignition coils three times with different types and brands no change. So I continued with the ignition...


If the compression test was good, that takes care of most mechanical things.
If you know for a fact the plug is firing under pressure, that leaves a vac leak or a fuel injector problem.
You didn't say what size the engine is or if it is MFI, so I will assume it is.
Depending on when the miss happens, it could be a vac leak, including the EGR valve, or an injector that is not getting a ground signal from the engine computer.
Do you know which cylinder is not providing power ?
Does it happen all the time, or only when the engine is under a load ?

Oct 28, 2014 | 1994 Chevrolet S-10

1 Answer

85 Vic,5.0,CFI,..Was driving home from work (about 25mi) when I got about 4blks from home, she started missing and died. I restarted but it ran rough and died again.I parked it and walked home, had it...


From your description it could be fuel or ignition. Ignition is usually easier to start with and only checking the spark power and quality as the engine dies will indicate what is happening - if anything.

Mar 18, 2017 | 1985 Ford Crown Victoria

1 Answer

94 s10 blazer 4.3 cpi


Could be a vac leak, dirty throttle body, or faulty idle air control valve.
Is the check engine light on ?

Jul 04, 2012 | 1994 Chevrolet S-10 Blazer

1 Answer

1993 S10 Blazer with a Vortec Enginer V6 4.3L. Changed the Injector Assembly, Plinum Gasket, Plugs, O2 Sensor, Catalytic Converter. Still won't pass emissions test. What am I missing?


The problemis usually related to a EVAP problem. Such as a Vaccuum leak,bad EGR valve.The most common problem for these trucks is the EVAP canister in the rear of the truck or the vac lines going to or from it also the EGR valve gets clogged or stuck. If you get the truck scanned it should give a code then you will know where to look.

Apr 26, 2011 | 1994 Chevrolet S-10 Blazer

2 Answers

Trying to locate the ignition module for chevy blazer s10 1994


Ignition module sits in the ignition distributor, remove distributor cap, there will be two elec. harness plugs, the one with two wire's is for the pick up coil, the other one is for the ignition module, just unscrew module out of distributor and install new one.

Sep 23, 2010 | 1994 Chevrolet S-10 Blazer

2 Answers

4.3 cpi rough idle ,pops on acceleration to


did you check for vacoum leaks?

Sep 26, 2009 | 1994 GMC Jimmy

1 Answer

Crank no start


JUST REMEMBER THE BASICS,COMP./SPARK/FUEL,IF ONES MISSING ,NO CRANK

Aug 20, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

Engine idles rough, misses at 2500-3000 rpm's


i would first check the timing and if that does not fit i would take the cover back off and look at the belt for a bad or missing tooth

Feb 14, 2009 | 1996 Toyota Camry

1 Answer

Why is my 1994 Chevy S10 Blazer lugging? motor shakes and lugs.


Could be vacuum leak or bad ignition wire(s).

I had a similar problem on my "93 Ford probe. The engine idled pretty rough with shakes, Turned out to be a head gasket leaking engine coolant into the cylinder during low rpm's. At fast rpm's it was fine becuase the internal cylinder pressure was greater than the hot coolant pressure & would prevent the coolant from leaking in.

A friend has the same problem with his "94 Blazer 4.3 L, throttle body injection, manual tranny. He hasn't fixed it yet, It started a few weeks ago & is getting worse. His gets a fast idle with hiccups which causes the engine shake. He already checked the EGR valve. He also has a severe exhaust problem, Not oilly but very gray & terrible smelly, but only when the fast idle problem happens. THis fast idle hiccup problem starts when the engine is warmed up.

Nov 19, 2008 | 1994 Chevrolet S-10 Blazer

Not finding what you are looking for?
1994 Chevrolet S-10 Blazer Logo

683 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

71288 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22059 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7009 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...