Question about 1990 Ford F150

1 Answer

4.9 liter will idle but wont accelerate have to start with ether

We have a 1996 f150 with a 4.9 6 cyl. it takes ether to start it then will idle but when you accelerate at all it dies. weve tuned it up, mapp sensor ok, throttle position sensor ok, what can it be?

Posted by on

  • yadayada
    yadayada May 11, 2010

    Have you checked the fuel pressure or replaced the fuel filter?

×

1 Answer

Yes checked fuel pressure and replaced the fuel filter, checked the mapp sensor,tested throttle position sensor, has strong spark, 50psi fuel pressure, fresh tune up, runs real rich and rough idle but wont rev up like fuel injectors arent speeding up, also checked exhaust. thanks julius

Posted on Oct 10, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

I have a 99 geo metro.4 cyl no start condition.new fuel pump/filter.will start with ether and hold about 2000rpm if holding throttle..will not idle or start withought the ether...help please.


First off.... You have to make sure it IS getting fuel. Are you sure the fuel pump is getting 12volts... the fuel filter is installed in the right direction? Have you disconnected the supply line at the throttle bodt to verify fuel pressure and volume? If it starts with ether... there is definately a fuel supply issue from the tank

Apr 11, 2015 | Geo Metro Cars & Trucks

1 Answer

I have a 1999 jeep Cherokee 4 liter 6 cyl & it


Is the check engine light on, and did they check fuel pressure ?

Jul 13, 2013 | Cars & Trucks

1 Answer

My 95 explorer's service eng. light has been on and it would stall when accerating from a stop, when drove it felt like ether the idle/ thrattle, or shift position sensor was acting up, and today it...


SOUND LIKE THE TPS SENSOR FAULTY.SOUND LIKE TPS SENSOR OPEN.THE PCM USES THE THROTTLE POSITION SENSOR SIGNAL CONTROL FUEL DELIVERY ON ACCELERATION.

Jun 26, 2011 | 1996 Ford Explorer

1 Answer

Starts sometimes wont idle or accelerate


try checking your egr valve pressure sensor i have a 96 eddie bauer explorer and had the same problem and only showed me a code for a oxygen sensor malfuntion and replaced both and it cured it

Jun 23, 2010 | 1996 Ford Explorer

1 Answer

My 1996 ciera has the 6 cyl. 3.1L and has a


Check the egr valve,make sure it is not sticking,and do a major tune up,this will help in burning the rich mixture at cold idle.

May 16, 2010 | 1996 Oldsmobile Cutlass Ciera

2 Answers

How much motor oil dose the 1996 aurora tade and


1996 OLDSMOBILE AURORA 4.0L 8-cyl Engine Code [C] DOHC
Engine Oil Grade 1......API* SAE 10W-30 is preferred......5W-30 optional CAPACITIES: Engine, with filter..........7.1 liters After refill check oil level.

Feb 17, 2010 | 1996 Oldsmobile Aurora

4 Answers

What oil should I use in my Saab 96 900?


factory recommends you use 10w-30 motor oil ,hope this is helpful.

Nov 27, 2009 | 1996 Saab 900

2 Answers

Power loss after running


loss of power can happen even if exhaust does not flow in other words you have a rstriction in the exhaust usualy the catalytic converter has collapsed any exhaust shop will be able to tell you right away, or when you loose power do you hear a hissing noise ? if so that is clearly a clogged converter replace the catalytic converter

Nov 12, 2008 | 1996 Jeep Grand Cherokee

Not finding what you are looking for?
1990 Ford F150 Logo

656 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...