Question about 2006 Toyota ECHO

2 Answers

Engine not starting

I have vitz 2006 with engine start-stop push button. For few days the engine was taking a longer than normal time for starting; some 5-6 seconds long self. Today when I pressed the brake, the green light came ON in the start-stop button but there was no self on pressing the button. Instead the brake pedal got harder and then even the green light did not come ON in subsequent attempts. When I pressed the brake lever harder the green lt did come ON but on pressing it there was no self. The only thing I could figure out abnormal was the Blue cool light on the instrument panel continuously flashing. Pl help.

Posted by on

  • Naveed Riaz Oct 09, 2008

    The blue light is the one indicating temperature. Its normally ON early morning before the first start. I ve never noticed it flashing before.

  • Naveed Riaz Oct 09, 2008

    I got a new battery 1 month back and had the starter checked. The guy said batt needs to be changed and that the starter was ok. There must be some programmed logic which is preventing it to engage the IGN.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Hi Buddy.
If you still face such problem, try to disconnect the battery terminal. Keep it dissconnected for a while. Then try it. Also make sure, that the doors are closed properly. It wont start if the door is open,
Regards
http://www.thekonsultant.com.
http://www.manwithvans.com

Posted on Jan 23, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 39 Answers

Have you gotten all of the routine services? What is this blue light shaped like?

Posted on Oct 09, 2008

  • Mark Lee
    Mark Lee Oct 09, 2008

    You may want to have your battery checked. Its that or a faulty starter button.

  • Mark Lee
    Mark Lee Oct 09, 2008

    Yeah it sounds like there is an ECU error going on. Is there any other lights that lit up on your cluster when you go to start the car?

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I bought my 06 Dodge Charger, used, in 2011. First year no problems, then sometime in 2013, I would get in, turn the key, "reh-reh-reh-reh-reh"... stop, turn key off, wait a few seconds, turn key and...


Its not the plugs. And probably not a sensor.
It could be the fuel pump relay or the pump in the tank.
A sensor going bad would make the check engine light come on with a trouble code. A faulty pump relay or pump would make it take longer to get the fuel pressure up to normal. You could probably make it start by just cranking it longer too.
I would check to see if the pump comes on when it fails to crank.

Sep 02, 2013 | 2006 Dodge Charger

6 Answers

Engine start-stop push button not working


Please check the spark plug. There might be too much carbon present on it so you need to clean it. If cleaning wont fix it, try replacing it. If you can't do it, just bring it to the nearest auto mechanic.

Oct 09, 2008 | 2006 Toyota ECHO

1 Answer

2007 Gran Vitara engine noise when start


old post.zero help, so here i am, filling the hole for next person.

the V6 has no cam belt. it's a chain drive.
how many miles on v6 motor.?
the chain runs 2 times longer than a belt. easy. or more.
the hydraulic adjusters may not, when not doing oil changes on time.
the start up noise is normal (not mine) but the factory TSB covers this, on higher mileage v6,
the engine starts and the chain , or lifters can make noise
until oil pressure reaches normal. (0w oil can be and issue here)
i run 10w40 all year, and mine runs like new, all the time. 100k miles on my block.
if the noise stops , after few seconds the TSB is clear on that.
its normal.
if it makes noise full time, really any engine. its time to stop
not run it and fix it or the damage can cascade it to total engine destruction.
have an ASE mech, diagnose the noise and true source
we have tools to do that , and you dont.
we find the true source and evaluate that.
next time post how long the noise happens, hot and cold
and hot only start ups.?
most shop manuals have a chapter on noise.

here is typical translation of that.
http://www.fixkick.com/NOISE.html

Jan 31, 2013 | Suzuki Cars & Trucks

1 Answer

How to turn of change engine oil light on 2011 ford focus


From FocusFanatics online - -

Resetting the oil life monitoring system
1. Turn the ignition key to the on position. Do not start the engine.
For vehicles with push-button start, press and hold the START/STOP
button for two seconds without pressing the brake pedal. Do not attempt
to start the engine.
2. Press both the accelerator and brake pedals at the same time.
3. Keep both pedals fully pressed.
4. After three seconds, the Service: Oil reset in prog. message will be
displayed.
5. After 25 seconds, the Service: Oil reset complete message will be
displayed.
6. Release both the accelerator and brake pedals.
7. The Service: Oil reset complete message will no longer be
displayed.
8. Rotate the key to the off position.
For vehicles with push-button start, press the START/STOP button to
turn the vehicle off completely.

Jul 07, 2012 | Ford Cars & Trucks

1 Answer

2006 vitz eco not working 1000cc


i have 2004 model with eco package bt its not working proprly. as the brake padle is presed engine turnz of bt when released it didnt start automatically.anyone plz

Mar 07, 2012 | Cars & Trucks

1 Answer

My Toyota Fortuner year 2006,i guess, D4D 3000cc diesel .. I was in a rushed so i drove very fast and suddenly the engine couldn't accelerate but not shutdown stayed at idle and the engine trouble light...


It sounds like it overheated. I am guessing a standard transmission or an automatic that was run in a lower gear?

Diesels cannot rev as high as gasoline engines by their very nature. They act like big compressors and the fuel is ignited by the pressure alone creating enough heat (no spark plugs, and their "glow plugs" are only used for cold starts...when the "wait to start" light is on). When they are over-revved, (two "v"s there, not a "w"), fuel ignites before a valve is fully closed and they will overheat very quickly, and it is possible to have this happen before your coolant gets hot enough to warn you that the engine has overheated.

It sounds like you may not have damaged anything, so you were fortunate to slow down in time before your engine went very much further into a state that is called "preignition" which can cause severe engine damage.

Try taking it a little easier and you should be OK.

Feb 15, 2011 | Toyota Pickup Cars & Trucks

1 Answer

Intelligent idle engine stoping system vitz 2006


Hello
Yes, vitz 2006 got idle engine stopping system.
I got the same model and was told by my mechanic that these car have that system installed.
Also you can notice yourself that when you are reducing the speed while turning or stopping, you can feel the engine going to die. i mean idling it self.
I h ope you get my point as its hard for me to explain
Regards
http://www.thekonsultant.com
http://www.manwithvans.com
:)

Jan 23, 2009 | 2006 Toyota ECHO

1 Answer

After swapping Automatic vitz to manual , check engine light is always on


You might also have to swap the ECM (engine control computer) because most new cars also read readings from the transmission and because you changed it to a manual, it no longer gets readings it needs from the auto transmission. The only way to know is to hook the car up to an ODB II code reader or take the car to the repair shop and let them pull the codes from the computer and tell you if they relate to the automatic transmission. There is no way you can shut off the transmission side of your computer and use the same old computer that you used when you had an automatic transmission.

Nov 10, 2008 | 2006 Toyota ECHO

3 Answers

Temperature light of vitz toyota


Check your coolant level first then start having sensors checked. Could be a bad sensor or wiring issue.

Jun 21, 2008 | 2005 Toyota ECHO

Not finding what you are looking for?
2006 Toyota ECHO Logo

198 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6879 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...