Question about 2000 Mercedes-Benz S-Class

2 Answers

Instrument lights are out

My instrument cluster lights went out. Mechanic put in new fuses--it went out again. whats wrong here?

Posted by on

  • billuk Nov 09, 2008

    I have the same problem with my 2002 S320 CDI and its coming up with B1193 code on the computer. Can anyone help with this code. Billuk

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Check for a recall or extended warranty for this problem. I have a 2002 S430 and the instrument cluster went out and it is covered from a mercedes benz dealership only.

Posted on Oct 27, 2008

  • shwn27 Sep 21, 2010

    Any idea if it will cover a 2001 S430 thats what i have and it recently went out. i have no idea how fast im going my fuel the temp, time if everything is just black and on my steeting wheel i cannot use any of the handy features like volume or seek

×

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 231 Answers

Could be a short in the wiring or you could need a new head lite switch.

Posted on Oct 09, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

92 roadmaster instrument lights


Oh boy, I just went through this with my '92 Lesabre, took a long time to trace it all down, and wound up splicing in a new wire just to my instrument cluster lights. A short kept blowing fuses somewhere in that circuit.
Down where your feet go, up under the dash at the fuse panel, there is a 15 amp fuse for park/tail lights. When you hit the light switch (for heads or park lights), power is sent to that fuse, and then to the exterior park lights. There is another wire from that fuse (green wire on mine) that also goes up under the dash, and splices to several bulbs-on the radio, on the HVAC controller, on the ashtray light, also one to the under hood lamp, and then one to the dimmer/brighter switch on the dash, the rheostat that controls brightness of interior lights. One of the green splices goes into this switch, and then another wire goes from this switch to the instrument cluster for the gauge and dash illumination. I couldn't find the short, so ran a new wire from the park light fuse to the gray wire to the instrument cluster for the cluster bulbs. I bypassed the dimmer, and left off the HVAC bulbs and ashtray light. Too much trouble to wire them all up, and think my short may have been in the dimmer rheostat.
If you have a voltmeter, pull out the dimmer switch and check for power on those wires, the green from the fuse. The park light must be switched on, or the fuse has no power. There be 8 or 9 wires on that dimmer rheostat-I never did figure out where all of them went. Asked all over a Buick forum, but nobody had an answer.

Dec 02, 2016 | 1992 Buick Roadmaster

1 Answer

Instrument cluster lights blowing fuses in 2002 ford explorer


need to replace the dimmer switch its probably shorted

Feb 27, 2013 | 2002 Ford Explorer

1 Answer

Bmw e36 318is 1997 instrument cluster help needed.Went dead while driving....now petrol and temp/guage not working.....What can i check? replacing the tem swicth and termostat


CHECK 5 AMP FUSE TO THE POWER DISTRIBUTION CIRCUIT WHICH SENDS POWER TO THE INSTRUMENT CLUSTER.IF FUSE OKAY.EITHER CLUSTER HAS A LOOSE WIRE OR CLUSTER SHORTED OUT.IF CLUSTER IS FAULTY. THE BMW HAS TO REPLACE THE CLUSTER BECAUSE NEW CLUSTER HAS TO BE CODED TO MATCH THE VECHICLE.

Aug 26, 2011 | 1996 BMW 318

1 Answer

My Caravan is good yet,dash board light is not working trying to aviod a mechanic..Can I fix it myself"


CHECK THE INSTRUMENT CLUSTER LIGHTS FUSE.SHOULD BE 10 AMP FUSE.IF FUSE GOOD CLUSTER COULD BE FAULTY.YOU NEED A HAYNES REPAIR MANUAL.IT WILL SHOW YOU HOW TO REMOVE INSTRUMENT CLUSTER.

Mar 27, 2011 | 1998 Dodge Caravan

1 Answer

Instrument cluster lights don't work. Fuses and bulbs are good.


feed wire for the lights may have failed or the circuit on the board may have gone. if you remove the cluster you can put a supply to the bulb circuit (carefully) and check if it is the circuit. If it's ok you can run a new feed to the cluster from your lights. Job done.

Feb 16, 2010 | 1995 Jeep Cherokee

1 Answer

Instrument cluster went dead except lights. was told it was an Instrument cluster problem. Put in new cluster it is also non responsive except for lights


Replaced once before and still periodically happens. Disconnect battery and reconnect and it starts working on our voyager.

Feb 07, 2010 | 1997 Plymouth Grand Voyager

4 Answers

Instrument panel went dead


Checked Every fuse in the fuse box (no small task).This includes #4 - Power point Instrument Panel, #14 - Day time running lamps (auto lamps doesn't work nor does auto lock), #27 - ignition switch run feed, #35 - Instrument Cluster, #41 - Instrument Cluster, #42 - Delayed Accessory, #45 - Ignition switch run/start feed, #102 - Door locks body security module, #103 - Ignition switch, #110 - Ignition switch, & #116 - Ignition switch. But I also check all other ones as well, they all register OK. AC panel & radio work. Turn signals work. Mileage does not work, trip computer does. So, basically, everything works except auto head-lights, auto locks, and the dash cluster (no MPH, RPM, mileage display, Fuel, Temp, Tran Temp, and Oil Pressure).

Aug 19, 2009 | 2003 Ford Excursion

1 Answer

1999 Oldsmobile Alero Gauge problem


Could be lose connection on the back of the instrument cluster ,which means you would need to pull it out of the vehicle . Check pin fit to instrument cluster . for the B+ voltage suppy an ground connection's .
You said autozone - Tried to have auto zone diagnose from inside the car, came up with no codes. That's in the PCM - engine computer . There scan tool will not communicate with the instrument cluster ,which is also a computer in it's self. Need a factory scan tool to check instrument cluster.
Speedometer and/or Odometer Inaccurate
Step
Action
Value(s)
Yes
No
Important: A short to ground will cause an open fuse(s). Before performing this diagnostic procedure, inspect the fuse(s) for an open.
1
Did you perform the Instrument Cluster System Check?
--
Go to Step 2
Go to Instrument Cluster System Check
2
Turn the ignition switch to the ON position.
With the scan tool select Instrument Panel Cluster, Special Functions, Instrument Panel Cluster (IPC) gauges.
Perform the Speed Gauge Sweep Test.
Does the speedometer complete a full sweep when commanded?
--
Go to Powertrain On Board Diagnostic (OBD) System Check in Engine Controls
Go to Step 3
3
Replace the instrument cluster. Refer to Instrument Cluster Replacement .
Did you complete the repair?
--
Go to Instrument Cluster System Check
--
With a scan tool select the instrument panel cluster, data display, gear status.
Monitor the gear range status.
Move the gear lever through each gear.
Does the scan tool display the correct gear selected?
Your best bet , take it to a qualified repair shop .

Feb 27, 2017 | 2001 Oldsmobile Alero

1 Answer

Instrument cluster lights and tail lights went out


if its not the fuse then you have a bad headlight switch

Mar 13, 2009 | 2002 Mercury Mountaineer

1 Answer

INSTRUMENT CLUSTER DASH LIGHTNING


dash cluster assembly needs replacement/try used one or go to dealer and spend 90.00 for diagnoisis if you have to buy new no return on electrical parts

Nov 06, 2008 | 2001 Chrysler PT Cruiser

Not finding what you are looking for?
2000 Mercedes-Benz S-Class Logo

429 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...