Question about 1996 Chevrolet K1500

1 Answer

My '96 k-1500 idles too high

I've got a '96 Z-71 w/ a 5.0 & auto trans. When you first start it up it idles fine, but after you drive it it idles @ 1100rpm in drive and jumps to 2100rpm when you put it in park. The MIL apparently has been disconnected by the last owner because I put my scanner on it and pulled 4 DTCs. P0172,P0175, and I don't remember the other numbers but they were random misfires and catalist system efficency below threshold or something like that. I've changed the plugs and fuel filter & cleaned the I.A.C, but nothing helped. I also checked for vacuum leaks & didn't find any.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

You need to reconnect the mil with it unplug the oxygen sensor can not operate when your rich the sensor has to set at around 600 millivolts if your lean it drops to 300 mill a good dwell meter can check it hot and cold

Posted on Jan 11, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an 86 2.8 2wd s10 blazer automatic trans.


check your timing.. and start pinching off hoses till you notice the difference then replace that hose..

Oct 17, 2014 | Cars & Trucks

1 Answer

Seems to idle high


Throttle position sensor mounts on the side of the throttle body. It could be sticking but not yet faulted to the point to throw a code. try removeing and spraying with brake parts cleaner while working the inside mechanism back and forth

Jan 24, 2014 | 2004 Hyundai Santa Fe

1 Answer

1988 chevy suburban 1/2 ton auto trans; 4 wd; dies after putting into drive


Could be a dirty throttle body or faulty idle air control valve.
Is the check engine light on ?

Jul 09, 2012 | Chevrolet Suburban Cars & Trucks

1 Answer

High idle 99 k 1500 z-71 4.8l manual transmission


This truck uses an idle air control valve to change the idle speed.
The valve could be dirty or failing.

Jul 03, 2012 | 1999 Chevrolet Silverado 1500

1 Answer

My 2000 gmc sierra z-71 has started idleling at about 1300 rpm after driving for a while. when i turn it off and restarted it would idle fine for a while then start idleing high again. it is getting to...


I assume the check engine/ service soon light is on. Commonly the MAP sensor is the culprit, but can be TPS, CSS, even a buggy O2 sensor. Only way to be sure? (light or not) is to scan it.

Jul 02, 2017 | 2000 GMC Sierra

1 Answer

Overheating, idling funny


try getting a higher number in thermostat like a 180. replace the cap it may be malfunctioning anf finally the overspray will cause things to go wierd spray down with water and things should improve.

May 18, 2009 | 1994 Honda Accord

2 Answers

Have 1987 nissan sentra wagon 1.6 carb.engine the problem is an idle problem when I start in the morning or when its had time to cool down I depress the accelorator pedel to set the choke and high idle cam...


Check your Ignition timing before anything
check your plugs see what color they are
red or orange means carb is to lean , black
or oil means to rich then you can go from there
and set mixture screws on carb , let me no how you make out .

Mar 09, 2009 | 1987 Nissan Sentra Wagon

3 Answers

Won't start after several trips in one day


Give me the year make and model, engine size and standard or auto trans? Sound like you have a fuel issue to me. Perhaps a faulty fuel injector(S). Let me know the specs...cheers!

Jun 14, 2008 | 1996 Pontiac Sunfire

Not finding what you are looking for?
1996 Chevrolet K1500 Logo

Related Topics:

201 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...