Question about 1997 Ford Windstar

2 Answers

Transmission problems hello, i hope you can help me even ford are baffled! im living in geramnny so maybe they dont have the right expertise, but ill explain it to you as best i can. My 97 windstar has the engine fault light on constantly, in the morning when i move off it takes an age or a lot of revving to change up, when it eventually does the O/D button flashes, after a few minutes of driving eveything is fine? i stop the engine restart and she drives fine, but warning light stays on. just recently when turning corners slowly the engine cuts out now and again, any ideas?? Thanks steve

Posted by on

  • dungster Sep 30, 2008

    ihave been trying to find a trans control module on a few parts but am unable to do so, can you tell me where i will find this part?

  • dungster Sep 30, 2008

    i have tried the site for a TCM but to no avail, any other ideas, thanks again!

    I am changing alternator and overdrive solenoid on thursday, ill keep you posted!

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 360 Answers

This van has a problem with the alternator. spikes in the voltage regulator will cause the trans computer to go into failsafe mode. have the alternator scoped or replaced.

Posted on Sep 30, 2008

  • Jimmy
    Jimmy Sep 30, 2008

    this woud explain the engine cutting out. good luck

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,263 Answers

Your overdrive solenoid inside the transmission is the fault. it could be sticking or flat out not working. just have them replace that solenoid, if that won't do the trick then it's a faulty transmission control module....please rate this

Posted on Sep 29, 2008

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No response on the throttle but idles ok!


you posted to USA forum with a car we dont have,
so ill attempt to answer based on rules of Mr, Otto Cycle engines.
gas.(petrol)
even fails in park or neutral ,no way to race engine fast at all?
be key evidence that.... yah?
car dont move, right? in any gear, is transmission a stick or auto.
we cant guess transmission either.
so ill pretend engine power is nill.
top causes. in no order.
  1. bad fuel
  2. low fuel pressure
  3. no tune this decade, spark and filters.
  4. CEL lamp in cluster glows running and you ignoring it.
  5. scan the PCM
  6. check fuses.
  7. get car serviced.
  8. bad engine.
  9. is idle speed normal hot? engine?

Mar 28, 2016 | 2010 Suzuki Alto 1.0

1 Answer

HELLO I HAVE A FORD RANGER V6 1988. THE IDLE SOUNDS LIKE IT REVING UP AND DOWN. I THOUGHT MAYBE THE FILTER. BUT WHEN I DRIVE I HAVE TO MANUALLY SHIFT IT (ITS AN AUTOMATIC) BUT IT WONT GO ABOVE 45MI AN I...


Make sure the fulid is at the safe level in the tranny when it is warm, I have the fluid dosent smell burnt, if both things are fine then your transmission might be sliping indeed.

Mar 02, 2011 | 1988 Ford Ranger

2 Answers

Well, my transmission likes to slip majorly between 1st and 2nd gear. and if im just starting the car (like first thing in the morning), ill give it about a minute to warm up and then ill leave. well when...


After the engine reaches operating temp, on a flat level surface, check the fluid level in the transmission (running in park) If it's low, top it off. If it's full, chances are there is an internal seal that is allowing pressure loss, preventing the transmission clutches to fully engage. You could try changing the fluid and filter, adding lucas trans conditioner. That may help a bit but most times the only permanent cure is to rebuild/replace the unit. Don't expect "instant results" from the conditioner. often it takes a few days to work...it took a long time for the seal to wear.

Jan 06, 2011 | 1997 Jeep Grand Cherokee

1 Answer

I was driving down freeway when my 98 ford zx2 backfired and died, it felt like i was out of gas but i wasnt. It turns over but i dont think im getting any fire. There was a strong emission smell present....


Clean all the corrosion from the battery, take some spare wire and any crimp on ends you can get, splice all the bad wiring back together. Cut the wires till you get to good clean copper. 

Apr 04, 2010 | 2002 Ford ZX2

1 Answer

My 1998 ford taurus


take it to someone who knows what they are doing... especially if you have kids in the car, your local FORD dealer has all the tools and expertise to fix your problem, allthough it may be costly it is the safest bet.hope this helps and good luck

Jul 14, 2009 | 1998 Ford Taurus

1 Answer

Transmission


this type of problem is difficult to diagnose over the web or even a phone call. Your best bet is to go ahead and take it to a transmission shop as they have test equipment that can better pinpoint the problem more directly then someone saying oh its this fix or that fix. This issue can be caused by any of the 8 sensors( at minimum) in the transmission to the transmission control module, or the main car computer.

Jul 11, 2009 | 1991 Ford F150

1 Answer

Automatic transmission doesn't shift into gear right away, there is a long lag before it engages


Hello There

Sounds like your transmission oil needs to be changed, when was it last changed?


Hope this helps, please don't forget to rate me.

May 20, 2009 | 1983 Ford F 250

1 Answer

I went out a few days ago and my Ford escort would not even turn over. I tried jumping it and had no luck. I tried switching over to a new battery and still no luck starting. When I turn the ignition key...


high im haveing simalar problems with mine except i turn the key and get nothing no lights no radio nothing batter is new and altenartor is good so seys pepboys.im going to check all the wireing to make sure i have a good ground to the block or frame and im also going to see if there is any exsposed wireing that could be grounding out the car ??? im probaly going to replace the alternator despite what pepboy says ill let you know what happens if i solve it or not hopefully that it will help you also check your fuses to

Mar 21, 2009 | 2001 Ford Escort ZX2

1 Answer

96 ford taurus


if you take it to the dealership they have diagrams that they will pull up and make sure you are getting the right part they should even take a look under the hood for free, just talk to the parts guy, this will be the simplest way for you instead of us making a mistake by miscommunication over the internet without seeing it, unless you have a picture i would go to the dealership sorry im not that much of a help im just giving you the most reliable simplest way to get it fixed properly.

Dec 10, 2008 | 1996 Ford Taurus

1 Answer

Ranger 2003 ranger 3.0 stalls when accelerating


I guess I have to ask is the CHECK ENGINE LIGHT ON? I have seen a crack in the air intake hose that only opens up on hard acceleration because of the engine torque Im sure you looked at that, just mentioning it.
Has a TPS been check don't just replace parts test then replace sure its slower but sure is less expensive and you learn something too.
If the engine light is on, get the code then contaact me and Ill tell you how to TROUBLESHOOT AND DIAGNOSE NOT JSUT CHANGE PARTS

Aug 16, 2008 | 2003 Ford Ranger Regular Cab

Not finding what you are looking for?
1997 Ford Windstar Logo

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...