Question about 2005 Nissan Armada

Open Question

My nissan armada jerks while driving and even when idle it misses

My car started jerking and later stalled on the highway. have changed spark plugs, manifold gaskets, checked injectors.

Posted by on


6 Suggested Answers

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: 1992 SE maxima jerking, sputtering, stalling

I had a similar problem and resolved it by replacing the mass airflow sensor. Ive got 235k+ miles on my 1992 Maxima SE.
Still runs good but having problems with the alarm system.

Posted on Feb 24, 2009

  • 3433 Answers

SOURCE: 2004 chevy aveo jerking and cutting out

Have your MAF sensor ck'd or replace. It controls your fuel/ good luck

Posted on Jun 14, 2009

  • 750 Answers

SOURCE: 1999 nissan pathfinders jerks and stalls

try replacing fuel filter

Posted on Jun 24, 2009

  • 1 Answer

SOURCE: 2002 Nissan Altima 3.5 "Choking & Jerking"

I just had the same problem with my '02 altima SE.
Took it to Buckeye Nissan in Hilliard OH. and they had to replace the two crank sensors which.
The sensors themselves were about $44.00 a piece, but w/labor about $300.00 was the total. Hope this helps.....Now if I can just get the heater working!

Posted on Oct 09, 2009

  • 57 Answers

SOURCE: Transmission fixed but car still jerks from first ito second gear

Interesting that the fuel injector is under the manifold! must be an american car! lol..... if there is a problem with the manifold this would indicate exhaust problem! (state the obvious) did you machanic touch/ remove the Lambda sensor???? try also testing the AMP at the EGR valve if it has one! absolute manifold pressure should stabilise when revving the engine! if this drops then perhaps there is a problem with the mainfold gasket! would be good to get a Gas reading as to narrow the fault to the EGR or Lambda.

Hope this hepls.

Posted on Oct 28, 2009

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

2 Answers

P0300 code

sounds like you have checked a lot of things if it was mine I would do new intake gaskets, I had a 2002 Sonoma I did a lot of what you did and every time I gave it back to owner a few days later lite was on and p0300 I did intake gaskets and its been good 2 yrs now,not sure what gaskets you got but gm use plastic ones I got new gm ones and they were aluminum type call gm dealer parts good luck

Mar 05, 2015 | 2005 GMC Sierra 2500HD 4WD

1 Answer

If you have a manifold gasket leak on a '07 trailblazer ss would it make the vehicle lose power when driving down the highway

A manifold gasket leak will cause a power loss everywhere you drive, although a hot engine may lose more power than a cold one. You can check you spark plug color. A manifold leak makes a lean mixture so the plug should show the typical white-ish deposits.

Apr 23, 2014 | 2007 Chevrolet TrailBlazer SS

2 Answers

Head gasket or intake manifold gaste again 96 k1500 5.7 vortec. starts runs idles and drives rough it likes to **** while trying to drive almost as if it wants to stall out. i put my scanner on it and

The website has software that looks for obscene words.
I would think a compression test would show if the cylinder is having mechanical problems. And yes the intake or head gasket could be leaking again, especially if the intake or head were warped or cracked.
Have you checked fuel pressure ?
Does the spark plug for cylinder 5 show signs of coolant leaking into the cylinder ?

Feb 09, 2013 | 1996 Chevrolet K1500

1 Answer

2001 ford taurus,lopes when first started,when cold.

intake manifoold leak check all vacuum lines replace all vacuum lines if look cracked ,spark plugs could be fouled out by leaking fuel injectors, clean fuel injectors,replace fuel filter,replace air filter,replace spark plugs and wires,do tune up see if it helps if not.could have leaking intake manifold gasket or leaking egr valve,use engine vacuum gauge check engine vacuum for intake manifold gasket leaks.

Sep 23, 2012 | Ford Cars & Trucks

2 Answers

Heavy idle, random misfire code 04 trailblazer

I would start with the inlet manifold gasket, these are know to break down causing vacuum leaks which can cause this issue, also check around engine for other vacuum leaks

Mar 08, 2012 | Chevrolet Cars & Trucks

1 Answer

I changed the injectors, spark plugs, plug wires, intake gasket, and my santa fe 2001 idles good but dies on accelleration

How many km are on this car I would go to muffler shop and do back pressure test it only costs 10$ to me it sounds like a bad cat to me

Jan 08, 2012 | 2001 Hyundai Santa Fe

1 Answer

Sometimes car will not start when I get in but may start later on or even 5 minutes later. Car also hesitates when accelerating on highway. I have had a head gasket and heater coil replacement done...

Try adding 91% rubbing alcohol to clean the tank of fuel this eliminates water and gunk in the tank or use injector cleaner 6oz to full tank...... this doesn't always work on 1st try depending on condition of tank /injectors/ filter/ map sensors ( pay close attention)

check to see if fuel is getting to the fuel injectors at the prescribe psi if not check the fuel filter for blockgage you should blow thru with a steady flow of air ......if not replace

check your spark plugs for signs of oil, wear/ proper gap/ wire resistance

When is the last time...... you had a through tuneup......... this will give you better performance overall

Jun 10, 2011 | 2002 Chrysler Concorde

2 Answers

Rough idle and stalls

sounds like a bad idle air control valve, but if its misfiring thats another ball game,then you may have a bad spark plug or plug wire.when was the last time this car was tuned? if its been a while then you may what to start with a complete tune up, also have the fuel preasure check as this would also cause this problem but if it rides fine and only runs rough at idle then its not the we are back at a tune up.

Feb 24, 2010 | 1993 Ford Crown Victoria

1 Answer

1989 Cavalier Z24 Stalling problem

Have you heard of Noid lights? You unplug the fuel injector and plug these in and they will light up if the injector is getting power. This might give you a better hint. There are also lights that go inbetween the spark plug and wire. Between these two items you may be able to narrow down the problem to a specific system. I believe that your car has a coil pack. Some of these engines have problems with the crank trigger. I believe it is located on the back side of the motor. If you decide to change it, be careful. I have heard of them breaking into two pieces and becoming a big problem.

Jul 11, 2009 | 1989 Chevrolet Cavalier

1 Answer

Wont start

1st check for codes, could be crank sensor, or faulty injectors, or electroic issue

Jul 06, 2009 | 2001 GMC Jimmy

Not finding what you are looking for?
2005 Nissan Armada Logo

Related Topics:

140 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts


Level 3 Expert

77947 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides