Question about 2001 Chevrolet Metro

3 Answers

2001 metro P0340 intermittent sevice light, hard hot starts

Engine starts and runs fine cold. If engine is warm and outside temeratures above 80 then after driving 20 minute or more and stopping engine, restarts are sometime difficult and service light will come on. code is P0340. camshift position sensor circuit. The problem goes away after engine cools down. The light goes out after a time. The problem is intermittent.

Computer seems to lose track temporarily where camshaft position is. Is this really a CMP sensor failure or is the computer getting reset? or what?
Dan Anderson (andersons18@comcast.net)

Posted by on

  • 1 more comment 
  • andersons18 Nov 14, 2008

    Yes I know the CMP is losing sync. Does this mean that the problem is in the CMP and I should replace it?..or does it mean the CMP is faulting because of othe problems, For Example: a faulty or intermittent ground?

  • andersons18 Nov 14, 2008

    posted by andersons18 on Nov 12, 2008Report abuse
    Engine starts and runs fine cold. If engine is warm and outside temeratures above 80 then after driving 20 minute or more and stopping engine, restarts are sometime difficult and service light will come on. code is P0340. camshift position sensor circuit. The problem goes away after engine cools down. The light goes out after a time. The problem is intermittent.
    The Computer seems to lose track temporarily where camshaft position is. Is this really a CMP sensor failure or is the computer getting reset? or what?
    Dan Anderson


    1st solution offered:
    that is a typical camshaft sensor problem they lose theyr'e signal that makes it hard to start


    (andersons18@comcast.net)Comment by andersons18, posted on Nov 14, 2008
    Yes I know the CMP is losing sync. Does this mean that the problem is in the CMP and I should replace it?..or does it mean the CMP is faulting because of othe problems, For Example: a faulty or intermittent ground?

    Dan

  • andersons18 Nov 15, 2008

    Well It appears that the consensus of "two" is that I should replace the CMP sensor. I'm not convinced but it is a first step even though it will cost me ~$100. The only remaining question I have is will a 1999-2000 sensor work on a 2001? There are some indications by sellers that it will but I would like a little more definite information about that. Dan

×

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 899 Answers

When the computer gives a code it is because that sensor or other device is not working properly and the voltage change is detected and then sends the code untill the battery cable is removed , after the replacement of bad part so you will definately need to replace the sensor i had the same thing happen and the codes have been always correct , but you should do it soon before other codes start comming up from the engine not running properly

electech

Posted on Nov 14, 2008

  • jason Nov 14, 2008

    to explain how the sensor is failing : after power has been applied for a little while the sensor starts to no longer work correctly and then eventually not work, untill power has been taken off the sensor for a while to let it get back to its normal state , heat can also cause them to fail when they get hot



    the reason I know you do not have an intermittent ground is because it runs fine untill running for a little while , otherwise it would start to do it right away



    electech

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,450 Answers

WITHOUT looking at the sensor on a scope it would be hard to tell. it is most likely just a bad sensor. other possible cause,if i am thinking correctly the cam sensor is in the distritur on the side? if oil gets in there it can cause it to lose its signal.

Posted on Nov 14, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 160 Answers

That is a typical camshaft sensor problem they lose theyr'e signal that makes it hard to start

Posted on Nov 12, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine miss when cold, engine light on, new gas, air filter. fuel pump in tank. hot engine loght goes on off, when off at stop stalls out engine light off.


Diagnose Engine Misfire - Auto Diagnosis Repair Help

www.aa1car.com/library/misfire.htm
The engine may shake so badly at idle that it causes vibrations that can be felt in ...The engine may only misfire and run rough when cold but then smooth out as ...

What is causing an intermittent misfire only when engine is ...

community.cartalk.com/.../what-is-causing-an-intermittent-misfire-only-...
Jun 27, 2013 - NOTE: You MUST restart the engine for the misfire to go away. ... in an expert to do that test, but it might be worth it to prove/disprove the injectors being thecause. 0 ... The first is that the car should run fine even on cold starts.

Engine misfires when cold but runs fine after warming up few ...

https://answers.yahoo.com/question/index?qid...
Mar 24, 2009 - They also gave it to me because of this misfire problem it has. ...Engine misfires when cold but runs fine after warming up few minutes later? ... and you start next morning will also cause a misfire until it burns off the coolant.

"Miss/splutter" with cold engine, but fine when warm? M103 / also ...

www.peachparts.com > ... > Tech Help
Jul 13, 2011 - My moms old 300SEL (with the M103) that was once my car is now my "work car" again as she is getting a brand new SUV very soon.

Cold start misfire solved (finally!) - Bimmerforums


Dec 16, 2015 | Cars & Trucks

1 Answer

1996 goe metro hard to start fuel problem


ever tune it up, every 60,000 miles, this decade?
yes?
cold fuel is hard to burn, and bad spark is cause.
tune it up.
spark parts never last the life of any engine.
nor work cold , and damp, when old.
oldest cause on earth.

Mar 17, 2014 | 1996 Geo Metro

1 Answer

Tcs light flashes and p0340 code


P0340 code means "Something" is wrong in the timing...
from CMP (Camshaft Position sensor) to the crankshaft bolt.

Very first thing, verify connectors are clean and shiny.
clear all codes, even hard codes.

57f2e883-ce32-4061-b04b-ae0890f2c653.gif
612c4a6c-208f-43b8-8645-8318e85f9e48.gif
9e0c3051-1208-49b3-95d5-de3ff545fd3a.gif

Nov 23, 2013 | 2005 Mazda 6

1 Answer

Volvo v40gdi sometimes won't start but starts fine from cold when trying to start it chokes and struggles if I remove air filter assembly it starts fine,


To troubleshoot the issue, click the link below:

Car Repair Diagram

http://technoanswers.blogspot.com/2013/03/car-repair-diagram.html

-------


HOT/WARM START ISSUE


Its a hot start issue.

Can be related to low fuel pressure or problem with crank sensor.


Also it can be weak battery or starter.


But possibilities are to be inspected to confirm what exactly it is.------


To troubleshoot and confirm the issue,i suggest you refer few solved help links with similar types of problem like yours:------


Click the link below:------


1991 Toyota Trecel: Engine Starts fine but dies when gets Warm?

http://whatisbyme.blogspot.in/2012/05/1991-toyota-trecel-engine-starts-fine.html

-------------

1994 Toyota Pickup: Starts fine but dies in few seconds?


http://howtobyme.blogspot.in/2012/05/1994-toyota-pickup-starts-fine-but-dies.html

------------

1995 Lexus LS400: Running Hot?

http://whatisbyme.blogspot.in/2012/05/1995-lexus-ls400-running-hot.html

------------

2002 Toyota Camry: Puff of Blue or White Smoke while Starting?

http://whatisbyme.blogspot.in/2012/05/2002-toyota-camry-puff-of-blue-or-white.html

------------

Multiple problems on car: Car runs hot, A/C blows hot and car starts surging?

http://schematicsdiagram.blogspot.in/2012/04/multiple-problems-on-car-car-runs-hotac.html

--------------

Delay starting on Toyota Prius?


http://schematicsdiagram.blogspot.in/2012/02/delay-starting-on-toyota-prius.html

-----------

Honda car will not start intermittently?

http://technoanswers.blogspot.in/2012/02/honda-car-will-not-start-intermittently.html

--------------

Vehicle Starts, Runs and Loses Power

http://whoisbyme.blogspot.in/2012/07/vehicle-startsruns-and-loses-power.html

--------------

Intermittent starting issues on Volvo 760?

http://schematicsdiagram.blogspot.in/2012/02/intermittent-starting-issues-on-volvo.html

-----------

Car starts and cuts off immediately?

http://repairhelpcenter.blogspot.com/2012/01/car-starts-and-cuts-off-immediately.html

-----------

Car won't start when cold?

http://schematicsdiagram.blogspot.com/2011/12/car-wont-start-when-cold.html

===========

These details will help.

Thanks.

Mar 14, 2013 | Cars & Trucks

1 Answer

Cold engine cranks when bumpping the starter once. After engine is wram you have to bump starter three time to crank. 1997 jeep wrangler 4.0 engine. What is the problem. Thanks


Its a hot start issue.

Can be related to low fuel pressure or problem with crank sensor.


Also it can be weak battery or starter.


But possibilities are to be inspected to confirm what exactly it is.------


To troubleshoot and confirm the issue,i suggest you refer few solved help links with similar types of problem like yours:------


Click the link below:------


1991 Toyota Trecel: Engine Starts fine but dies when gets Warm?

http://whatisbyme.blogspot.in/2012/05/1991-toyota-trecel-engine-starts-fine.html

-------------

1994 Toyota Pickup: Starts fine but dies in few seconds?


http://howtobyme.blogspot.in/2012/05/1994-toyota-pickup-starts-fine-but-dies.html

------------

1995 Lexus LS400: Running Hot?

http://whatisbyme.blogspot.in/2012/05/1995-lexus-ls400-running-hot.html

------------

2002 Toyota Camry: Puff of Blue or White Smoke while Starting?

http://whatisbyme.blogspot.in/2012/05/2002-toyota-camry-puff-of-blue-or-white.html

------------

Multiple problems on car: Car runs hot, A/C blows hot and car starts surging?

http://schematicsdiagram.blogspot.in/2012/04/multiple-problems-on-car-car-runs-hotac.html

--------------

Delay starting on Toyota Prius?


http://schematicsdiagram.blogspot.in/2012/02/delay-starting-on-toyota-prius.html

-----------

Honda car will not start intermittently?

http://technoanswers.blogspot.in/2012/02/honda-car-will-not-start-intermittently.html

--------------

Vehicle Starts, Runs and Loses Power

http://whoisbyme.blogspot.in/2012/07/vehicle-startsruns-and-loses-power.html

--------------

Intermittent starting issues on Volvo 760?

http://schematicsdiagram.blogspot.in/2012/02/intermittent-starting-issues-on-volvo.html

-----------

Car starts and cuts off immediately?

http://repairhelpcenter.blogspot.com/2012/01/car-starts-and-cuts-off-immediately.html

-----------

Car won't start when cold?

http://schematicsdiagram.blogspot.com/2011/12/car-wont-start-when-cold.html

===========

These details will help.

Thanks.

Dec 17, 2012 | Jeep Cherokee Cars & Trucks

1 Answer

Why is my 1991 olds cutlass calis hard start & spiting & poping when its hot


Its a hot start issue.

Can be related to low fuel pressure or problem with crank sensor.


Also it can be weak battery or starter.


But possibilities are to be inspected to confirm what exactly it is.------


To troubleshoot and confirm the issue,i suggest you refer few solved help links with similar types of problem like yours:------


Click the link below:------


1991 Toyota Trecel: Engine Starts fine but dies when gets Warm?

http://whatisbyme.blogspot.in/2012/05/1991-toyota-trecel-engine-starts-fine.html

-------------

1994 Toyota Pickup: Starts fine but dies in few seconds?


http://howtobyme.blogspot.in/2012/05/1994-toyota-pickup-starts-fine-but-dies.html

------------

1995 Lexus LS400: Running Hot?

http://whatisbyme.blogspot.in/2012/05/1995-lexus-ls400-running-hot.html

------------

2002 Toyota Camry: Puff of Blue or White Smoke while Starting?

http://whatisbyme.blogspot.in/2012/05/2002-toyota-camry-puff-of-blue-or-white.html

------------

Multiple problems on car: Car runs hot, A/C blows hot and car starts surging?

http://schematicsdiagram.blogspot.in/2012/04/multiple-problems-on-car-car-runs-hotac.html

--------------

Delay starting on Toyota Prius?


http://schematicsdiagram.blogspot.in/2012/02/delay-starting-on-toyota-prius.html

-----------

Honda car will not start intermittently?

http://technoanswers.blogspot.in/2012/02/honda-car-will-not-start-intermittently.html

--------------

Vehicle Starts, Runs and Loses Power

http://whoisbyme.blogspot.in/2012/07/vehicle-startsruns-and-loses-power.html

--------------

Intermittent starting issues on Volvo 760?

http://schematicsdiagram.blogspot.in/2012/02/intermittent-starting-issues-on-volvo.html

-----------

Car starts and cuts off immediately?

http://repairhelpcenter.blogspot.com/2012/01/car-starts-and-cuts-off-immediately.html

-----------

Car won't start when cold?

http://schematicsdiagram.blogspot.com/2011/12/car-wont-start-when-cold.html

===========

These details will help.

Thanks.

Dec 04, 2012 | 1991 Oldsmobile Cutlass Calais

1 Answer

Vw polo, 1.4 petrol, 1996. when slowing down revs drop and car stalls and can be difficult to start again. when driving it can suddenly get abit jerky, no power from accelerator then loses the revs and...


HOT/WARM START ISSUE


Its a hot start issue.

Can be related to low fuel pressure or problem with crank sensor.


Also it can be weak battery or starter.


But possibilities are to be inspected to confirm what exactly it is.------


To troubleshoot and confirm the issue,i suggest you refer few solved help links with similar types of problem like yours:------


Click the link below:------


1991 Toyota Trecel: Engine Starts fine but dies when gets Warm?

http://whatisbyme.blogspot.in/2012/05/1991-toyota-trecel-engine-starts-fine.html

-------------

1994 Toyota Pickup: Starts fine but dies in few seconds?


http://howtobyme.blogspot.in/2012/05/1994-toyota-pickup-starts-fine-but-dies.html

------------

1995 Lexus LS400: Running Hot?

http://whatisbyme.blogspot.in/2012/05/1995-lexus-ls400-running-hot.html

------------

2002 Toyota Camry: Puff of Blue or White Smoke while Starting?

http://whatisbyme.blogspot.in/2012/05/2002-toyota-camry-puff-of-blue-or-white.html

------------

Multiple problems on car: Car runs hot, A/C blows hot and car starts surging?

http://schematicsdiagram.blogspot.in/2012/04/multiple-problems-on-car-car-runs-hotac.html

--------------

Delay starting on Toyota Prius?


http://schematicsdiagram.blogspot.in/2012/02/delay-starting-on-toyota-prius.html

-----------

Honda car will not start intermittently?

http://technoanswers.blogspot.in/2012/02/honda-car-will-not-start-intermittently.html

--------------

Vehicle Starts, Runs and Loses Power

http://whoisbyme.blogspot.in/2012/07/vehicle-startsruns-and-loses-power.html

--------------

Intermittent starting issues on Volvo 760?

http://schematicsdiagram.blogspot.in/2012/02/intermittent-starting-issues-on-volvo.html

-----------

Car starts and cuts off immediately?

http://repairhelpcenter.blogspot.com/2012/01/car-starts-and-cuts-off-immediately.html

-----------

Car won't start when cold?

http://schematicsdiagram.blogspot.com/2011/12/car-wont-start-when-cold.html

===========

These details will help.

Thanks.

Nov 28, 2012 | Cars & Trucks

1 Answer

When outside temp is above 80 degrees, engine will not start after running for a while. maybe vapor lock? After engine cools, 15-20 minutes engine starts.


Check the Engine Coolant Temperature sensor. If it is faulty or disconnected, it will tell the engine computer that the engine is still fully cold even when it is actually warm. The computer will then schedule too much fuel for a warm start--flooding the engine. You wind up waiting for the excess fuel to evaporate and the engine to cool down some and "match" the faulty sensor before it will start.

Another possibility is a leaking fuel injector. Again, a warm engine with too much fuel dripping from an injector will flood.

Mar 11, 2011 | Ford F-250 Super Duty Cars & Trucks

1 Answer

I have a 97 geo metro 3cyl 1.0 lt. Runs


Have you checked (or replaced) the O2 sensor. This can cause the engine to run bad at cold temps if the sensor is bad

Sep 22, 2009 | 1995 Geo Metro

2 Answers

Astro starting problems


your battery is about to die....

May 20, 2008 | 1996 Chevrolet Astro

Not finding what you are looking for?
2001 Chevrolet Metro Logo

3,757 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6864 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...