Question about 1998 Mitsubishi Galant

2 Answers

Vr4 with miss and back fire under load

I got a 98 mitzi legnum vr4 that has a bad miss under load and when add more acceliration and it start to back fire. it seem to get worse the lower the fuel get have cleaned filter sock on bottom of fuel pump and have replaced fuel filter but have not made any differance

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My 97 vr4 legnum is missing, can feel it when i put throttle into it, but still drive it around, any ideas

Posted on Jun 22, 2013

  • jesse kay
    jesse kay Dec 14, 2013

    also got same problem with mine checked all the hoses ,has fairly new plugs changed the throttle body gaskets and intake ,added another ground wire all i think next that somewhere along the inter cooler is causing it maybe the material covered piping?

×

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 43 Answers

If this just started, maybe after a hard run, you may want to check your sparkplugs. I've melted the insulator on one of my plugs after a prolonged, spirited run causing same symptoms.

Posted on Oct 05, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mitsubishi legnum vr4 1996 cranks but don't start no spark to coil


run fault codes
could be crank/ cam position sensor
ignition control module
immobilizer not operational
broken timing belt/chain

Aug 22, 2016 | Mitsubishi Cars & Trucks

1 Answer

Timing digram v6 2500cc mitsubishi vr4


Visit the on-line store, know as reliable-store, they have the repair manuals. I'm sure you will get the solution of your problem.

Best Manuals

Jun 30, 2016 | Mitsubishi Cars & Trucks

1 Answer

My tlc off light has come on along with my engine light,and when on boost there is a missfire?legnum vr4.


If you can drive it to autozone and have them check the engine codes with a reader, it would be a big help

Dec 19, 2013 | Mitsubishi Galant Cars & Trucks

1 Answer

Mitsubishi legnum vr4


probably means that the engine mounts and reaction rod need new mounts and rubbers.

Nov 06, 2013 | Cars & Trucks

1 Answer

Replacing legnum vr4 starter motor but cant get it out the car what do i need to remove to get it out as iv tried from top and bottom now but looks major either way there is also a hole in the wheel arch...


remove the radiator if its at teh front of the engine ,if at the back then lower subframe or exhaust manifold down pipe ,all depends on the layout of the engine ,never done one so i just do not hence the suggestions

Aug 18, 2011 | Mitsubishi Lancer Cars & Trucks

1 Answer

Toyota camry V6 1993 Car has been running fine until just now. In drive position it is missing real bad with no back fire. It seems ok at this point in nutral & park. In the midst of floods &...


if the car is missing only when it is under a load my first guess would be the coil, i would hate to point you in the wrong direction since cash is short for everyone right now, you didnt mention the last time you changed the sparkplugs and wires but it seems if it was one of these the skip would be continuous, although i have seen a bad wire cause a skip under load,it really could be a number of things but this is the best place to start

Jan 14, 2011 | Toyota Camry Cars & Trucks

Not finding what you are looking for?
1998 Mitsubishi Galant Logo

583 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6879 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...