Question about Hyundai Motor 1999 Elantra

1 Answer

No heat my temp gauge works fine, until I turn the heat on and then it drops below the cold mark. Every once in awhile it will rise and I get heat, but not for long. What's the prob?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Master
  • 674 Answers

With the engine cold remove the radiator cap and check your antifreeze . im sure its low but now we have to find out why its low . look for leaks. filler up and get it warmed up and look around try to find your leak.'
good luck

Posted on Sep 14, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is the thermostat fuse at


There is a fuse for the gauges, If no other gauges work then I'd suspect the fuse. If only the temp gauge is acting up, look at the temp sensor wiring or the sensor itself.

Sep 30, 2015 | Cars & Trucks

1 Answer

No heat coming from the vents.


If it is a manual system--sounds like coolant low ie: air bubble in system. If it is ATC system, Check Codes, if no failure codes, coolant may be low--air bubble in system--most Durango's have air bleeders in system.

Jan 18, 2015 | 1998 Dodge Durango

1 Answer

Temperature gauge cold then back to normal


You have to make sure the thermostat is working properly and is the correct one. Idle the vehicle for about 20 minutes and then feel the upper radiator hose. It should be hot to the touch. Drive the vehicle and when the temp gauge falls to 'cold' stop and feel it again. If it is much cooler to the touch than before the thermostat is defective or wrong.

Mar 23, 2014 | 2000 Ford Ranger SuperCab

1 Answer

Heat goes in and out and the temp gauge goes up and down


Your temp sensor has nothing to do with your heater. The temp sensor needs coolant in order to work properly. So first check the coolant level because if it is low your heater will act the way you describe. Once the coolant gets low enough the heater will blow cold. Another possibility is the radiator cap. After the engine has warmed up it expands when it cools down it contracts. As it is contracting if the cap is weak air can be drawn into the system and cause air pockets to form and will cause the same problem

Feb 09, 2013 | 2000 Pontiac Grand Prix

1 Answer

Cooling fan problems


Hi Dave the ECU receives messages from sensors, one of which is a temperature sensor. When the sensor responds to a temp higher than the normal operating temp the fans are then and only then supposed to operate. They will switch in for a brief period and then turn off again. The idle speed is in direct relation to the cold start up idle requirements and specifications. When the engine is cold the idle speed will automatically increase and as the engine achieves operating temp, the idle speed will decrease inthe way you have recorded. If you start the engine and allow it to idle until normal temp is achieved the fan should cut in. The way you've desribed all systems are A okay!. Regards John

Mar 29, 2012 | Pontiac Montana Cars & Trucks

2 Answers

My temp gauge goes to the third line before fans come on and only the low fan comes on. I already replaced thermostat, engine coolant temp. sensor and radiator flush... any idea why high fans dont come on...


CHECK COOLANT FAN FUSES AND RELAYS. CHECK COOLANT LEVEL.MAKE SURE ITS NOT TOO LOW BECAUSE IF COOLANT TOO LOW . BY NO COOLANT AROUND OR COOLANT SENSOR NOT SUBMERGED IN COOLANT COOLING FANS WONT TURN ON.MAKE SURE YOU HAVE 50/50 ANTIFREEZE AND WATER. CHECK FOR CLAPSE RADIATOR HOSES.CHECK RADIATOR HOSE AT WATER PUMP.IF HOSE LOOK CLAPSE REPLACE IT AND BLEED COOLANT SYSTEM.IF EVERY THING HAS BEEN DONE YOU NEED ENGINE BLOCK FLUSHED OUT.HEATER CORE ALSO COULD BE STOPPED UP.A VERY HIGH MILEAGE ENGINE WILL OVER HEAT.OLD ENGINE LOSES COMPRESSION AND HORSE POWER.PUTTING MORE LOAD ON THE OLD ENGINE WILL MAKE IT OVER HEAT.IF COOLANT LEVEL IS LOW.BLEED COOLANT SYSTEM.START THE ENGINE LET IT IDLE FEW MINUTES WATCH THE COOLANT TEMPERATURE GAUGE.WHEN TEMPERATURE START RISING.TURN OFF THE ENGINE LET IT SET FOR 20 MINUTES.TAKE A LARGE RAG PLACE OVER RADIATOR CAP ON COOLANT EXPANSION TANK SLOWLY OPEN RADIATOR CAP JUST A LITTLE TO RELEASE A LITTLE PRESSURE AT A TIME.DONT OPEN CAP RAPIDLY OR YOU WILL GET SCALDED.ONCE THE RADIATOR CAP REMOVED.IF COOLANT LOW ADD MORE COOLANT IN THE THE COOLANT EXPANSION UNTIL YOU GET TO THE COLD MARK.REPEAT THIS PROCEDURE START ENGINE LET IT RUN UNTIL TEMP GAUGE START CLIMBING A BIT DONT LET CAR RUN TO OVER HEAT JUST IDLE UNTIL TEMP JUST START TO RISE.THEN YOU TURN OFF ENGINE. WAIT 20 MINUTES.THEN USE LARGE RAG OPEN RADIATOR CAP LITTLE AT A TIME. DO THIS PROCEDURE UNTIL THE COOLANT IN THE EXPANSION TANK STOP DROPPING. THEN ALL THE AIR IS BLEED OUT THE COOLANT.WHEN COOLANT LEVEL STOP DROPPING, WHEN YOU DRIVE CAR AROUND.AND TURN OFF ENGINE.WHEN ENGINE OFF CAR SET FOR A WHILE KEEP CHECK ON THE COOLANT LEVEL IN COOLANT EXPANSION TANK. THE COOLANT LEVEL SHOULD BE AT THE COLD MARK IN THE EXPANSION TANK.MAKE SURE COOLANT IS IN THE EXPANSION TANK.IF NOT AIR WILL DRAW IN COOLANT SYSTEM. CAUSING ENGINE TO OVER HEAT.IF BLEEDING AIR OUT THE COOLANT SYSTEM DONT HELP AND COOLANT FANS DONT TURN ON YOU HAVE PCM PROBLEMS.

Apr 22, 2011 | 2004 Pontiac Grand Prix

1 Answer

2002 gmc van overheatig


It has a leak. Fill up the radiator and the coolant tank. Then restart it and check for leaks.

Mar 13, 2009 | 2002 GMC Savana

2 Answers

I have a 2000 Daewoo Leganza. When I first bought it, there was no heat in car, temperature guage was blowing sky high and shutting down engine. It was discovered that there was engine problems, so that...


You have air in the cooling system, it needs bleeding, this is best done from the heater hoses. you cannot have a heating or cooling sysem that is not pressurised. no water no heater no demister no temp guage

Jan 17, 2009 | 2000 Daewoo Leganza

Not finding what you are looking for?
Hyundai Motor 1999 Elantra Logo

Related Topics:

133 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hyundai Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6869 Answers

Are you a Hyundai Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...