Question about 1999 BMW 318 ti

1 Answer

1999 bmw 316i location of sensors

Could you please help me find the location of the coolant low level sensor or sensors on a bmw 316i thanks

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Vice President:

    An expert whose answer gotĀ voted for 100 times.

    Sniper:

    An expert who has posted more than 50 answers, of which 90% or more were rated as helpful.

  • Expert
  • 117 Answers

Hello there

the coolant level sensor is at the bottom of the raidiator, ther is an electrical wire going to it so you sould find it easily.

Hope this helps, please don't forget to rate me.

Posted on May 19, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Low coolant code stays on but the coolant level is fine 1995 bmw 525i touring. What's causing this?


coolant sensor replace it because it could cause more problems with other important sensors andscrew gas milege big time please dont wait get it fixed Coolant sensor u can getit from your parts store its very easy to replace

Feb 20, 2014 | 1995 BMW 5 Series

3 Answers

I am getting message "Coolant low". My sister


Welcome to Fixya

You need to add few ounces of coolant to the reservoir. The reservoir is located under the hood. It is a white plastic that has liquid in it. Please see picture below of the coolant reservoir.
10_1_2011_3_07_37_pm.png
Thank you for using Fixya!

Oct 01, 2011 | 1999 Jeep Grand Cherokee

1 Answer

I have a BMW 1999 740iL. The engine temperature indicator on the dashboard goes up close to the red zone when I drive above 70 m/h or climb a hill for about 10 to 15 min. After I slow down to about 40...


CHECK FOR LOW COOLANT LEVEL.IF COOLANT LEVEL OKAY.SCAN VECHICLE FOR FAULTY COOLING FAN OR RELAY.AND SCAN FOR FAULTY COOLANT TEMPERATURE SENSOR.

Feb 01, 2011 | 1999 BMW 7 Series

2 Answers

My low coolant light flashes on and off then it will stay on.I have checked my coolant level it is good what could be the problem? 1999 Buick regal


Make sure you are checking the coolant level in the radiator as well as in the overflow tank. The sensor is located in the radiator, so if the level in the overflow tank is good, it could still be low in the radiator.

Dec 06, 2010 | 1999 Buick Regal

2 Answers

I have a 1995 316i compact and it keeps misfireing, it has had the coil pack replace which seemed to solve the problem for a few miles and thn it started to misfire again. please help


i've had similar issues with a 1999 M3. normally attributed to electrical power levels this could be a low voltage issue.

do you have error codes?

make sure the power contact at the starter motor (between the alternator and the battery) is tightened.

I have also had issues with a cranshaft position sensor. but my favourite culprit of electrical issues is a wet ECU.

the ecu compartment is under the windshield on the passenger side on E36

you gain acess to it under the hood....
this compartment gets wet, the ecu lays on a flat surface in that
compartment.

the bottom side of the circuit board gets wet and starts corrosion.

remove the ecu, take the bottom plate off, clean the bottom of the circuit
board with alcohol and a soft tooth brush.

you should be able to see the signs of corrosion or conductive build up.

this gunk bridges solder points doing all sort s of wierd things to your
car, including false sensor readings from asc/abs controllers and other
sensors....

all the way to engine failure and worst case burnt and shorted wiring
harness.

I'm on my 3rd ecu, took me and the repair boys a few years to figure this
one out.

BTW: i would get that ecu mounted above that flat surface, use some sort
of standoff to raise it so that it is not laying in the wet.

Feb 01, 2010 | 1999 BMW 328 Series

2 Answers

Low coolant light came on 1999 Oldsmobile Silhouette, went out a couple minutes later without adding any coolant. Adding a little anyway after light went out. Now about 1 1/2 weeks later light came on...


If its not low on coolant and the light continues to come on it is the low coolant sensor in the radiator. This sensor is in the plastic side of the radiator and just pops off. These sensors are always a problem and don't always require replacement of the sensor. What happens -especially if you are using red DEX-COOL coolant is that the coolant gets hard and crusty inside the sensor and wont allow the coolant to enter and make contact with the sensor. Simply take the sensor off and blow compressed air or water pressure in it to free it of debris. Easy fix-hope this helps!

Dec 08, 2009 | 1996 Chevrolet Camaro

1 Answer

Red light square with arrow need to know what it is


I'ts the low coolant sensor. I'ts located on your radiator. they are know to go out. if your coolant level is not low, just change the sensor. the sensor cost about $50.00.
good luck.

Jun 25, 2009 | 1999 Oldsmobile Intrigue

1 Answer

BMW 316i KEEPS STALLING WHEN SLOWING DOWN AT JUNCTIONS


at the engine, there is a small sensor that helps increase or decrease the rpm of the engine. Perhaps yours is soo low, that when you slow down, it's almost about to stop.

The other problem could be the airfilter sensor. If it's not properly fixed or if the sensor itself is a bit damaged, than the engine is not getting enough air and so, let's the engine almost go off.

Please give further details if this has not helped.

thank you

May 06, 2009 | 1997 BMW 318

1 Answer

Buick 1999 century replaced the sensor light and still comes on.


your buick century has a low coolant level sensor located in the passenger side of the radiator , sometiomes the sensor get covered with coolant sludge and will show that the cooling system is not filled , sometime the radiator is just still low on coolant . check the radiator when the engine is cold ( IF HOT WAIT !!! 30 mins ) and make sure the level is above the sensor.

Feb 06, 2009 | 1999 Buick Century

1 Answer

Brake wear sensors


Redmondeo34


A couple of things to check.
This is only if you replaced the front pads, after the warning light came on.
1. Make sure brake fluid is level and at the max mark
2. Did you replace the front pads sensors with the new pads.If not please do.
3. Check that the rear pads and sensors are not worn and do not require replacing.
4. If all above is good, Drive vehicle for about 5klm and switch off and on it will reset itself

regards
I hope this helps.

Jul 03, 2008 | 1996 BMW 318

Not finding what you are looking for?
1999 BMW 318 ti Logo

Related Topics:

424 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Fred Sops

Level 2 Expert

271 Answers

Al Clark

Level 2 Expert

290 Answers

Doberman

Level 2 Expert

246 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...