Question about 1995 Chevrolet Astro

1 Answer

All wheel drive transmission

The transmission was replaced last year with a rebuilt one, then the van was parked for about a 9 months. when it was driven again it was on a long haul, from new york to north carolina. about half way there the van started to make a loud noise, when we inspected further transmission fluid was leaking out. repaird a broken return hose, a small 1/4 inch rubber hose located on the return line. refilled the transmission, and drove, now the vehicle will not shift into overdrive to go into high way speed, so 45 mph is the fastest it can go without making the engine race, but all the low gears are shifting good, when you get up to highway speed it acts as though it is goverened, my first inclination was to change the modulator valve but when i went to get one, they told me that particular transmission does not have one, what component, if any took the place of a modulator valve or was that guy just trying to get me to go to his uncle's shop?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

If it is a 4l60e transmission its all electronic and it has solinoids to do the shifting it sounds like the drive or overdrive solinoid is not working

Posted on Jan 07, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Truck will not go into drive, only neutral or park.


Sorry to deliver the bads news but you have a failed automatic transmission. You will need it replaced or rebuilt.

Jun 12, 2012 | Mitsubishi Raider Cars & Trucks

2 Answers

Had the transmission rebuilt 1 year ago. It haas not worked right since then. I have taken it back to the mechanic 3 times. Now when I am driving the van suddenly "bolts"(feels like I ran over...


Hi...I am not a transmission expert and I would wait for other solutions but it sounds like the Torque Converter...was it replaced at the time the ****** was rebuilt?

Sep 18, 2011 | 2004 Ford Freestar

2 Answers

My 2000 MPV gets stuck in park. The parking gear will not light up to indicate the van is in park. Once the van is running for about 20 mins or more the parking gear light will come on and I am able to...


it sounds like a shift lock solinoid ....this prevents the car from being shifted out of park when ur foot is not on the brake....u will have to bring this to a repair shop since the faulty part is located inside the paneling where ur shifter handle is

Jul 15, 2011 | 2000 Mazda MPV

2 Answers

I replaced the drive shaft one yr.ago as the front universal joint was shot.My dealer told me it would cost about $1800.with labour to replace.I decided to replace it with a used shaft for $800. Now,after...


I didn't see the model or year and if it is posted,it won't let me see it since I selected your problem...Anyhow,I would contact Toyota to find about possible problems/recalls with the drive shaft.A recommendation I would like to suggest though,when it comes to repairing/replacing anything in the drive system,you should buy new,not used or rebuilt.Rebuilt transmissions usually are constantly problematic.I rebuilt my own engine and it blew again in about 6 months.I do buy used whenever possible though,door parts,bumper,mirrors,stuff like that.I hope Toyota has something for you.Good luck! Greg

Aug 13, 2010 | Toyota Highlander Cars & Trucks

1 Answer

My 2002 chevrolet 2500hd 4 wheel drive will not engage. Light does not come on. Worked last winter. Transmission was rebuilt last summer. After about a month, I heard a loud kerplunk. It was real cold here...


I would check the wire harnesses for damage (pinching, cuts and such) from the transfer case. There may be damage from the trans install. Also fuse panels both under hood and interior. Since no lights are on it is probably a fuse or the harness is disconnected.

Jan 07, 2010 | 2002 Chevrolet Silverado 2500HD

1 Answer

I heard a loud pop, then the vehicle wont move in any gear.It then grinds when I try to put it in park.


It sounds like you broke a Constant Velocity joint (CV Joint). The pop was probably the joint breaking. When you put it in gear it's just spinning. Think of one of your hands as the transmission. Hold a pencil that would be the CV Joint(s) and axle, and use the other hand to hold the other end of the pencil. That's the front hub (part that makes the wheel turn). So you have ...hand, pencil...hand = trans, axle... wheel. If you hold the pencil firmly with both hands, and spin the pencil with one, both hands still move.

If the pencil breaks...the one not spinning does nothing.

So...The transmission is trying to make the van go, but the cv joint is broken, so the wheels aren't spinning. When you put the van in park, the transmission doesn't know the vans not moving. Therefore it's making the same noise as if you put the van in park while driving. If you must start the van and put it in gear to see if the driver's or passenger's axle is just spinning. Shut the van off, wait a minute for the axle shaft to stop spinning, and then put it in park.

Oct 02, 2009 | 1995 Mercury Villager

1 Answer

Transmission has been rebuilt but manual shift lever wont work and it is not bound up in transmission it something under the transmission pan


I sounds as though your friend bent the parking pin, or tried to engage park with your van moving either forward or back and has wedged it somehow. you can try to grease the **** linkage or have this done it may help or you may need a new park pin

Apr 26, 2009 | 1999 Dodge Durango

Not finding what you are looking for?
1995 Chevrolet Astro Logo

214 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

63574 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...