Question about 1995 Lincoln Town Car

1 Answer

Trouble with engine

My car turns on alright but whenever i put it on drive and step on the accelerator it delays and just revs the engine as if it were on neutral. it does the same thing when i put it on reverse.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 169 Answers

Check the transmission fluid level. is it full? is it dark red or black? is it burn't or sharp smelling? you may have a burned up transmission if the fluid is full and it won't move. can you feel the gears being changed like a ratcheting of the shifter handle when moved from park to the desired gear? if not then you have some linkage problems and that can be repaired alot cheaper than a transmission. Good luck .... Scott

Posted on Sep 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My 2011 nissan maxima is having trouble accelerating. when i put it into drive, i need to almost floor the gas peddle to get going. car has regular oil changes (synthetic) and has 170K on it.


too serious a problem to let go un-diagnosed
pop into the service center for assessment

is the engine light on
that model has an electronic gas pedal sensor
I would start there

then if motor revs a lot and not go forward as it should
a transmission fault


26310343-aj0bpuggwlpnm3rl25tm2hi1-4-0.jpg

Oct 13, 2016 | 2011 Nissan Maxima

1 Answer

When applying pressure to accelerator, it sometimes "sticks", revs REALLY high and the car har no power to the accelerator - have to pull over, turn off vehicle and restart...???


pull diagnostic trouble codes and post back, sounds like it could be a problem with tps or app sensors, assuming this is a drive by wire and not a cable driven system

Feb 20, 2014 | 2003 Renault Sportwagon

1 Answer

Transmission hesitation


I suspect you have a clogged transmission filter. The problem could also be a bad fluid pump. These transmissions are designed to be 'disposable' meaning when issues such as these occur, it may be cheaper to replace the trans than to fix it. First I would have the transmission flushed, then have the filter changed. If the problem persists, then replacing it may be your only option.
Hope this helps and thanks for using Fixya!!

Feb 17, 2014 | Toyota Camry Cars & Trucks

1 Answer

Press gas pedal


check your throttle pedal position switch and your throttle position sensor

Dec 19, 2013 | 2005 Chevrolet Cobalt Sedan

1 Answer

Hi, I have any Audi Allroad 2003 automatic. Its started to occasionally delay changing from 1st to 2nd gear when in drive. If I change to sport mode then back to drive it will change gear, Also when on...


Try putting the in in on position and depress accelerator pedal to floor for ree seconds three times. that should put it in learning mode however sounds more like TCM or tranny valve body.

Oct 20, 2012 | 2002 Audi allroad

1 Answer

Car has trouble starting again after being driven.


The very first thing you need done here is the computer tested for fault codes, one or more is set whenever the check engine light is turned on. Autozone and others do this for free. Ask for an OBD2 fault code test (1996 and newer models only)

Jun 01, 2012 | Mitsubishi 3000GT Cars & Trucks

1 Answer

After diagnosis my v8 740i bmw indicated the "variable valve gear guide sensor for bank 2 and variable valve gear learning stops necessary" currently it's difficult accelerating the engine. would...


You have a v8 with a "variable valve gear guide sensor" on each bank. The trouble code is telling you that bank#2 sensor is faulty, or its signal is not getting to the engine computer.

Consequently, when bank#1 adjusts the timing (under hard acceleration or higher revs), bank #2 is not getting adjusted.

If the variable valve timing is not being activated (low load, load revs) the engine will run more or less normally.

Get the car to the dealer. You risk MAJOR ENGINE DAMAGE if you keep driving it.

SD

Jan 06, 2011 | BMW 750 Cars & Trucks

4 Answers

Ok... chev blazer 2003 is accelerating on its own..


might wanna check ur throtle position sensor

Jun 13, 2008 | 2003 Chevrolet Blazer

1 Answer

Engine spits and sputters


check your spark plug wires.

May 15, 2008 | 1993 Saturn SC1

Not finding what you are looking for?
1995 Lincoln Town Car Logo

150 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lincoln Experts

yadayada
yadayada

Level 3 Expert

63990 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Are you a Lincoln Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...