Question about 1994 Chevrolet S-10 Blazer

1 Answer

Dash gauges flashed for a day except fpr the speedo the speedo still works but everything else is blank

Dash gauges went out

Posted by on

  • yadayada
    yadayada May 11, 2010

    Have you checked the fuse?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Same happened to me when i bought mine only the speed and miles were on

you have to replace the bottom board on your dash panel a new part runs about 300$

and repaired one with a lifetime warranty is about 60$

http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&item=280244943702&ssPageName=ADME:X:AAQ:MOTORS:1123

SHipping takes forever but his stuff does work!

Posted on Sep 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No dash lights when headlights are turned on. Everything works fine on my vehicle EXCEPT today the panel lights don't work. Turn signals, hazard blinker, oil gauge, rpm gauge, speedometer, drive shift...


there is a regulator for the display brightness, you may have it turn'd down or it has stopped working;. it controls the brightness at which the dash lights are. usually has a speedo sign on it. goes up and down. it works with the main light and is conecter to them on the same lighting board if it has gone then a new light swtch control switch will be needed.

Oct 13, 2013 | 2001 Chrysler Town & Country

1 Answer

2000 Audi A4 2.8 Quattro, heater core went bad. Now nothing works in the instrument cluster except a few warning lights, no speedo, tack, gas or anything. I checked all fuses, nothing was burnt out. Trying...


need to check the ignition control unit under the dash. its right behind the dash. if you have had a water leak it is the first part to go. when you turn the key you should hear it click. sends power to the dash.lights gauges etc.

Sep 11, 2013 | 2000 Audi A4

1 Answer

The dash lights went out on my 2000 Buick Lesabre Custom. It doesn't have the heads up display or remote locks, though they are power. All the other lights work fine, the computer displays work, and when...


Sounds like you have some confusion going on here.
The dash lights and tail lights have always been on different circuits and fuses. So if one set of lights fail, the other stays on unless the headlight switch blows up.
The fuse marked "instruments" is for the speedo and gas gauge, not the lights.
On your car there is an instrument panel module and a dash integraded module which both involve the dash lights.
You may need a shop manual to get the wiring diagrams and test procedures for this circuit.
Another thing - after 1998 most cars and trucks switched from having the headlight switch provide power to having them provide the ground connection.

Apr 22, 2011 | 2000 Buick LeSabre

4 Answers

Instrument panel went dead


Checked Every fuse in the fuse box (no small task).This includes #4 - Power point Instrument Panel, #14 - Day time running lamps (auto lamps doesn't work nor does auto lock), #27 - ignition switch run feed, #35 - Instrument Cluster, #41 - Instrument Cluster, #42 - Delayed Accessory, #45 - Ignition switch run/start feed, #102 - Door locks body security module, #103 - Ignition switch, #110 - Ignition switch, & #116 - Ignition switch. But I also check all other ones as well, they all register OK. AC panel & radio work. Turn signals work. Mileage does not work, trip computer does. So, basically, everything works except auto head-lights, auto locks, and the dash cluster (no MPH, RPM, mileage display, Fuel, Temp, Tran Temp, and Oil Pressure).

Aug 19, 2009 | 2003 Ford Excursion

2 Answers

Dash Probs


Agree with whooly17 sender unit in the fuel tank- good luck

Jul 15, 2009 | 1996 BMW 318

1 Answer

Check engine&abs light on, speedo and gauges go to 0


there would either be a shorted wire or the computer is malfunctioning. The only way to fix this problem is to have a mechanic put a scanner on your car and test it. AUTOZONE DOES IT FREE other wise it's about $40

Apr 03, 2009 | 1996 Dodge Caravan

2 Answers

Ford transit van dashboard display not working


ive got a 55 plate 85 T260 swb crewcab 68000 miles, , i bought it 12 months ago, red light flashes on dash board most days, some times arratically, sometimes quite slow, and all clocks, speedo and dash does not work?????????
the smallest scratch and the van rusts, no under seal, there just a use it and dump it van.

i would just like to say fords are ****

Dec 27, 2008 | 2003 Ford Escort

Not finding what you are looking for?
1994 Chevrolet S-10 Blazer Logo

Related Topics:

236 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...