Question about 1999 Chevrolet Cavalier

1 Answer

Sluggish engine after i had replaced both the wires and spark plugs, the engine ran normal for 1 week. After 1 week, engine idled rough during warm up idled normal when engine got hot. engine now hesitates and sluggish during normal driving. What could be wrong?

Posted by on

  • Anonymous Mar 23, 2014

    when i am driving and its warmed up it hesitates and has no power

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Could be your catalytic converter. Get an Oil Change and see if they will read your codes. If it indicates misfire or exhaust problem have the converter replaced. DO Not pay 600 dollars buy an after market converter and let them weld it in. Should cost 200 -300 bucks.

Posted on Sep 15, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2000 vw new beetle and am having with the engine idle


take it and have the engine codes ran that will tell you whats up with it sounds like a bad spark wire or coil but could be something else

Aug 22, 2014 | Volkswagen New Beetle Cars & Trucks

1 Answer

Have just replaced plugs and leads and the engine light keeps coming on for 1 to 3 mins and when its warm and i go to start it again the engine light comes on and runs a little rough what could this be?


It must be from the rough idling. Check the spark plug gaps and the lead wires if they have good continuity. Check your car manual for the proper gap for the spark plugs. Set it with the use of a spark plug gauge.

Jun 17, 2014 | 2005 Mitsubishi Lancer

1 Answer

Rough idle 2004 Mazda B3000 3.0


check for dirty fuel filter.

Dec 14, 2013 | Mazda Cars & Trucks

1 Answer

Have a 2.5 liter and number 2 cylinder exploded. I replaced the entire engine including head, valves, spark plugs and wires. new engine ran a little rough and had a check engine light for a o2 sensor....


check the spark plug wires. go somewhere dark, get a spray bottle with some water in it, then mist the spark plug wire and look for a spark to jump

Sep 06, 2011 | 2000 Jeep Wrangler

1 Answer

1992 honda accord ex 2.2L \r\nStarts. and run s OK till engine warms-up then it lacks power and idles rough? Service engine (yellow light) comes-on after engine gets warm! Red oil pressure light also...


Hi. This issue has several causes, but the oil light indicator is a strong sign of low pressure in the engine. This will cause the engine lubrication rate to drop, thus, producing a illuminated oil light, and erratic Oil pressure readings. The necessary actions are to have a manual oil pressure test ran on this engine, asap. When running a manual oil pressure test, you will discover if the true oil pressure is low, or normal. If the test proves that the oil pressure is, indeed, low, this will confirm that the Oil pump is suspect.

Now, if the true readings given during the manual oil pressure test are indicating that the pressure is normal, this will be the result of a failed sending unit(oil pressure switch). Although the oil pressure is suspect, this is not your only issue here. There seems to be a abnormal compression rate, present. This is causing the rough idle, and erratic RPMs. I recommend to administer a engine block compression test, as well. This test will discover if , indeed, there are issues within the cylinder heads, and block structure, such as a worn head gasket, cylinder wall issues, and cracked block. Normally, these issue will send signs, like white, or gray smoke out the tail pipe, or discolored oil. It will, also, promote erratic RPM ratings, and a rough idle. Have the oil pressure test, and engine block compression test ran, asap.

Once the test are administered, you will be able to isolate the actual problem areas, more accurately. Check the spark plug wire sets, and ignition assembly for faults, also.

Apr 09, 2011 | 1992 Honda Accord

1 Answer

It violently shakes when parked or when stopped with brake applied, doesn't shake when moving though, rpms is like 500rpm constant so between 0 and 1 on the gauge. it also notice at night my lights stay...


If it shakes, it is normally either a bad motor mount (if the car runs fine) or your car is "missing" on one or more cylinders (misfire). The belt will squeal because they stretch with use. That can be solved by replacing the belt or tightening the belt. The squealing sound won't go away until you do one of those two things and is unrelated to the shaking. You PROBABLY are experiencing a very "rough idle" if any of the hoses to the intake (top of the motor) have a hole or crack in them from heat or age. This is common and is the first thing to look for to avoid high repair bills. Bad (worn out) spark plugs or old cracked plug wires can also cause a misfire. You could also have a bad coil pack, but mine has gone 186,000 miles without coil replacement or new plugs or wires and I've only changed the fuel filter once. Another possiblity is a faulty Idle Position Sensor that is not properly regulating the fuel delivery. Normally that would cause an engine light to come on also though and you can have someone at the parts store "read the code" once the engine light comes on.

Apr 09, 2010 | 2003 Kia Spectra

1 Answer

1998 dodge ram pickup 318 eng. engine idle rough on warm-up engine idle rough after warm-up shutting off engine and starting back up engine also runs sluggish in over drive at a low idle. I have...


If the engine seems to run fine over 1450 RPM maybe there is a vacuum hose leaking or EGR valve is slightly stuck open. Any help from the OBD II trouble codes? Or is there simply no MIL and no stored information in the OBD II computer read at the local parts store through the connector by the drivers knee?

Dec 04, 2009 | 1998 Dodge Ram 1500 4WD

2 Answers

2001 grand am se1. Rough Idle - Spark Plugs and Spark Plug wires


What engine? You need to have it scanned for codes. Autozone will do this for free

Sep 01, 2009 | 2001 Pontiac Grand Am SE

1 Answer

95 GMC Jimmy 4.3l W vin rough idle


My problem was solved when I repaired my 4 wd activation dash switch. The switch was contacting on 2WD & 4HI at the same time. The front differential activation is vacuum activated possibly creating a tug of war that didn't actually engage it but drained off vacuum from the engine? A theory at best but stumbbled across it because I knew the switch wasn't working properly I repaired it and low and behold rough idle disappeared and all is good for 3 weeks running.

Nov 17, 2008 | 1995 Chevrolet Blazer

Not finding what you are looking for?
1999 Chevrolet Cavalier Logo

Related Topics:

230 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...