Question about 1999 Ford Expedition

1 Answer

Wiper problem my front wipers sometimes turns on by itself especially when vehicle is on the run.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Ford Master
  • 60,769 Answers

This is causes by a defective wiper switch, replace it and you are home free.

Posted on Oct 13, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sometimes when I start my 2004 Santa Fe, the rear windshield wiper comes on. The switch is in the off position. Even if I turn the vehicle off, it will still run until it decides to stop. Help.


If you will find the fuse that controls the rear wiper, and remove it, you can determine if the problem is "bleed over", which can be the result of an automobile accident.
In that case, a pinched wire somewhere can cause this problem.
If pulling the fuse stops it, then suspect the wiper switch itself.
God bless your efforts.

Nov 02, 2015 | Hyundai Cars & Trucks

2 Answers

I have a 2003 Chevy cavalier and the wiper blades don't move but I see and hear the motor turning. What could be wrong with it and how can I fix it myself.


Take the wiper arm and try to move it if it's easy to move then ....we call it the transmission between wiper arm and motor itself. little teeths are gone wiper arm side or transmission

or transmission arms are disconnected

hope it help

Mar 04, 2015 | 2003 Chevrolet Cavalier

2 Answers

Windshield wipers sometime works and sometimes dont turn on. and its not a fuse. what do i have to replace to fix this?


REPLACE THE WIPER MOTOR WHEN THEY DONT WORK HIT THE WIPER MOTOR AND THEY SHOULD START WORKING

Oct 15, 2010 | 1998 GMC Jimmy

1 Answer

Windshield wipers run with switch turned off


I have a similar vehicle and I can tell you that they're prone to electrical problems, whether it's the ECM, the clock switch in the steering wheel, or just a bad ground. I would check all the grounds, especially coming from your wiper motor under your hood. Sometimes ground switches are used on "things", so when there is no ground, "things" think they're turned on. Could also be a stuck relay, but doubtful. Best of luck.

Oct 09, 2010 | 1996 Chrysler Town & Country

1 Answer

Rear wiper runs when front wipers are turned on even after it was replaced? Dealer not sure?


The rear wiper on CR-V's is designed to go on when the front wipers are on and either one of 2 things: 1. you turn the rear wiper switch on, or 2. when the front wipers are on, if you shift into reverse, the rear wiper automatically is activated. Is it one of these, or do they just run all the time the front wipers are on? If that's the case, you probably need to have the wiper switch replaced. If the dealer said he's not sure, go to another dealer.

Mar 30, 2010 | Honda CR-V Cars & Trucks

1 Answer

Rain sensing wipers on 2005 320i BMW do not work correctly


but windex on the wind-sheild and rain-x especially where the rear-view mirror sits. dust can give a false signal to the wipers.

Oct 29, 2009 | 2008 BMW 3 Series

1 Answer

I have a 2005 Mercury Grand Marquis and I can't turn the wipers.


this is a very common problem on these vehicles. the wiper motor has a park switch built into it that fails. replace the wiper motor and this will stop problem. hope this info helps you!

Sep 22, 2009 | 2005 Mercury Grand Marquis

1 Answer

Wipers sometimes do not work on 1997 Bonneville SE


wiper module failures are common its mounted on the front of your wiper motor has a circut board that slides in ? sometimes the motor itself shorts out the board i would just replace the whole motor with a rebuilt unit ?

Aug 27, 2009 | 1997 Pontiac Bonneville

2 Answers

Left windshield wiper not working


If one works and not the other, it is obviously not anything wrong with the electrical or wiper motor, it has to be the arm itself, just tighten it down. Sometimes they come lose, especially if it is froze and etc.

Mar 21, 2009 | 1999 Isuzu Rodeo

1 Answer

2003 HUMMER H2


Had the same problem. i have to re-place my front wiper motor they are all connected.

Dec 08, 2008 | 2003 Hummer H2

Not finding what you are looking for?
1999 Ford Expedition Logo

Related Topics:

62 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...