Question about 2001 GMC Jimmy

1 Answer

Quits running for no reason

I allready replaced the 02 sensor on the drivers side recently. I had no problems for a while then it wouldn't start for me without starting fluid. Then a little while later it just quit running on my way to work and would not re-start even with starting fluid. The next day I tried it again with starting fluid and it fired up and took me home. I parked it for about 4 months. During that time, being parked, I would start it occasionally needing starting fluid to do so. Today I started it with fluid of course so I wouldn't kil the battery and drove around the block a couple times with no problem. When I shut it off, I re-started it a few times on it's own. Let it sit for about 1/2 hour and again needed fluid to re-start it. Before I started having problems it did seem to start missing or bogging when I had to accelerate quickly. I've been told there's 4 02 sensors but only see the two on the exaust just before the converter from underneath. Should I replace the drivers side sensor next? Where are the other 2 sensors?

Posted by on

  • workingmanph Sep 06, 2008

    I meant to say replace passenger side next.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,263 Answers

Htere is a good posiblity that it isn't your o2 sensor it's morelikely the tps(throttle position sensor) or you have a bad fuel pump. I just replaced a fuel pump with in a jeep cherokee with the same symptoms and lo and behold that did the trick. please rate this .

Posted on Sep 07, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2000 Oldsmobile Alero will turn over but wont start...any solutions to this problem? I did recently replace the crankshaft position sensor.


my sister in-laws did the exact same thing. we replaced fuel filter pump and injectors. All the time it was old spark plugs. It kept cranking but wouldn't start. spent less than $20 on new spark plugs and it fired right up and is still running strong

Jul 13, 2012 | 2000 Oldsmobile Alero

2 Answers

I have 1999Chevy suburban with 6.5 turbo diesel motor.it idles up and down and when driving the gas pedal is real touchy Wat is the problem and were do i locate the problem


Check the help links related to this problem.Click the link below to go through its troubleshooting procedure :-----Idles rough and quits when gas pedal is pressed less? http://technoanswers.blogspot.in/2012/01/1999-ford-f-150-idles-rough-and-quits.html---------
Car won't start without hitting the gas pedal? http://schematicsdiagram.blogspot.com/2011/12/car-wont-start-without-hitting-gas.html
-------Complete loss of brake pedal then all gets normal? http://repairhelpcenter.blogspot.com/2012/01/complete-loss-of-brake-pedal-then-all.html
------Car dies when gas pedal is pressed? http://schematicsdiagram.blogspot.com/2011/12/car-dies-when-gas-pedal-is-pressed.html
--------Pushing on the gas pedal, but the car slows down? Gas pedal to the floor and the car slows down?

http://technoanswers.blogspot.in/2012/02/pushing-on-gas-pedal-but-car-slows-down.html

---------

After replacing brake rotors and pads, brake pedal remains on floor? http://technoanswers.blogspot.in/2012/02/after-replacing-brake-rotors-and-pads.html

---------

accelerator pedal sensor? http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

-------

For rough idle issues and problem troubleshooting,go through the help links provided below :----- van idles rough?

http://howtobyme.blogspot.in/2012/01/2004-ford-freestar-van-idles-rough.html

---------
will not idle when cold?

http://technoanswers.blogspot.in/2012/02/ford-explorer-40-will-not-idle-when.html

----------
runs lean and idles rough?

http://technoanswers.blogspot.in/2012/02/ford-runs-lean-and-idles-rough.html

-----------
Engine stumbles coming off idle when warm?

http://repairhelpcenter.blogspot.com/2012/01/engine-stumbles-coming-off-idle-when.html

------------
Erratic idle on car?

http://schematicsdiagram.blogspot.com/2011/12/erratic-idle-on-car.html

----------
Low idle when cold out side?

http://repairhelpcenter.blogspot.com/2011/12/low-idle-when-cold-out-side.html

---------
Idle Air Control (IAC) Valve Replacing?

http://schematicsdiagram.blogspot.com/2011/12/gmc-idle-air-control-iac-valve.html

----------
Engine quits at idle?

http://repairhelpcenter.blogspot.com/2011/10/engine-quits-at-idle.html

------------
Car overheats and Air blows hot at idle?

http://howtobyme.blogspot.com/2011/11/car-overheats-and-air-blows-hot-at-idle.html

------
While stop engine idles like cylinder missing?

http://schematicsdiagram.blogspot.com/2012/01/while-stop-engine-idles-like-cylinder.html

---------

This will help.

Thanks.

Mar 01, 2012 | 1999 GMC Suburban

1 Answer

Replaced:plugs,wiresdistributor,fuel pump.truck wouldn't start before but now it starts but i am getting po135,po141,po147.po300 codes


P0135 means 0xygen heater circuit malfunction, P0141 mean 02 heater circuit bank1 sensor 2 (this is catalytic monitor) P0147 means 02 heater sensor circuit bank 1 sensor 3, P0300 is random misfire. You will get all the 02 code because of the misfire correct the misfire and the 02 should correct.We will start with the plug wire and make sure the firing order is correct 1996 chevy blazer that will make it a 4.3 engine size check the firing order firing order is 165432 also check the coil (it has a tendency to short you will know if it is) cansmo_181.gifcansmo_182.gifmake sure the distributor rotation is check

Sep 09, 2011 | 1996 Chevrolet Blazer

1 Answer

1991 Subaru Legacy 2.2L not Turbo "Idle" very


i would check the idle air control solenoid first. simply unplug it then remove the unit and inspect the air passage for any blockage and carbon buildup. Clean it if its dirty then test it out. If the IAC is good then you should look at the throttle position sensor.

Aug 30, 2011 | 1991 Subaru Legacy

1 Answer

I have a 1998 ford windstar and i need upstream & downstream 02 sensor but i dont know if i need 1 or 2 upstream sensors.


assueming it has the v-6 in it look at the exhaust pipe comming off the side of the engine there will be two up stream 02 sensors which are heated and one downstream past catalitic conveter. If may have the second style with the Y cross over with 1 upstream before the cat and one after. The difference between the 0-2 sensors is the upstrean are heated so it goes into closed loop faster. I find that on most of these the up stream 02 sensor heaters have failed. You can go to a Autozone and they can pull the codes for you and tell you which side it is that needs to be replaced. However 02 sensors get old after time and they start shifting slowly, if it shifts slowly then it's called a lazy 02 sensor. And will send a code to the computer, if you get the trouble code of the 02 sensor heater is bad you will have to change it, I recommend Replacing both. The reason is if one is going bad the other will soon follow. You can buy a socket wrench For the 02 sensors for 12 dollars makes it real easy to replace the 02 sensors when they are COLD. Hope this helps and thanks for using fix-ya.

Sep 14, 2010 | 1998 Ford Windstar

2 Answers

Check engine light came on recently. Car then


The exhaust system has two 02 sensors One before the cat converter and one after. The #2 02 behind the cat converter is the one that trips the light if emmisions are unacceptable coming out of the converter. The #1 or front 02 sensor monitors and constantly adjusts the fuel to stay within parameters. If the #2 tries to compensate for an inefficient converter and it conflicts with the #1 02, the ebgine will run poorly due to either too rich or too lean fuel adjustment. Have the #2 02 sensor replaced and the converter checked. Good luck

Nov 15, 2009 | 2005 Toyota Corolla

1 Answer

1993 Jeep Cherokee starts when cold. Runs short distance.


It can possibly be the crank position sensor mounted on the top of the bell housing on the passenger side of the vehicle causing the problem. I have replaced a few of these for the same reason.

Sep 13, 2009 | 1993 Jeep Grand Cherokee

1 Answer

I have 2004 GMC ENVOY XL the engine light stay on. i do a diagnostic on it the code i get is P1133 HO25/025 INSUFFICIENT SWITCHING SENSOR 1 OR BANK 1 SENSOR 1. also code PO133 02 CIRCUIT SLOW RESPONSE(BANK...


P1133 is a slow 02 sensor or a shorted to ground at the PCM to 02 sensor signal. If the 02 sensor does not cycle fast enought it is called a lazy 02 sensor, the only way to test for this is with a digital volt meter or a scanner. if it will not pulse fast enough it will throw the code so Replace the 02 senor on the driver side bank. Bank one. then clear the codes. The code is thrown do to seveal reasons the 02 sensor could be dirty or it just could be worn out, you could pull it and clean it and try it again or just replace it and be done with it. The cost of a heated 02 sensor is $50.00 at a auto parts store or the dealer might charge a little higher but the cost in savings of fuel is well worth it.

Jun 30, 2009 | 1998 Saturn SC

Not finding what you are looking for?
2001 GMC Jimmy Logo

127 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...