Question about 1994 Chevrolet S-10

1 Answer

1994 s10 service engine soon light

I have a 1994 chevy s10 ive replaced the o2 sensor the idle air contol the throdle posission sensor and the light comes after i park it it idles a little high then the light goes on then if i take off again the light goes off and it drive fine and idles fine

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

Have you had the truck scanned for codes? If so, what was the code, codes? Why did you replaced those listed parts. Can you hear any hissing noise coming from the engine or engine compartment?

Posted on Sep 04, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What are the probable causes of DTCs P0031, P0603, and P1148?


Clean out you idle air bypass valve with carb cleaner. P0031 air/fuel sensor 1 heater (B1)bank 1, p0603 engine control back up circuit,p1148 closed loop B1. Broken heater in upper O2 sensor is one if not all of your problems. Replace all of your O2 sensors & reset engine light.

Sep 01, 2015 | 2012 Nissan Altima 2.5 Sedan 2.5L 4-cyl....

2 Answers

Service engine soon light is on showed p0160 replaced an checked for bad wiring to the mas air sensor still rough idle in gear n now want to shake when it shifts into overdrive it shakes


MOST LIKELY A BAD O2 SENSOR...Potential causes of an P0160 code include: Holes in exhaust near post cat o2 sensor Bad Bank 2, position 2, o2 sensor Wiring problem, melted harness, broken connectors, etc. Bad PCM

Apr 16, 2015 | 1996 Chevrolet Suburban

1 Answer

My service engine soon light is on in my 1988 s10 pickup 5 speed with an inline 4 I have replaced the TPS, MAP sensor, spark plugs, fuel filter it was idleing to low then it was idleing high from work then...


you need to have the fault code pulled to see what is acting up. you can throw alot of time and money into a vehicle by swapping parts. from the problem you desribed it sounds as if the o2 sensor is slow to switch and cuasing fuel control problems.

Aug 05, 2011 | 1988 Chevrolet S-10

1 Answer

1998 S10 4cyl. The check engine light came on this week and the truck will not idle accelerate smoothly. Mileage per gallon went from 27 mpg to 20 mpg. Could this be a problem with the oxygen sensor?


Yes it can be. Ive had this problem acouple of times. I had to keep my foot on the gas pedal when at stop signs to. Ran rich until I replaced o2 sensor.

Nov 21, 2010 | 1998 Chevrolet S-10 Pickup

1 Answer

I have a 96 k1500 chevy truck and have 4 codes that pop up on the check engine light randomly. Codes are ckp A signal intermitent, cmp out of range, idle contol rpm to high, O2 bank 1 sensor 1 insuficent...


O2 sensor cross talk bank to bank irregular, change 02 sensor(s).

Sounds like Idle air control sensor bad, All of your codes interact, I would start with 02 sensor.

I would locate a Tech II and run a diagnosis, eliminate guess work.

Sep 29, 2010 | 1999 Chevrolet Silverado 1500

2 Answers

1987 chevy S10 engine idle problem


relace the throtle air idle valve.The temp switch will allso cause this problem.

Jul 19, 2009 | 1987 Chevrolet S-10 Pickup

2 Answers

1996 s10 2.2 engine starts but idles rough and will not rev up.


Hi! You must be frustrated by now! your code is marking that the O2 sensor is bad in bank 1. Did you replace the O2 sensor that is located  before the catalytic converter?  The S10 has an O2 sensor specially made for that cat. its about 30$ That would explain for your blackened spark plugs; your pc on the car is asking for more fuel. GOOD LUCK!!

Apr 29, 2009 | 1987 Chevrolet Blazer

1 Answer

90 chevy 5.7L k1500 failed emissions


COULD BE A VACUUM LEAK TAKE PROPANE TORCH AND LEAVE OFF PUT AROUND ALL VACUUM POINT WHERE YOU SUSPECT COULD POSSIBLY LEAK ENGINE SPEEDS UP THAT'S IT WORTH A SHOT BEFORE SPENDING MORE CASH

Nov 24, 2008 | 1990 Chevrolet K1500

2 Answers

1994 chevy blazer 4.3l feels like miss at idle only new cpi,egr,ignition.no vac leaks comp good tsb 4 crank sensor w/ spacer shim?


Just some quick checks: I'll assume you haven't received any error codes.
fuel filter,bad gas(water in the gas), indication of failing fuel pump(the 4.3 is notorious for its pump problems),dirty spark plugs, clogged fuel injectors, failed fuel injectors, MAF malfuntion(mass airflow sensor), I could go on...

anaanymous

Oct 11, 2008 | 1994 Chevrolet S-10 Blazer

1 Answer

My "service engine soon" is on...


Does it ever go off? Or is it on as soon as you turn on the vehicle?

May 17, 2008 | 2002 Ford Explorer

Not finding what you are looking for?
1994 Chevrolet S-10 Logo

769 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...